Bug 196991 - multimedia/{lib}x264: Update BUILD_DEPENDS to require yasm >= 1.2.0
Summary: multimedia/{lib}x264: Update BUILD_DEPENDS to require yasm >= 1.2.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: --- Affects Only Me
Assignee: Kubilay Kocak
URL:
Keywords: needs-qa, patch, patch-ready
Depends on:
Blocks:
 
Reported: 2015-01-22 03:16 UTC by takefu
Modified: 2015-01-27 04:39 UTC (History)
0 users

See Also:
koobs: maintainer-feedback+


Attachments
libx264.patch (416 bytes, patch)
2015-01-22 03:16 UTC, takefu
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description takefu 2015-01-22 03:16:14 UTC
Created attachment 152000 [details]
libx264.patch

# make
===>  License GPLv2 accepted by the user
===>   libx264-0.142.2455_2 depends on file: /usr/local/sbin/pkg - found
===> Fetching all distfiles required by libx264-0.142.2455_2 for building
===>  Extracting for libx264-0.142.2455_2
=> SHA256 Checksum OK for x264/x264-snapshot-20140827-2245-stable.tar.bz2.
===>  Patching for libx264-0.142.2455_2
===>  Applying FreeBSD patches for libx264-0.142.2455_2
===>   libx264-0.142.2455_2 depends on package: yasm>=0.6.0 - found
===>   libx264-0.142.2455_2 depends on executable: bash - found
===>   libx264-0.142.2455_2 depends on executable: gmake - found
===>  Configuring for libx264-0.142.2455_2
Found yasm 0.6.1.1880
Minimum version is yasm-1.2.0
If you really want to compile without asm, configure with --disable-asm.
===>  Script "configure" failed unexpectedly.
Please report the problem to koobs@FreeBSD.org [maintainer] and attach the
"/usr/ports/multimedia/libx264/work/x264-snapshot-20140827-2245-stable/config.log"
including the output of the failure of your make command. Also, it might be
a good idea to provide an overview of all packages installed on your system
(e.g. a /usr/local/sbin/pkg-static info -g -Ea).
*** Error code 1

Stop in /usr/ports/multimedia/libx264.
Comment 1 Bugzilla Automation freebsd_committer 2015-01-22 03:16:14 UTC
Auto-assigned to maintainer koobs@FreeBSD.org
Comment 2 Kubilay Kocak freebsd_committer freebsd_triage 2015-01-22 06:32:23 UTC
I will update the BUILD_DEPENDS minimum version, but I'm curious which yasm you're using? 

The one from ports (devel/yasm) is version 1.2.0. Were you just using an old one to test?
Comment 3 takefu 2015-01-22 07:13:00 UTC
(In reply to Kubilay Kocak from comment #2)


When older than devel / yasm 1.2.0, fails to build.
Of course, does not occur problem in the latest version.

% ===>   libx264-0.142.2455_2 depends on package: yasm>=0.6.0 - found

Here I pass the inspection of yasm version.
Build fails after them.
Comment 4 commit-hook freebsd_committer 2015-01-27 04:38:55 UTC
A commit references this bug:

Author: koobs
Date: Tue Jan 27 04:38:12 UTC 2015
New revision: 377978
URL: https://svnweb.freebsd.org/changeset/ports/377978

Log:
  multimedia/{lib}x264: Update minimum yasm version

  Update the minimum version of yasm required in BUILD_DEPENDS.

  PR:		196991
  Submitted by:	takefu airport.fm

Changes:
  head/multimedia/libx264/Makefile
  head/multimedia/x264/Makefile
Comment 5 Kubilay Kocak freebsd_committer freebsd_triage 2015-01-27 04:39:45 UTC
Committed with changes (added change to multimedia/x264 as well). Thank you!