Bug 201865

Summary: www/chromium: No file dialogs for saving files
Product: Ports & Packages Reporter: Tony Narlock <tony>
Component: Individual Port(s)Assignee: freebsd-chromium (Nobody) <chromium>
Status: Closed Overcome By Events    
Severity: Affects Some People CC: cpm, hayjumper, w.schwarzenfeld
Priority: --- Flags: bugzilla: maintainer-feedback? (chromium)
Version: Latest   
Hardware: Any   
OS: Any   

Description Tony Narlock 2015-07-25 02:15:29 UTC
chromium-43.0.2357.134

When trying to save an image, as an example, no file dialog pops up.

I have tried clearing out ~/.config/chromium. 

When I try to save a file, I don't get any output from 

> work/stage/usr/local/share/chromium/chrome-wrapper --gdb

when trying to save the file.  Is there anything I can try to find what may be responsible?
Comment 1 Hayjumper 2015-08-03 12:02:53 UTC
I can confirm... same version, same result... file dialog never appears when attempting to save a file.  Also affects extension downloads.
Comment 2 Tony Narlock 2015-08-03 23:46:57 UTC
Thanks for acknowledging this hayjumper.

I am cross-posting from bug #201836, during 44.0.2403.107, file dialogs were working fine.

I upgraded via ``pkg upgrade`` to 44.0.2403.125. Chromium wouldn't start.

After rebooting, chromium works now,  but now file dialogs are a no go again.
Comment 3 Hayjumper 2015-08-19 16:39:47 UTC
Quick note, upgrading to FreeBSD 10.2 seems to have fixed the following issues with newer Chromium versions (for me, at least):

1) Chromium window doesn't open when run
2) File Save dialogs don't open
3) Extensions do not install properly
Comment 4 Walter Schwarzenfeld freebsd_triage 2018-01-12 15:11:36 UTC
Version is at 61.0.3163.100. This is overcome by events.