Bug 222002

Summary: graphics/xpdf : update to 4.00
Product: Ports & Packages Reporter: Andrew Romanenko <melanhit>
Component: Individual Port(s)Assignee: Cy Schubert <cy>
Status: Closed FIXED    
Severity: Affects Many People Flags: bugzilla: maintainer-feedback? (cy)
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
xpdf-4.00.patch
none
xpdf4 none

Description Andrew Romanenko 2017-09-02 17:27:32 UTC
Created attachment 185996 [details]
xpdf-4.00.patch

Update xpdf to the latest version.

checked via portlint - all looks fine
Comment 1 Cy Schubert freebsd_committer 2017-09-02 17:49:09 UTC
This is a complete rewrite of xpdf. I will add this port as xpdf4. We can rename the old xpdf port to xpdf3 after an incubation period.
Comment 2 Cy Schubert freebsd_committer 2017-09-02 18:15:54 UTC
On one of my -CURRENT system:

[78/126] : && /usr/bin/c++  -O2 -pipe -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include -O2 -pipe -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include  -fstack-protector xpdf/CMakeFiles/xpdf_objs.dir/AcroForm.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Annot.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Array.cc.o xpdf/CMakeFiles/xpdf_objs.dir/BuiltinFont.cc.o xpdf/CMakeFiles/xpdf_objs.dir/BuiltinFontTables.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Catalog.cc.o xpdf/CMakeFiles/xpdf_objs.dir/CharCodeToUnicode.cc.o xpdf/CMakeFiles/xpdf_objs.dir/CMap.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Decrypt.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Dict.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Error.cc.o xpdf/CMakeFiles/xpdf_objs.dir/FontEncodingTables.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Form.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Function.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Gfx.cc.o xpdf/CMakeFiles/xpdf_objs.dir/GfxFont.cc.o xpdf/CMakeFiles/xpdf_objs.dir/GfxState.cc.o xpdf/CMakeFiles/xpdf_objs.dir/GlobalParams.cc.o xpdf/CMakeFiles/xpdf_objs.dir/JArithmeticDecoder.cc.o xpdf/CMakeFiles/xpdf_objs.dir/JBIG2Stream.cc.o xpdf/CMakeFiles/xpdf_objs.dir/JPXStream.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Lexer.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Link.cc.o xpdf/CMakeFiles/xpdf_objs.dir/NameToCharCode.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Object.cc.o xpdf/CMakeFiles/xpdf_objs.dir/OptionalContent.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Outline.cc.o xpdf/CMakeFiles/xpdf_objs.dir/OutputDev.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Page.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Parser.cc.o xpdf/CMakeFiles/xpdf_objs.dir/PDFDoc.cc.o xpdf/CMakeFiles/xpdf_objs.dir/PDFDocEncoding.cc.o xpdf/CMakeFiles/xpdf_objs.dir/PSTokenizer.cc.o xpdf/CMakeFiles/xpdf_objs.dir/SecurityHandler.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Stream.cc.o xpdf/CMakeFiles/xpdf_objs.dir/TextString.cc.o xpdf/CMakeFiles/xpdf_objs.dir/UnicodeMap.cc.o xpdf/CMakeFiles/xpdf_objs.dir/UnicodeTypeTable.cc.o xpdf/CMakeFiles/xpdf_objs.dir/UTF8.cc.o xpdf/CMakeFiles/xpdf_objs.dir/XFAForm.cc.o xpdf/CMakeFiles/xpdf_objs.dir/XRef.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Zoox.cc.o xpdf/CMakeFiles/pdfimages.dir/ImageOutputDev.cc.o xpdf/CMakeFiles/pdfimages.dir/pdfimages.cc.o  -o xpdf/pdfimages  goo/libgoo.a fofi/libfofi.a && :
FAILED: xpdf/pdfimages 
: && /usr/bin/c++  -O2 -pipe -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include -O2 -pipe -pipe -fstack-protector -isystem /usr/local/include -fno-strict-aliasing  -isystem /usr/local/include  -fstack-protector xpdf/CMakeFiles/xpdf_objs.dir/AcroForm.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Annot.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Array.cc.o xpdf/CMakeFiles/xpdf_objs.dir/BuiltinFont.cc.o xpdf/CMakeFiles/xpdf_objs.dir/BuiltinFontTables.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Catalog.cc.o xpdf/CMakeFiles/xpdf_objs.dir/CharCodeToUnicode.cc.o xpdf/CMakeFiles/xpdf_objs.dir/CMap.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Decrypt.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Dict.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Error.cc.o xpdf/CMakeFiles/xpdf_objs.dir/FontEncodingTables.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Form.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Function.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Gfx.cc.o xpdf/CMakeFiles/xpdf_objs.dir/GfxFont.cc.o xpdf/CMakeFiles/xpdf_objs.dir/GfxState.cc.o xpdf/CMakeFiles/xpdf_objs.dir/GlobalParams.cc.o xpdf/CMakeFiles/xpdf_objs.dir/JArithmeticDecoder.cc.o xpdf/CMakeFiles/xpdf_objs.dir/JBIG2Stream.cc.o xpdf/CMakeFiles/xpdf_objs.dir/JPXStream.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Lexer.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Link.cc.o xpdf/CMakeFiles/xpdf_objs.dir/NameToCharCode.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Object.cc.o xpdf/CMakeFiles/xpdf_objs.dir/OptionalContent.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Outline.cc.o xpdf/CMakeFiles/xpdf_objs.dir/OutputDev.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Page.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Parser.cc.o xpdf/CMakeFiles/xpdf_objs.dir/PDFDoc.cc.o xpdf/CMakeFiles/xpdf_objs.dir/PDFDocEncoding.cc.o xpdf/CMakeFiles/xpdf_objs.dir/PSTokenizer.cc.o xpdf/CMakeFiles/xpdf_objs.dir/SecurityHandler.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Stream.cc.o xpdf/CMakeFiles/xpdf_objs.dir/TextString.cc.o xpdf/CMakeFiles/xpdf_objs.dir/UnicodeMap.cc.o xpdf/CMakeFiles/xpdf_objs.dir/UnicodeTypeTable.cc.o xpdf/CMakeFiles/xpdf_objs.dir/UTF8.cc.o xpdf/CMakeFiles/xpdf_objs.dir/XFAForm.cc.o xpdf/CMakeFiles/xpdf_objs.dir/XRef.cc.o xpdf/CMakeFiles/xpdf_objs.dir/Zoox.cc.o xpdf/CMakeFiles/pdfimages.dir/ImageOutputDev.cc.o xpdf/CMakeFiles/pdfimages.dir/pdfimages.cc.o  -o xpdf/pdfimages  goo/libgoo.a fofi/libfofi.a && :
xpdf/CMakeFiles/xpdf_objs.dir/GlobalParams.cc.o: In function `GlobalParams::GlobalParams(char const*)':
/export/wrkdir/amd64/export/home/cy/freebsd/svn/ports/graphics/xpdf4/work/xpdf-4.00/xpdf/GlobalParams.cc:(.text+0xbe6): undefined reference to `paperinit'
/export/wrkdir/amd64/export/home/cy/freebsd/svn/ports/graphics/xpdf4/work/xpdf-4.00/xpdf/GlobalParams.cc:(.text+0xbeb): undefined reference to `systempapername'
/export/wrkdir/amd64/export/home/cy/freebsd/svn/ports/graphics/xpdf4/work/xpdf-4.00/xpdf/GlobalParams.cc:(.text+0xbf8): undefined reference to `paperinfo'
/export/wrkdir/amd64/export/home/cy/freebsd/svn/ports/graphics/xpdf4/work/xpdf-4.00/xpdf/GlobalParams.cc:(.text+0xc03): undefined reference to `paperpswidth'
/export/wrkdir/amd64/export/home/cy/freebsd/svn/ports/graphics/xpdf4/work/xpdf-4.00/xpdf/GlobalParams.cc:(.text+0xc14): undefined reference to `paperpsheight'
/export/wrkdir/amd64/export/home/cy/freebsd/svn/ports/graphics/xpdf4/work/xpdf-4.00/xpdf/GlobalParams.cc:(.text+0xc4a): undefined reference to `paperdone'
c++: error: linker command failed with exit code 1 (use -v to see invocation)
ninja: build stopped: subcommand failed.
*** Error code 1

Stop.
make[1]: stopped in /export/home/cy/freebsd/svn/ports/graphics/xpdf4
*** Error code 1

Stop.
make: stopped in /export/home/cy/freebsd/svn/ports/graphics/xpdf4
slippy$ 

The reason is I have print/libpaper installed on my laptop.
Comment 3 Cy Schubert freebsd_committer 2017-09-02 18:18:28 UTC
pfft. Hit enter...

We will need to add a libpaper dependency. I'll look into this.
Comment 4 Andrew Romanenko 2017-09-02 19:11:31 UTC
build fine without libpaper via poudriere, hmmm
Comment 5 Andrew Romanenko 2017-09-02 19:12:04 UTC
stable/11
Comment 6 Cy Schubert freebsd_committer 2017-09-02 20:01:29 UTC
Neither of those are the correct answer. It needs to support with and without libpaper. And, not that it's an issue but stable/10 and head also need to be supported.
Comment 7 Andrew Romanenko 2017-09-02 21:41:09 UTC
Created attachment 186007 [details]
xpdf4

renamed to graphics/xpdf4, added optional support for the libpaper
Comment 8 Cy Schubert freebsd_committer 2017-09-11 01:33:07 UTC
I prefer to  maintain maintainership. Is that OK?
Comment 9 Andrew Romanenko 2017-09-11 17:57:13 UTC
created new port graphics/xpdf4

https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=222231
Comment 10 Cy Schubert freebsd_committer 2017-09-11 19:07:21 UTC
*** Bug 222231 has been marked as a duplicate of this bug. ***
Comment 11 Cy Schubert freebsd_committer 2017-09-11 19:35:51 UTC
Still in progress.
Comment 12 commit-hook freebsd_committer 2017-09-12 19:01:21 UTC
A commit references this bug:

Author: cy
Date: Tue Sep 12 19:01:11 UTC 2017
New revision: 449702
URL: https://svnweb.freebsd.org/changeset/ports/449702

Log:
  PR/222002 initially patched graphics/xpdf to update to xpdf 4.00.
  As xpdf 4.00 introduces a brand new GUI based on QT5 rather than
  Motif, xpdf4 is being added as a new port, repocopied from
  graphics/xpdf.

  Subsequent to this commit graphics/xpdf will be renamed to xpdf3
  and a master port of graphics/xpdf (similar in concept to
  security/krb5, sysutils/cfengine and sysutils/syslog-ng) will be
  created to allow users to seamlessly update. People concerned
  with POLA will be encouraged to use the to be renamed graphics/xpdf3
  port.

  PR:		222002
  Submitted by:	Andrew Romanenko <melanhit@gmail.com>

Changes:
  head/graphics/Makefile
  head/graphics/xpdf4/
  head/graphics/xpdf4/Makefile
  head/graphics/xpdf4/distinfo
  head/graphics/xpdf4/files/patch-Makefile.in
  head/graphics/xpdf4/files/patch-cmake-config.txt
  head/graphics/xpdf4/files/patch-splash_Makefile.in
  head/graphics/xpdf4/files/patch-splash_SplashFTFont.cc
  head/graphics/xpdf4/files/patch-xfont
  head/graphics/xpdf4/files/patch-xpdf-qt_CMakeLists.txt
  head/graphics/xpdf4/files/patch-xpdf_CMakeLists.txt
  head/graphics/xpdf4/files/patch-xpdf_GlobalParams.cc
  head/graphics/xpdf4/files/patch-xpdf_GlobalParams.h
  head/graphics/xpdf4/files/patch-xpdf_Stream.cc
  head/graphics/xpdf4/files/patch-xpdf_XPDFViewer.cc
  head/graphics/xpdf4/files/patch-xpdf__Makefile.in
  head/graphics/xpdf4/files/xpdf-man.conf.in
  head/graphics/xpdf4/pkg-descr
  head/graphics/xpdf4/pkg-plist
Comment 13 commit-hook freebsd_committer 2017-09-12 19:22:39 UTC
A commit references this bug:

Author: cy
Date: Tue Sep 12 19:22:01 UTC 2017
New revision: 449705
URL: https://svnweb.freebsd.org/changeset/ports/449705

Log:
  This is the functional update of xpdf to xpdf 4.00.

  graphics/xpdf is renamed (actually copied) to xpdf3. Those who want to
  continue to use xpdf with a Motif interface can either install xpdf3 or
  set XPDF_VERSION=3 in make.conf and continue to install graphics/xpdf.
  This works around any POLA issues people might have between the
  old and the new.

  PR:		222002

Changes:
  head/graphics/Makefile
  head/graphics/xpdf/Makefile
  head/graphics/xpdf/distinfo
  head/graphics/xpdf/files/
  head/graphics/xpdf/pkg-descr
  head/graphics/xpdf/pkg-message
  head/graphics/xpdf/pkg-plist
  head/graphics/xpdf3/
Comment 14 Cy Schubert freebsd_committer 2017-09-12 19:23:27 UTC
Update is now complete. We now have the best of both worlds.
Comment 15 Cy Schubert freebsd_committer 2017-09-12 19:29:17 UTC
Thank you very much for the update. You should be able to install graphics/xpdf now to install the new port while we still allow those who still want the Motif interface to use that instead.

Once again thank you very much.