Bug 223063

Summary: devel/php-composer: Update to 1.5.2
Product: Ports & Packages Reporter: Felix Flor <freebsd>
Component: Individual Port(s)Assignee: Jochen Neumeister <joneum>
Status: Closed FIXED    
Severity: Affects Only Me CC: cyberbotx, joneum, tz
Priority: --- Flags: cyberbotx: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
New Makefile with changes
none
Update to 1.5.2 cyberbotx: maintainer-approval+

Description Felix Flor 2017-10-17 13:14:15 UTC
Created attachment 187234 [details]
New Makefile with changes

Index: Makefile
===================================================================
--- Makefile    (revision 452274)
+++ Makefile    (working copy)
@@ -2,7 +2,7 @@
 # $FreeBSD$
 
 PORTNAME=      composer
-DISTVERSION=   1.4.2
+DISTVERSION=   1.5.2
 CATEGORIES=    devel
 MASTER_SITES=  http://getcomposer.org/download/${DISTVERSION}/
 PKGNAMEPREFIX= php-
@@ -21,7 +21,7 @@
 NO_BUILD=      yes
 NO_WRKSUBDIR=  yes
 USES=          php
-USE_PHP=       intl openssl phar json ctype filter
+USE_PHP=       intl openssl phar json ctype filter mbstring
 
 PLIST_FILES=   bin/composer \
                bin/composer.phar
Index: distinfo
===================================================================
--- distinfo    (revision 452274)
+++ distinfo    (working copy)
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501420357
-SHA256 (composer-1.4.2/composer.phar) = 6b1945c3ee477f12be508a5bb41a5025d57de5510bcf94855ae6a4d59f3d86f4
-SIZE (composer-1.4.2/composer.phar) = 1838958
+TIMESTAMP = 1508245554
+SHA256 (composer-1.5.2/composer.phar) = c0a5519c768ef854913206d45bd360efc2eb4a3e6eb1e1c7d0a4b5e0d3bbb31f
+SIZE (composer-1.5.2/composer.phar) = 1852323
Comment 1 Naram Qashat 2017-10-17 16:37:44 UTC
Please submit an actual patch for an attachment, not the full Makefile. I'm pretty sure that a committer would not want to deal with the above. Otherwise, this looks fine.
Comment 2 Jochen Neumeister freebsd_committer 2017-10-17 16:42:59 UTC
Hi eqvvs :-) 

what is the reason to add "mbstring"? Is there a reason for this?

Is there a link for a changelog?
Comment 4 Felix Flor 2017-10-18 07:24:56 UTC
@Naram Qashat:

Aloha Naram,

i'm sorry, its my first patch for feebsd i ever done. i will upload a secound attachment like the description. 

@Jochen Neumeister:

Aloha Jochen,

i installed the php-composer from ports with pkg and with make. in both cases, if i try to use composer, i get an fatal error that tells me the mbstring is missing. after i installed mbsting i worked fine. So i thought it make sense ;)

In the changelog on composer nothing is written about mbsting.
Comment 5 Felix Flor 2017-10-18 07:25:41 UTC
Created attachment 187263 [details]
Update to 1.5.2
Comment 6 Torsten Zuehlsdorff freebsd_committer 2017-10-18 08:00:19 UTC
*** Bug 223062 has been marked as a duplicate of this bug. ***
Comment 7 Torsten Zuehlsdorff freebsd_committer 2017-10-18 08:01:45 UTC
@eqvvs
Please obsolete the wrong Patch / Makefile to avoid confusions.

@Jochen
The Patch is approved by me. No need for a Diff Review. I entrust the correct commit message to you ;)
Comment 8 Felix Flor 2017-10-18 08:12:33 UTC
@Torsten Zuehlsdorff
done
Comment 9 Jochen Neumeister freebsd_committer 2017-10-18 08:18:19 UTC
(In reply to Torsten Zuehlsdorff from comment #7)

Ups, i read this too late. There is now a open review, sorry.
Comment 10 commit-hook freebsd_committer 2017-10-18 08:39:49 UTC
A commit references this bug:

Author: joneum
Date: Wed Oct 18 08:39:34 UTC 2017
New revision: 452320
URL: https://svnweb.freebsd.org/changeset/ports/452320

Log:
  devel/php-composer: Update from 1.4.2 to 1.5.2

  -Changelog:
    https://github.com/composer/composer/releases/tag/1.4.3
    https://github.com/composer/composer/releases/tag/1.5.0
    https://github.com/composer/composer/releases/tag/1.5.1
    https://github.com/composer/composer/releases/tag/1.5.2

  Add missing mbstring module to avoid fatal PHP error

  PR:		223063
  Reported by:	eqvvs <freebsd@flornet.de>
  Approved by:	Naram Qashat <cyverbotx@cyberbotx.com> (maintainer), tz (mentor)
  MFH:	2017Q4
  Differential Revision:	https://reviews.freebsd.org/D12711

Changes:
  head/devel/php-composer/Makefile
  head/devel/php-composer/distinfo
Comment 11 Jochen Neumeister freebsd_committer 2017-10-18 08:42:03 UTC
Committed, thanks :-)
Now i am waiting for the MFH 2017Q4 approval
Comment 12 commit-hook freebsd_committer 2017-10-25 10:13:17 UTC
A commit references this bug:

Author: joneum
Date: Wed Oct 25 10:12:26 UTC 2017
New revision: 452839
URL: https://svnweb.freebsd.org/changeset/ports/452839

Log:
  MFH: r452320

  devel/php-composer: Update from 1.4.2 to 1.5.2

  -Changelog:
    https://github.com/composer/composer/releases/tag/1.4.3
    https://github.com/composer/composer/releases/tag/1.5.0
    https://github.com/composer/composer/releases/tag/1.5.1
    https://github.com/composer/composer/releases/tag/1.5.2

  Add missing mbstring module to avoid fatal PHP error

  PR:		223063
  Reported by:	eqvvs <freebsd@flornet.de>
  Approved by:	Naram Qashat <cyverbotx@cyberbotx.com> (maintainer), tz (mentor)
  Differential Revision:	https://reviews.freebsd.org/D12711

  Approved by:	ports-secteam (swills)

Changes:
_U  branches/2017Q4/
  branches/2017Q4/devel/php-composer/Makefile
  branches/2017Q4/devel/php-composer/distinfo