Bug 226160

Summary: www/wt: Please update to 4.0.2
Product: Ports & Packages Reporter: Yuri Victorovich <yuri>
Component: Individual Port(s)Assignee: Rene Ladan <rene>
Status: Closed FIXED    
Severity: Affects Only Me CC: 0mp, info, rene, w.schwarzenfeld
Priority: --- Flags: info: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 224183    
Attachments:
Description Flags
wt 3.3.7_6 to 3.3.9 patch file
info: maintainer-approval+
wt3 3.3.9 shar file
info: maintainer-approval+
www/wt3: version 3.3.9 in a branch
info: maintainer-approval+
www/wt 4.0.2 shar file
info: maintainer-approval+
Updated version 4.0.2
none
wt3 v3.3.11 shar file
info: maintainer-approval+
www/wt3 v3.3.11 shar file with some improvements
info: maintainer-approval+
wt3 v3.3.12 shar file
info: maintainer-approval+
Latest www/wt3 (v3.4.0) shar file
info: maintainer-approval+
Latest www/wt (v4.1.0) shar file info: maintainer-approval+

Description Yuri Victorovich freebsd_committer 2018-02-24 10:17:06 UTC
Version 4.0.2 is available here https://www.webtoolkit.eu/wt/download

Previous stalled bug with a patch for the older version: bug#210750
Comment 1 Walter Schwarzenfeld freebsd_triage 2018-02-24 11:15:23 UTC
see also Bug #224183.
Comment 2 Mateusz Piotrowski freebsd_committer 2018-02-27 21:24:21 UTC
I'll try to see if I can update this port to 4.0.2.
Comment 3 Mohammad S. Babaei 2018-02-28 17:02:17 UTC
I'm the maintainer. Been away for some time. I believe we should maintain two version of this port since 3.x and 4.x are not compatible at all and it will break currently working apps. In my estimation, the current port could be moved to www/wt3 and we could create a new one (www/wt) for the 4.x branch.

If that's ok with you I could start working on both ports shortly. I already have a working 3.3.9 port which did not submit due to the mentioned bug with poudriere in bug 222920 which I couldn't reproduce since I did not have poudriere installed.

And I should also mention bug 210750 is not applicable anymore and could be closed. I haven't look into bug 224183 for some time, but I believe I could fix that.
Comment 4 Yuri Victorovich freebsd_committer 2018-02-28 18:32:03 UTC
(In reply to Mohammad S. Babaei from comment #3)

Ok, just submit the shar of the new version, and I will take it from there.

Thank you!
Yuri
Comment 5 Mateusz Piotrowski freebsd_committer 2018-02-28 18:41:32 UTC
(In reply to Mohammad S. Babaei from comment #3)
Sure, I'll focus on other things then. Thanks!
Comment 6 Mohammad S. Babaei 2018-03-01 13:26:32 UTC
(In reply to Mateusz Piotrowski from comment #5)

You're welcome!
Comment 7 Mohammad S. Babaei 2018-03-01 13:30:51 UTC
(In reply to Yuri Victorovich from comment #4)

At the moment I'm installing FreeBSD on VirtualBox (since I do not have FreeBSD installed on my current PC) in order to test and fix the 3.9.9 port for boost-1.66.0 as describe by Bug 224183. Once that done I'll submit the www/wt3 for the latest 3.x version. After that I'll go for the 4.x port.
Comment 8 Yuri Victorovich freebsd_committer 2018-03-01 18:41:28 UTC
(In reply to Mohammad S. Babaei from comment #7)

Sounds like a good plan! :)

Yuri
Comment 9 Mohammad S. Babaei 2018-03-01 20:21:48 UTC
I spent some time on Bug 224183 and since there were many errors, heavely patched 3.3.9 in order to make it work with boost-1.66.0. It should now build with both older and newer boost versions.

I ran the following checks with both default options and all options selected and it passed them all successfully:

    make stage

    make stage-qa

    make check-orphans

    make package

    make install

    make deinstall

    make clean

Just a few notes:

1. I'll a attach a patch which renames the current www/wt to www/wt3 in order to make room for wt 4.x (this probably should be mentioned in /usr/ports/UPDATING).

2. I'll also attach a shar file (in case you need it)

3. The configuration file location has changed from /usr/local/etc/wt/wt_config.xml to /usr/local/etc/wt3/wt_config.xml in order to avoid future conflicts with 4.x version. I mentioned this inside a pkg-message file. It could be added to /usr/ports/UPDATING.

4. I did not ran Poudriere on the port (since I haven't set it up yet) in order to see if Bug 222920 still affects the port.

5. Bug 224183 can be closed now.

I'll attach the files shortly. Please let me know if there are any issues with the port.

Thank you!
Comment 10 Mohammad S. Babaei 2018-03-01 20:22:53 UTC
Created attachment 191113 [details]
wt 3.3.7_6 to 3.3.9 patch file
Comment 11 Mohammad S. Babaei 2018-03-01 20:23:49 UTC
Created attachment 191114 [details]
wt3 3.3.9 shar file
Comment 12 Mohammad S. Babaei 2018-03-02 17:46:07 UTC
Created attachment 191144 [details]
www/wt3: version 3.3.9 in a branch

Since I found two minor issues in the submitted 3.x port, I'll makr the previously submited port as obsolete. This is the shar file, let me know if you need a patch.
Comment 13 Mohammad S. Babaei 2018-03-02 17:48:06 UTC
Created attachment 191145 [details]
www/wt 4.0.2 shar file

Here's also the shar file for the 4.0.2 port. For the sake of simplicity I also submit a shar file instead of a patch. Let me know if you need a patch for this one too.
Comment 14 Yuri Victorovich freebsd_committer 2018-03-10 20:25:14 UTC
*** Bug 222920 has been marked as a duplicate of this bug. ***
Comment 15 Mohammad S. Babaei 2018-04-06 23:02:09 UTC
Any updates on when the submitted changes appear in Ports? I myself rely on them so it's good to know of an estimation.

Thank you!
Comment 16 Yuri Victorovich freebsd_committer 2018-04-07 07:45:20 UTC
(In reply to Mohammad S. Babaei from comment #15)

Hi Mohammad,

Sorry for the delay.
The 4.0.2 version required some changes. I will be done with making and testing them within a few days.

Have a great weekend!
Yuri
Comment 17 Yuri Victorovich freebsd_committer 2018-04-07 21:03:30 UTC
Created attachment 192318 [details]
Updated version 4.0.2

I converted most .if/.endif statements to helpers, and made some other simplifications.

Now there is one problem with DOXYGEN=on, after fixing which this can be committed.
Comment 18 Mohammad S. Babaei 2018-04-08 22:24:08 UTC
Thank you so much for the update!
Comment 19 Mohammad S. Babaei 2018-06-11 12:26:57 UTC
Sorry for poking this issue again. But, I receive this email every other week from bugzilla-noreply@FreeBSD.org:

> The following is a listing of current problems submitted by FreeBSD users,
> which need special attention. These represent problem reports covering
> all versions including experimental development code and obsolete releases.
> 
> Status      |    Bug Id | Description
> ------------+-----------+---------------------------------------------------
> New         |    224183 | www/wt: fails to build with boost 1.66
> In Progress |    226160 | www/wt: Please update to 4.0.2
> 
> 2 problems total for which you should take action.

So, I wonder what is the barrier here, since this was an official port already and not a new port. I've seen this happen with new ports, but, none of my previous updates for the ports I maintain took this long to get updated. Is there something I can do to make this process faster? I would be happy to help since I'm waiting for these ports myself.
Comment 20 Yuri Victorovich freebsd_committer 2018-08-25 20:10:33 UTC
I'll look into this this week.
Comment 21 Mohammad S. Babaei 2018-09-02 17:36:22 UTC
(In reply to Yuri Victorovich from comment #20)

I see 'DEPRECATED= Broken for more than 5 months' and 'EXPIRATION_DATE= 2018-08-20' set on the on port https://svnweb.freebsd.org/ports/head/www/wt/Makefile?revision=476723&view=markup 

Does this mean it has been marked for removal since the expiration date is overdue?
Comment 22 Rene Ladan freebsd_committer 2018-09-02 17:38:25 UTC
Yes, but Yuri is looking into fixing the port.
Comment 23 Mohammad S. Babaei 2018-09-03 11:38:23 UTC
OK, I see there are new upstream updates (3.3.11 for 3.x branch and 4.0.4 for 4.x branch). Since Yuri has made some modifications to fix the original port, then I guess I should wait for his part to gets done. Then, I'll pick that up and update to the latest releases for each branch on top of his work in order to avoid redundant work.
Comment 24 Mohammad S. Babaei 2018-09-12 16:44:53 UTC
Created attachment 197058 [details]
wt3 v3.3.11 shar file

OK, since I haven't heard back from Yuri and I had some extra time some I decided to port over version 3.3.11 for www/wt3. So, I'll mark the 3.3.9 port as obsolete.

Soon I'll try the same with www/wt and try to update it to v4.0.4.
Comment 25 Mohammad S. Babaei 2018-09-12 17:21:54 UTC
Created attachment 197059 [details]
www/wt3 v3.3.11 shar file with some improvements
Comment 26 Mohammad S. Babaei 2019-03-06 12:38:41 UTC
Created attachment 202648 [details]
wt3 v3.3.12 shar file

I am not sure why this issue has been blocked. Anyway, here is the updated port for www/wt3-3.3.12 which I am using in production. If there is still interest let me know to update www/wt to 4.0.5.
Comment 27 Rene Ladan freebsd_committer 2019-08-12 18:42:30 UTC
Yuri and Mohammad, can we clear up this PR and PR 224183? They have been dragging on for way too long now. So:

- update www/wt to 4.something
- create www/wt3 at 3.3.12

Note that boost is currently at version 1.70, so 224183 is pretty much useless by now.

Two weeks timeout.
Comment 28 Mohammad S. Babaei 2019-08-12 23:32:28 UTC
Thank you so much for attending this. Sure, I'll try to update to the latest from each branch (3.4.0 and 4.0.5) and get back to you soon.
Comment 29 Mohammad S. Babaei 2019-08-13 19:33:25 UTC
Created attachment 206503 [details]
Latest www/wt3 (v3.4.0) shar file
Comment 30 Mohammad S. Babaei 2019-08-13 19:34:06 UTC
Created attachment 206504 [details]
Latest www/wt (v4.1.0) shar file
Comment 31 Mohammad S. Babaei 2019-08-13 19:35:25 UTC
Here are the latest working ports. They successfully pass the following tests with the default or all options:

    make stage

    make stage-qa

    make check-orphans

    make package

    make install

    make deinstall

    make clean
Comment 32 Rene Ladan freebsd_committer 2019-08-13 19:47:32 UTC
(In reply to Mohammad S. Babaei from comment #31)
Thanks, I'll look at the patches.
Comment 33 Mohammad S. Babaei 2019-08-13 21:49:46 UTC
(In reply to Rene Ladan from comment #32)
Thanks!
Comment 34 commit-hook freebsd_committer 2019-08-18 18:42:39 UTC
A commit references this bug:

Author: rene
Date: Sun Aug 18 18:42:33 UTC 2019
New revision: 509235
URL: https://svnweb.freebsd.org/changeset/ports/509235

Log:
  Fix and update wwww/wt to version 4.1.0.

  Minor corrections from me.

  PR:		226160
  Submitted by:	maintainer
  MFH:		2019Q3

Changes:
  head/www/wt/Makefile
  head/www/wt/distinfo
  head/www/wt/files/patch-CMakeLists.txt
  head/www/wt/pkg-plist
Comment 35 Rene Ladan freebsd_committer 2019-08-18 18:44:37 UTC
I committed the two ports with some minor fixes, thanks for the patches.
Comment 36 commit-hook freebsd_committer 2019-08-18 18:44:41 UTC
A commit references this bug:

Author: rene
Date: Sun Aug 18 18:43:57 UTC 2019
New revision: 509236
URL: https://svnweb.freebsd.org/changeset/ports/509236

Log:
  Fix, repocopy and update www/wt to version 3.4.0 as wwww/wt3

  PR:		226160
  Submitted by:	maintainer

Changes:
  head/www/wt3/
  head/www/wt3/Makefile
  head/www/wt3/distinfo
  head/www/wt3/files/patch-CMakeLists.txt
  head/www/wt3/files/patch-examples_te-benchmark_benchmark.cpp
  head/www/wt3/pkg-message
  head/www/wt3/pkg-plist
Comment 37 Mohammad S. Babaei 2019-08-18 23:08:53 UTC
Thank you so much!
Comment 38 commit-hook freebsd_committer 2019-08-19 09:36:01 UTC
A commit references this bug:

Author: rene
Date: Mon Aug 19 09:35:45 UTC 2019
New revision: 509265
URL: https://svnweb.freebsd.org/changeset/ports/509265

Log:
  MFH: r509235

  Fix and update www/wt to version 4.1.0.

  Minor corrections from me.

  PR:		226160
  Submitted by:	maintainer

  Approved by:	ports-secteam (joneum)

Changes:
_U  branches/2019Q3/
  branches/2019Q3/www/wt/Makefile
  branches/2019Q3/www/wt/distinfo
  branches/2019Q3/www/wt/files/patch-CMakeLists.txt
  branches/2019Q3/www/wt/pkg-plist