Bug 229146

Summary: ports-mgmt/pkg "alias" section for pkg(8) should mention e.g. prime-(list|origins)
Product: Ports & Packages Reporter: Harald Schmalzbauer <bugzilla.freebsd>
Component: Individual Port(s)Assignee: freebsd-pkg (Nobody) <pkg>
Status: Closed Not A Bug    
Severity: Affects Only Me CC: doug
Priority: --- Flags: bugzilla: maintainer-feedback? (pkg)
Version: Latest   
Hardware: Any   
OS: Any   

Description Harald Schmalzbauer 2018-06-19 09:33:22 UTC
Accidentally I found the 'prime-list' and 'prime-origins' aliases _today_.

I've quiet often looked at the man page during the evolution of pkg(8) to see if there's an aequivalent of 'portmaster --list-origins', which was mandatory for me at pkg_legacy times.

"alias" is only mentioned once for pkg(8), without telling that there are predefined aliases available, which feature not only simple synonyms, but extended functionality by providing "pkg query" makros e.g.

Please add a sentence like above to encourage the user to have a look at "alias".
And I vote for listing at least the most widely useful example aliases, which I think 'prime-list' definitely belongs to.

Thanks,

-harry
Comment 1 Guangyuan Yang freebsd_committer 2021-01-03 18:19:15 UTC
*** Bug 252387 has been marked as a duplicate of this bug. ***
Comment 2 Baptiste Daroussin freebsd_committer 2021-08-17 16:58:23 UTC
Those are examples provided by the sample pkg.conf imho that should not be part of the manpages.