Bug 230836

Summary: databases/xtrabackup does not build in 2018Q3
Product: Ports & Packages Reporter: rainer
Component: Individual Port(s)Assignee: Kurt Jaeger <pi>
Status: Closed FIXED    
Severity: Affects Some People CC: aleks, bagas1983, ddrinnon, pi, sergey
Priority: --- Flags: pi: maintainer-feedback-
pi: merge-quarterly+
Version: Latest   
Hardware: amd64   
OS: Any   
Attachments:
Description Flags
xtrabackup poudriere build log
none
xtrabackup-llvm60-fix.patch sergey: maintainer-approval? (aleks)

Description rainer 2018-08-23 07:17:13 UTC
Created attachment 196467 [details]
xtrabackup poudriere build log

See attached poudriere build log.

11_2-amd64, 2018Q3 as of yesterday.
It did build at the beginning of August, according to my build-logs.

So, something between then and now must have broken it.
Comment 1 Sergey Akhmatov 2018-08-27 17:04:08 UTC
Created attachment 196604 [details]
xtrabackup-llvm60-fix.patch

Fixes build with llvm6
Upstream: https://github.com/percona/percona-xtrabackup/commit/09069e9ee8f84df0ba3091f591b9269842e71503#diff-765605c50b26c5ee91da8227ac1093b2
Comment 2 Sergey Akhmatov 2018-08-27 17:08:27 UTC
(In reply to rainer from comment #0)
It seems to be broken with llvm60 due to more strict c++.
Could you test port build with the attached patch?

Patch origin is upstream: https://github.com/percona/percona-xtrabackup/commit/09069e9ee8f84df0ba3091f591b9269842e71503#diff-765605c50b26c5ee91da8227ac1093b2

It haven't made it to release yet.
Comment 3 ddrinnon 2018-08-27 19:08:00 UTC
I was able to build the port after applying the patch and ran a test db backup with the program with no issues.
Comment 4 rainer 2018-10-01 10:23:33 UTC
Can someone commit this and MFH to 2018Q4?
Comment 5 Walter Schwarzenfeld freebsd_triage 2018-10-06 21:20:08 UTC
*** Bug 231943 has been marked as a duplicate of this bug. ***
Comment 6 Kurt Jaeger freebsd_committer 2018-10-22 12:48:40 UTC
testbuilds@work
Comment 7 commit-hook freebsd_committer 2018-10-22 16:41:16 UTC
A commit references this bug:

Author: pi
Date: Mon Oct 22 16:40:58 UTC 2018
New revision: 482753
URL: https://svnweb.freebsd.org/changeset/ports/482753

Log:
  databases/xtrabackup: fix build due to stricter llvm60 c++

  PR:		230836
  Submitted by:	Sergey Akhmatov <sergey@akhmatov.ru>
  Reported by:	rainer@ultra-secure.de
  Reviewed by:	ddrinnon@cdor.net,
  Approved by:	aleks@twindb.com (maintainer timeout)
  Obtained from:	https://github.com/percona/percona-xtrabackup/commit/09069e9ee8f84df0ba3091f591b9269842e71503#diff-765605c50b26c5ee91da8227ac1093b2
  MFH:		2018Q4

Changes:
  head/databases/xtrabackup/files/patch-plugin_keyring_common_system__keys__container.cc
  head/databases/xtrabackup/files/patch-storage_innobase_row_row0sel.cc
Comment 8 commit-hook freebsd_committer 2018-10-22 16:44:25 UTC
A commit references this bug:

Author: pi
Date: Mon Oct 22 16:43:38 UTC 2018
New revision: 482756
URL: https://svnweb.freebsd.org/changeset/ports/482756

Log:
  MFH: r482753

  databases/xtrabackup: fix build due to stricter llvm60 c++

  PR:		230836
  Submitted by:	Sergey Akhmatov <sergey@akhmatov.ru>
  Reported by:	rainer@ultra-secure.de
  Reviewed by:	ddrinnon@cdor.net,
  Approved by:	aleks@twindb.com (maintainer timeout)
  Obtained from:	https://github.com/percona/percona-xtrabackup/commit/09069e9ee8f84df0ba3091f591b9269842e71503#diff-765605c50b26c5ee91da8227ac1093b2
  Approved by:	portmgr (unbreak blanket approval)

Changes:
_U  branches/2018Q4/
  branches/2018Q4/databases/xtrabackup/files/patch-plugin_keyring_common_system__keys__container.cc
  branches/2018Q4/databases/xtrabackup/files/patch-storage_innobase_row_row0sel.cc
Comment 9 Kurt Jaeger freebsd_committer 2018-10-22 16:45:30 UTC
Committed, thanks!