Bug 233698

Summary: x11-toolkits/fltk-devel: fix build with GCC-based architectures
Product: Ports & Packages Reporter: Piotr Kubaj <pkubaj>
Component: Individual Port(s)Assignee: Koichiro Iwao <meta>
Status: Closed DUPLICATE    
Severity: Affects Only Me CC: meta
Priority: ---    
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
patch none

Description Piotr Kubaj freebsd_committer 2018-12-01 20:10:17 UTC
Created attachment 199721 [details]
patch

-Wno-c++11-narrowing is not supported by base GCC, set USE_CXXSTD=c++98 instead.

While here, add USES=gl localbase:ldflags.

Tested on powerpc64 and amd64.

Hardware sponsored by IntegriCloud.
Comment 1 Koichiro Iwao freebsd_committer 2019-02-14 03:55:23 UTC

*** This bug has been marked as a duplicate of bug 234928 ***