Bug 239709

Summary: net-mgmt/flow-tools: Fix build with OpenSSL 1.1.x
Product: Ports & Packages Reporter: Krzysztof <ports>
Component: Individual Port(s)Assignee: Muhammad Moinur Rahman <bofh>
Status: Closed FIXED    
Severity: Affects Some People Keywords: easy, needs-qa
Priority: --- Flags: bugzilla: maintainer-feedback? (bofh)
koobs: merge-quarterly?
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 228865    
Attachments:
Description Flags
flow-tools patch for openssl 1.1.x none

Description Krzysztof 2019-08-08 08:25:53 UTC
Created attachment 206356 [details]
flow-tools patch for openssl 1.1.x

After upgrade base system to 12.0 flow-tools does not compile because of openssl 1.1.x (in base).

I've found patch which was published on gihub (pld linux project) - https://github.com/pld-linux/flow-tools/blob/master/openssl.patch

I've applied this patch to port. Everything is working good. Portlint does not complain. poudriere returns no errors.

I hope it will be applied soon.
Comment 1 commit-hook freebsd_committer 2019-09-03 21:53:53 UTC
A commit references this bug:

Author: bofh
Date: Tue Sep  3 21:53:48 UTC 2019
New revision: 511046
URL: https://svnweb.freebsd.org/changeset/ports/511046

Log:
  net-mgmt/flow-tools: Fix build with OpenSSL 1.1.x

  PR:		239709
  Submitted by:	ports@bsdserwis.com

Changes:
  head/net-mgmt/flow-tools/Makefile
  head/net-mgmt/flow-tools/files/patch-lib_ftxlate.c