Bug 242263

Summary: devel/py-envisage: Update to 4.9.0
Product: Ports & Packages Reporter: vladimir.chukharev
Component: Individual Port(s)Assignee: Tobias C. Berner <tcberner>
Status: Closed FIXED    
Severity: Affects Only Me CC: tcberner
Priority: --- Keywords: buildisok
Version: Latest   
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Patch vladimir.chukharev: maintainer-approval+

Description vladimir.chukharev 2019-11-27 07:14:31 UTC
Update devel/py-envisage from 4.8.0 to 4.8.0.

Release notes: https://github.com/enthought/envisage/releases/tag/4.9.0

QA:
portlint : OK
port test : OK
poudriere : OK (py36, 12Ramd64)
make test : OK

make test in 'poudriere -i': fails with the following messages (seemingly related to bug 214340, an update of the mentioned ports did not help, yet).

qt.qpa.xcb: could not connect to display
qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.

Available platform plugins are: bsdfb, minimal, offscreen, vnc, xcb.

*** Signal 6

Stop.
make: stopped in /usr/ports/devel/py-envisage
Comment 1 vladimir.chukharev 2019-11-27 07:15:29 UTC
Created attachment 209472 [details]
Patch
Comment 2 Automation User 2019-11-27 17:28:51 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/98855736
Comment 3 Tobias C. Berner freebsd_committer 2019-12-08 15:14:43 UTC
Committed. Thanks.
Comment 4 commit-hook freebsd_committer 2019-12-08 15:14:46 UTC
A commit references this bug:

Author: tcberner
Date: Sun Dec  8 15:14:35 UTC 2019
New revision: 519307
URL: https://svnweb.freebsd.org/changeset/ports/519307

Log:
  devel/py-envisage: Update to 4.9.0

  PR:		242263
  Submitted by:	vladimir.chukharev@gmail.com (maintainer)

Changes:
  head/devel/py-envisage/Makefile
  head/devel/py-envisage/distinfo