Bug 244116

Summary: sysutils/getssl: Update 2.19
Product: Ports & Packages Reporter: MIHIRA Sanpei Yoshiro <sanpei>
Component: Individual Port(s)Assignee: Emanuel Haupt <ehaupt>
Status: Closed FIXED    
Severity: Affects Only Me CC: ehaupt, rainbow
Priority: --- Keywords: buildisok
Version: LatestFlags: bugzilla: maintainer-feedback? (rainbow)
Hardware: Any   
OS: Any   
Attachments:
Description Flags
Patch to update to 2.19
none
Proposed patch for 2.20 none

Description MIHIRA Sanpei Yoshiro freebsd_committer 2020-02-14 05:31:25 UTC
Created attachment 211635 [details]
Patch to update to 2.19

Update to 2.19

2.15
 * issue #453 and #454 Add User-Agent to all curl requests
 * issue #456 Fix shellcheck issues
 * issue #459 Fix missing chain.crt
 * issue #462 Use POST-as-GET for ACMEv2 endpoints
 * issue #464 and #486 "json was blank" (change all curl request to use POST-as-GET)
 * Error and exit if rate limited, exit if curl returns nothing
 * Change domain and getssl templates to v2

2.16
 * issue #473 and #477 Don't use POST-as-GET when sending ready for challenge for ACMEv1

2.17
 * issue #475 and #483 Fix grep regex for >9 subdomains in json_get
 * Add support for CloudDNS
 * allow file transfer using WebDAV over HTTPS
 * Use urlbase64_decode() instead of base64 -d
 * Fix "already verified" error for ACMEv2
 * Check awk new enough to support json_awk
 * Fix epoch_date for busybox
 * Bugfixes for json_awk and nslookup to support old awk versions

2.18
 * Add SCP_OPTS and SFTP_OPTS
 * Fix for DUAL_RSA_ECDSA not working with ACMEv2 (#334, #474, #502)
 * Fix #424 - Sporadic "error in EC signing couldn't get R from ..."

2.19
 * Fix "Registration key already in use" (2.19)
Comment 1 MIHIRA Sanpei Yoshiro freebsd_committer 2020-02-14 05:33:44 UTC
*** Bug 243728 has been marked as a duplicate of this bug. ***
Comment 2 Automation User 2020-02-14 05:54:07 UTC
Build info is available at https://gitlab.com/swills/freebsd-ports/pipelines/117825520
Comment 3 Emanuel Haupt freebsd_committer 2020-02-24 18:43:19 UTC
Meanwhile 2.20 is out. Any objections for updating it directly to 2.20?
Comment 4 Emanuel Haupt freebsd_committer 2020-02-24 18:45:22 UTC
Created attachment 211906 [details]
Proposed patch for 2.20
Comment 5 commit-hook freebsd_committer 2020-04-18 10:01:02 UTC
A commit references this bug:

Author: ehaupt
Date: Sat Apr 18 10:00:10 UTC 2020
New revision: 532015
URL: https://svnweb.freebsd.org/changeset/ports/532015

Log:
  Update to 2.22

  PR:		244116
  Submitted by:	sanpei
  Approved by:	maintainer timeout (rainbow@sanitylinux.org; 63 days)

Changes:
  head/sysutils/getssl/Makefile
  head/sysutils/getssl/distinfo
Comment 6 Emanuel Haupt freebsd_committer 2020-04-18 10:02:08 UTC
Committed an update to the most recent version 2.22. Thanks!