Bug 249678

Summary: editors/atom: depends on python 2.x
Product: Ports & Packages Reporter: Steve Wills <swills>
Component: Individual Port(s)Assignee: Hiroki Tagato <tagattie>
Status: New ---    
Severity: Affects Only Me CC: break19
Priority: --- Flags: bugzilla: maintainer-feedback? (tagattie)
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 249337    

Description Steve Wills freebsd_committer 2020-09-24 16:26:35 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 break19 2020-10-17 12:43:16 UTC
It's also a bit out of date.

1.52 is released and wants electron 6 rather than 5.

it also can be compiled with python 3.x on linux at least. my opensuse box has it built with python3.8 for example.

however, the code seems to be full of linuxisms and will likely require many patches to build here. It's a shame, as it's my favorite IDE.