Bug 249756

Summary: science/gnudatalanguage: depends on python 2.x
Product: Ports & Packages Reporter: Steve Wills <swills>
Component: Individual Port(s)Assignee: Thierry Thomas <thierry>
Status: Closed FIXED    
Severity: Affects Only Me CC: rene
Priority: --- Flags: thierry: maintainer-feedback+
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 249337    

Description Steve Wills freebsd_committer 2020-09-24 16:34:22 UTC
This port will be removed on 2020-12-31 if not fixed
Comment 1 Thierry Thomas freebsd_committer 2020-09-24 17:18:55 UTC
You're right, and upstream knows the situation (same thing on many Linux distros).
They are working on gdl-v1.0.0, which will depend on Python 3.x.

v1.0.0-rc.3 has been out since June 19, but there remains some caveats:
https://github.com/gnudatalanguage/gdl/issues
Comment 2 Rene Ladan freebsd_committer 2021-01-01 16:49:23 UTC
Switched to Python 3.6+ (commented out) in r557839