Bug 229240

Summary: www/otrs: Missing p5-DateTime and p5-XML-LibXML-Simple dependencies
Product: Ports & Packages Reporter: Peter <fbsdq>
Component: Individual Port(s)Assignee: freebsd-ports-bugs mailing list <ports-bugs>
Status: Closed FIXED    
Severity: Affects Some People CC: cs, m.tsatsenko, nikita, ohartmann
Priority: --- Keywords: needs-patch
Version: LatestFlags: bugzilla: maintainer-feedback? (m.tsatsenko)
koobs: merge-quarterly?
Hardware: Any   
OS: Any   
Attachments:
Description Flags
the patch m.tsatsenko: maintainer-approval+

Description Peter 2018-06-22 20:59:04 UTC
Hello,
  I had build otrs via poudriere [ otrs-6.0.6_1 ], installed it via pkg install and when I went to run './scripts/DBUpdate-to-6.pl' it complained about me missing DateTime.pm, and XML/LibXML/Simple.pm

I ran:
pkg install p5-DateTime
pkg install p5-XML-LibXML-Simple

and the DBUpdate script ran fine without error.

devel/p5-DateTime
textproc/p5-XML-LibXML-Simple

These don't seem like they fixed the issue all the way:
  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=227924
  https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=228106

Thanks for your work!
Comment 1 Peter 2018-06-25 04:22:44 UTC
Also, mail processing was failing.
Can't locate Class/Accessor/Lite.pm in @INC (you may need to install the Class::Accessor::Lite module) 

pkg install p5-Class-Accessor-Lite-0.08 resolved the issue.

devel/p5-Class-Accessor-Lite
Comment 2 m.tsatsenko 2018-06-27 22:57:59 UTC
Hello.
Thanks for reporting this. I will handle it along with next port upgrade.
Comment 3 m.tsatsenko 2018-08-30 23:12:49 UTC
Please try patch from bug #231040
Comment 4 O. Hartmann 2018-10-30 12:51:12 UTC
On 11-STABLE, 11.2-RELENG-p4, 12-BETA2 and 13-CURRENT as of today this issue is still present (build with most recent ports tree and poudriere). Obviously, installing OTRS fails to initialize due to the lack of, at least, textproc/p5-XML-LibXML-Simple.
Comment 5 O. Hartmann 2018-10-30 12:54:01 UTC
*** Bug 232523 has been marked as a duplicate of this bug. ***
Comment 6 Peter 2018-11-19 21:14:52 UTC
Yep, just installed it and I was missing the several perl modules which are required for otrs to functions.
Comment 7 Kubilay Kocak freebsd_committer freebsd_triage 2018-11-20 03:04:30 UTC
To progress, this issue needs:

1) A definitive and complete list of missing dependencies as of the latest port version.
2) Details the failures (feature, error) when these dependencies are missing
3) Confirmation that when only the dependencies from (1) are installed, all errors from (2) are resolved

@m.tsatsenko Bugfixes should always be addressed separately from version updates so that the fixes they can be merged to the quarterly branches, which shouldn't receive version updates in the default case.
Comment 8 Peter 2018-11-28 13:41:35 UTC
Fresh jail, installing from poudriere [using postgresql instead of mysql]:

can't even get past otrs/installer.pl
Kernel::System::XML::Simple could not be loaded:

pkg install p5-XML-LibXML-Simple-0.95

Trying to get emails:
Message: Can't locate Class/Accessor/Lite.pm in @INC (you may need to install the Class::Accessor::Lite module)

On a fresh install, the following are still missing:
textproc/p5-XML-LibXML-Simple
devel/p5-Class-Accessor-Lite

those are still missing when I do an install from FreeBSD.org packages with mysql - but did not test beyond that with mysql.
Comment 9 m.tsatsenko 2018-12-07 22:37:53 UTC
I had a look at both of the missing modules.

XML was an easy one. According to checkModules.pl output XML and PDF options should be removed since all of the modules under both of them are mandatory.

Regarding Class::Accessor::Lite the situation is not that clear. In particular it is not listed in checkModules.pl output at all and is not directly used by any of otrs components either. At least grep -r Accessor /usr/local/otrs command returns nothing. 
While Sisimai cpanfile says it needs Class::Accessor::Lite module while mail/p5-Sisimai port doesn't have corresponding RUN dependency. Probably this a root of this problem.
Comment 10 m.tsatsenko 2019-01-24 21:24:49 UTC
Created attachment 201381 [details]
the patch

- Remove XML dependency and make corresponding modules required
QA:
Portlint - OK
poudriere - ongoing
Comment 11 m.tsatsenko 2019-01-24 22:06:30 UTC
update:
poudriere 120amd64 OK
Comment 12 commit-hook freebsd_committer 2019-05-22 20:49:11 UTC
A commit references this bug:

Author: cs
Date: Wed May 22 20:49:03 UTC 2019
New revision: 502285
URL: https://svnweb.freebsd.org/changeset/ports/502285

Log:
  Add missing dependendies.

  PR:		229240
  Submitted by:	maintainer

Changes:
  head/www/otrs/Makefile