Bug 250354

Summary: net/avahi-app: Update to 0.8
Product: Ports & Packages Reporter: Olivier Duchateau <duchateau.olivier>
Component: Individual Port(s)Assignee: Rene Ladan <rene>
Status: Closed FIXED    
Severity: Affects Only Me CC: 0mp, greg, rene, tcberner
Priority: --- Flags: bugzilla: maintainer-feedback? (desktop)
Version: Latest   
Hardware: Any   
OS: Any   
Bug Depends on:    
Bug Blocks: 249745    
Attachments:
Description Flags
Patch to update net/avahi-app
none
Patch to update net/avahi-app none

Description Olivier Duchateau 2020-10-14 21:54:40 UTC
Created attachment 218748 [details]
Patch to update net/avahi-app

- Update to 0.8 (and slave ports)
- Adjust dependencies
- Remove uneeded patches
- Add GTK3 and GTK2 options in meta-port
- Switch to Python3 in net/py-avahi

Note: net/avahi-app contains PyGObject API for Avahi and AvahiCore (it is Python bindings for Avahi)
Comment 1 Rene Ladan freebsd_committer 2020-12-13 10:54:35 UTC
*** Bug 244799 has been marked as a duplicate of this bug. ***
Comment 2 Rene Ladan freebsd_committer 2020-12-13 11:00:23 UTC
*** Bug 250328 has been marked as a duplicate of this bug. ***
Comment 3 Rene Ladan freebsd_committer 2020-12-13 22:04:54 UTC
Hello,

the patch builds fine (should we also check reverse dependencies?) except that the avahi-gtk3 port does not have the avahi-discover-standalone binary, causing net/avahi to fail:

rene@e17:/zroot/poudriere/data/packages/12_2-amd64-default/All % tar tvf avahi-gtk3-0.8.txz 
-rw-r--r--  0 root   wheel    1633  1 jan.  1970 +COMPACT_MANIFEST
-rw-r--r--  0 root   wheel    3789  1 jan.  1970 +MANIFEST
-rw-r--r--  0 root   wheel     221 13 dec. 22:13 /usr/local/share/licenses/avahi-gtk3-0.8/catalog.mk
-rw-r--r--  0 root   wheel     103 13 dec. 22:13 /usr/local/share/licenses/avahi-gtk3-0.8/LICENSE
-rw-r--r--  0 root   wheel   26527 13 dec. 22:13 /usr/local/share/licenses/avahi-gtk3-0.8/LGPL21+
lrwxr-xr-x  0 root   wheel       0 13 dec. 22:13 /usr/local/lib/libavahi-ui-gtk3.so -> libavahi-ui-gtk3.so.0.1.4
lrwxr-xr-x  0 root   wheel       0 13 dec. 22:13 /usr/local/lib/libavahi-ui-gtk3.so.0 -> libavahi-ui-gtk3.so.0.1.4
-rwxr-xr-x  0 root   wheel   52120 13 dec. 22:13 /usr/local/lib/libavahi-ui-gtk3.so.0.1.4
-rw-r--r--  0 root   wheel     302 13 dec. 22:13 /usr/local/libdata/pkgconfig/avahi-ui-gtk3.pc

In contrast, the gtk2 variant does have the avahi-discover-standalone binary:
rene@e17:/zroot/poudriere/data/packages/12_2-amd64-default/All % tar tvf avahi-gtk-0.8.txz 
-rw-r--r--  0 root   wheel    1839  1 jan.  1970 +COMPACT_MANIFEST
-rw-r--r--  0 root   wheel    4710  1 jan.  1970 +MANIFEST
-rw-r--r--  0 root   wheel     221 13 dec. 14:11 /usr/local/share/licenses/avahi-gtk-0.8/catalog.mk
-rw-r--r--  0 root   wheel     103 13 dec. 14:11 /usr/local/share/licenses/avahi-gtk-0.8/LICENSE
-rw-r--r--  0 root   wheel   26527 13 dec. 14:11 /usr/local/share/licenses/avahi-gtk-0.8/LGPL21+
-r-xr-xr-x  0 root   wheel   16872 13 dec. 14:11 /usr/local/bin/avahi-discover-standalone
lrwxr-xr-x  0 root   wheel       0 13 dec. 14:11 /usr/local/bin/bshell -> bssh
-r-xr-xr-x  0 root   wheel   15032 13 dec. 14:11 /usr/local/bin/bssh
lrwxr-xr-x  0 root   wheel       0 13 dec. 14:11 /usr/local/bin/bvnc -> bssh
lrwxr-xr-x  0 root   wheel       0 13 dec. 14:11 /usr/local/lib/libavahi-ui.so -> libavahi-ui.so.0.1.4
lrwxr-xr-x  0 root   wheel       0 13 dec. 14:11 /usr/local/lib/libavahi-ui.so.0 -> libavahi-ui.so.0.1.4
-rwxr-xr-x  0 root   wheel   52704 13 dec. 14:11 /usr/local/lib/libavahi-ui.so.0.1.4
-rw-r--r--  0 root   wheel     297 13 dec. 14:11 /usr/local/libdata/pkgconfig/avahi-ui.pc
-rw-r--r--  0 root   wheel    3905 13 dec. 14:11 /usr/local/share/applications/bssh.desktop
-rw-r--r--  0 root   wheel    3839 13 dec. 14:11 /usr/local/share/applications/bvnc.desktop
-rw-r--r--  0 root   wheel    4101 13 dec. 14:11 /usr/local/share/avahi/interfaces/avahi-discover.ui
rene@e17:/zroot/poudriere/data/packages/12_2-amd64-default/All 

Can you investigate what goes wrong?
Comment 4 Tobias C. Berner freebsd_committer 2020-12-14 17:22:07 UTC
Thanks for taking that one Rene
Comment 5 Rene Ladan freebsd_committer 2020-12-15 17:57:20 UTC
(In reply to Tobias C. Berner from comment #4)
I stumbed upon it because net/py-avahi was python-2.7 only and had some PRs against it :)

@Olivier: I changed the meta-port to really on the library inside avahi-gtk3 instead.

I also did a test build for all reverse dependencies that Freshports showed me, some of those failed for unrelated reasons (IGNORE set, or build_fs_violations). So I think we can commit this?
Comment 6 Olivier Duchateau 2020-12-16 18:15:06 UTC
Created attachment 220632 [details]
Patch to update net/avahi-app

- Fix build of meta-port (net/avahi)
- 'avahi-discover-standalone' is now provided by net/avahi-gtk3 (because it calls gnome-terminal, a Gtk3 application)
Comment 7 Rene Ladan freebsd_committer 2020-12-16 20:12:36 UTC
(In reply to Olivier Duchateau from comment #6)
Thanks, I'm re-running the build test with reverse dependencies with your new patch.
Comment 8 commit-hook freebsd_committer 2020-12-17 10:52:50 UTC
A commit references this bug:

Author: rene
Date: Thu Dec 17 10:52:14 UTC 2020
New revision: 558281
URL: https://svnweb.freebsd.org/changeset/ports/558281

Log:
  Update the Avahi ports to version 0.8

  This switches the preferred GTK bindings to GTK3 and enable the GTK
  options in the metaport.

  This commit also switches the Python interface to Python3, thereby
  un-deprecating net/py-avahi.

  PR:		250354
  Submitted by:	Olivier Duchateu
  Reviewed by:	Greg V (earlier PR)

Changes:
  head/net/avahi-app/Makefile
  head/net/avahi-app/distinfo
  head/net/avahi-app/files/Makefile.am
  head/net/avahi-app/files/acinclude.m4
  head/net/avahi-app/files/avahi-qt_Makefile.am
  head/net/avahi-app/files/build-db
  head/net/avahi-app/files/configure.ac
  head/net/avahi-app/files/org.freedesktop.Avahi.service
  head/net/avahi-app/files/patch-avahi-daemon_main.c
  head/net/avahi-app/files/patch-avahi-qt_Makefile.in
  head/net/avahi-app/files/patch-avahi-qt_qt-watch.cpp
  head/net/avahi-app/files/patch-common_qt5-pie.m4
  head/net/avahi-app/files/patch-configure
  head/net/avahi-app/pkg-plist
Comment 9 Rene Ladan freebsd_committer 2020-12-17 10:56:26 UTC
(In reply to commit-hook from comment #8)
and r552828 for the rest of this patch