Bug 101285 - [patch] audio/icecast2 - fix rc.d script
Summary: [patch] audio/icecast2 - fix rc.d script
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Michael Nottebrock
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-03 00:20 UTC by Gabor Kovesdan
Modified: 2006-08-03 21:39 UTC (History)
1 user (show)

See Also:


Attachments
audio-icecast2.diff (1.21 KB, patch)
2006-08-03 00:20 UTC, Gabor Kovesdan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Gabor Kovesdan freebsd_committer 2006-08-03 00:20:16 UTC
The rc.d script of audio/icecast doesn't work as intended, the -b command line option is not
passed when invoking the script.

How-To-Repeat: 
Run the rc.d script with sh -x and you will be able to notice it:

+ [ start != start ]
+ eval _cmd=$start_cmd _precmd=$start_precmd _postcmd=$start_postcmd
+ _cmd= _precmd= _postcmd=
+ [ -n  ]
+ [ -z  -a -n  ]
+ [ ! -x /usr/local/bin/icecast ]
+ [ ! -r /usr/local/etc/icecast.xml ]
+ [ -n  ]
+ echo Starting icecast.
Starting icecast.
+ [ -n  ]
+ _doit=/usr/local/bin/icecast -c /usr/local/etc/icecast.xml 1>/dev/null
+ [ -n  ]
+ debug run_rc_command: _doit: /usr/local/bin/icecast -c /usr/local/etc/icecast.xml 1>/dev/null
+ eval /usr/local/bin/icecast -c /usr/local/etc/icecast.xml 1>/dev/null
+ /usr/local/bin/icecast -c /usr/local/etc/icecast.xml
Comment 1 Edwin Groothuis freebsd_committer 2006-08-03 00:21:59 UTC
Responsible Changed
From-To: freebsd-ports-bugs->lofi

Over to maintainer
Comment 2 Michael Nottebrock freebsd_committer 2006-08-03 17:23:41 UTC
Please commit.
Comment 3 Gabor Kovesdan freebsd_committer 2006-08-03 21:05:46 UTC
Michael Nottebrock wrote:
> Please commit.
>   
I'm sorry, but I can't. I am a SoC student, so I don't have access for 
CVS, just for Perforce.

-- 
Cheers,

Gabor
Comment 4 Erwin Lansing freebsd_committer 2006-08-03 21:39:11 UTC
State Changed
From-To: open->closed

Committed, thanks!