Bug 103651 - new port: biology/gmap, a standalone program for mapping and aligning cDNA sequences to a genome
Summary: new port: biology/gmap, a standalone program for mapping and aligning cDNA se...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Cheng-Lung Sung
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-09-25 23:00 UTC by Bob Zimmermann
Modified: 2006-09-29 05:10 UTC (History)
0 users

See Also:


Attachments
file.shar (2.96 KB, text/plain)
2006-09-25 23:00 UTC, Bob Zimmermann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Zimmermann 2006-09-25 23:00:34 UTC
A standalone program for mapping and aligning cDNA sequences to a
genome. The program maps and aligns a single sequence with minimal
startup time and memory requirements, and provides fast batch
processing of large sequence sets. The program generates accurate
gene structures, even in the presence of substantial polymorphisms
and sequence errors, without using probabilistic splice site models.
Methodology underlying the program includes a minimal sampling
strategy for genomic mapping, oligomer chaining for approximate
alignment, sandwich DP for splice site detection, and microexon
identification with statistical significance testing.

WWW: http://www.gene.com/share/gmap

Fix: (port add, not a bug)


port shar archive:

How-To-Repeat: (port add, not a bug)
Comment 1 Cheng-Lung Sung freebsd_committer 2006-09-27 02:32:53 UTC
Responsible Changed
From-To: freebsd-ports-bugs->clsung

I'll take it.
Comment 2 Cheng-Lung Sung freebsd_committer 2006-09-29 02:07:02 UTC
This port does not build on 4.x

http://tb.newzilla.org/errors/4-perl5005/gmap-2006.04.21.log

Can you fix it?

On Mon, Sep 25, 2006 at 04:51:21PM -0500, Bob Zimmermann wrote:
>=20
--=20
Cheng-Lung Sung - clsung@
Comment 3 dfilter service freebsd_committer 2006-09-29 05:06:02 UTC
clsung      2006-09-29 04:05:55 UTC

  FreeBSD ports repository

  Modified files:
    biology              Makefile 
  Added files:
    biology/gmap         Makefile distinfo pkg-descr pkg-plist 
    biology/gmap/files   extra-patch-src-genome.c 
                         extra-patch-src-indexdb.c patch-configure 
  Log:
  Add gmap 2006.04.21, a Genomic Mapping and Alignment Program for mRNA
  and EST Sequences.
  
  PR:             ports/103651
  Submitted by:   Bob Zimmermann <rpz at cse.wustl.edu>
  
  Revision  Changes    Path
  1.88      +1 -0      ports/biology/Makefile
  1.1       +32 -0     ports/biology/gmap/Makefile (new)
  1.1       +3 -0      ports/biology/gmap/distinfo (new)
  1.1       +17 -0     ports/biology/gmap/files/extra-patch-src-genome.c (new)
  1.1       +17 -0     ports/biology/gmap/files/extra-patch-src-indexdb.c (new)
  1.1       +11 -0     ports/biology/gmap/files/patch-configure (new)
  1.1       +12 -0     ports/biology/gmap/pkg-descr (new)
  1.1       +12 -0     ports/biology/gmap/pkg-plist (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Cheng-Lung Sung freebsd_committer 2006-09-29 05:09:38 UTC
State Changed
From-To: open->closed

New port added. Thank you.