Bug 106873 - [patch] rc.d/nfslocking does not properly restart
Summary: [patch] rc.d/nfslocking does not properly restart
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 6.1-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-rc mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-18 17:00 UTC by Oliver Lehmann
Modified: 2007-05-17 12:13 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (220 bytes, patch)
2006-12-18 17:00 UTC, Oliver Lehmann
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Lehmann freebsd_committer 2006-12-18 17:00:29 UTC
	/etc/rc.d/nfslocking restart
	will only restart rpc.statd. This is because after restarting rpc.statd
	_rc_restart_done got set to true by rc.subr.

Fix: To solve this, just unset _rc_restart_done before restarting rpc.lockd
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2006-12-19 17:13:09 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-rc
Comment 2 Mike Makonnen freebsd_committer 2007-05-17 12:00:40 UTC
Unfortunately, _rc_restart_done is private to rc.subr(8) and scripts
should not depend on it being available or having any specific
behavior. The solution is to breakup the script into separate scripts
for statd and lockd.

Cheers.
-- 
Mike Makonnen         | GPG-KEY: http://people.freebsd.org/~mtm/mtm.asc
mmakonnen @ gmail.com | AC7B 5672 2D11 F4D0 EBF8  5279 5359 2B82 7CD4 1F55
mtm @ FreeBSD.Org     | FreeBSD - http://www.freebsd.org
Comment 3 Mike Makonnen freebsd_committer 2007-05-17 12:11:48 UTC
State Changed
From-To: open->closed

Duplicate of conf/107316