Bug 106927 - rc.d/ntpd flags wrong when setting ntpd_config variable
Summary: rc.d/ntpd flags wrong when setting ntpd_config variable
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: conf (show other bugs)
Version: 6.2-PRERELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-19 18:20 UTC by Jeremy Chadwick
Modified: 2007-02-13 15:09 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Chadwick freebsd_committer 2006-12-19 18:20:28 UTC
	When using the ntpd_config variable, as referenced in /etc/rc.d/ntpd,
	the remaining command line flags passed to ntpd are incorrect.

	For example, without ntpd_config set:

root    41801  0.0  0.1  2916  1744  ??  Ss   10:13AM   0:00.01 /usr/sbin/ntpd -g -c /etc/ntp.conf -p /var/run/ntpd.pid -f /var/db/ntpd.drift

	With ntpd_config set to /conf/ME/ntpd.conf:

root    41733  0.0  0.1  2916  1736  ??  Ss   10:11AM   0:00.01 /usr/sbin/ntpd -g -c /conf/ME/ntp.conf

	The end result is that when using ntpd_config and attempting to
	stop the daemon via /etc/rc.d/ntpd stop, the user is told there's
	no pidfile (which is true).  The driftfile is also not getting
	created/used in that case.

Fix: 

Not sure how to fix this.
How-To-Repeat: 	Set ntpd_config in /etc/rc.conf.
Comment 1 Matteo Riondato freebsd_committer 2007-02-13 11:33:44 UTC
State Changed
From-To: open->feedback

I cannot reproduce this problem. Does it still exist for you?
Comment 2 Jeremy Chadwick freebsd_committer 2007-02-13 15:09:18 UTC
State Changed
From-To: feedback->closed

Hmm, interesting.  No, I can't reproduce this.  Maybe something in the 
rc.subr framework changed which somehow tickled a fix for this.  I'll go 
ahead and close this.  :)  Thanks for looking into it.