Bug 107158 - amarok-1.4.4 doesn't enable MTP support even if it is explicitly turned on
Summary: amarok-1.4.4 doesn't enable MTP support even if it is explicitly turned on
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Michael Landin
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-12-24 00:50 UTC by Rechistov Grigory
Modified: 2006-12-26 15:10 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rechistov Grigory 2006-12-24 00:50:15 UTC
Last update of port is claiming that it's possible to use MTP with hardware MP3 players and amarok. But in fact no mtp support is enabled during configuring. So no choice of MTP device is given in amarok.

How-To-Repeat: Doing next commands as root:

# cd /usr/ports/audio/amarok
# make rmconfig
# make config
<enabling MTP support in menu>
# make

After fetching, unpacking, pathich etc - during "configure" script there are lines in output:

..
checking for libmtp >= 0.0.15... gnome-config: not found
gnome-config: not found
checking for libmtp >= 0.0.12... gnome-config: not found
gnome-config: not found
checking for libmtp < 0.0.12... gnome-config: not found
gnome-config: not found
..

After that "configure" reports:

 ==========================
 ===  Amarok - PLUGINS  ========================================================
 ==========================
 =
 = The following extra functionality will NOT be included:
 =   - NMM-engine
 =   - Helix-engine
 =   - libvisual Support
 =   - XMMS Visualization Wrapper
 =   - MySql Support
 =   - Postgresql Support
 =   - iPod Support
 =   - iRiver iFP Support
 =   - MTP Device Support
 =   - Rio Karma Support
 =
 = The following extra functionality will be included:
 =   + xine-engine
 =   + Konqueror Sidebar
 =   + MusicBrainz Support
 =   + MP4/AAC Tag Write Support
 =   + Creative Nomad Jukebox Support
 =
 ===============================================================================

Good - your configure finished. Start make now

And after that amarok compiles flawlessly, but when it is run no MTP device is present in drop-down list (there are Generic, Nomad etc)
Comment 1 Edwin Groothuis freebsd_committer 2006-12-24 00:53:08 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mich

Over to maintainer
Comment 2 Rechistov Grigory 2006-12-25 11:28:54 UTC
Hello!

I've managed to add MTP support in amarok by hacking configure script  =

(bypassing the checking of libmtp presence tests and specifying paths to=
  =

libraries by hand). Now this type of devices is availible in dropdown  =

list. But the application crashes everytime when my Creative Zen  =

MicroPhoto is plugged in when I press "Connect" button. The output in a =
 =

console (when I run "amarokapp", not "amarok")

amarok: BEGIN: virtual bool MtpMediaDevice::openDevice(bool)
Found non-autodetected device "Creative Zen MicroPhoto" on USB bus...
Amarok is crashing...
Running: gdb --nw -n --batch -x /var/tmp/kde-GGG/amaroklMhTXG.tmp  =

amarokapp 75564

warning: Unable to get location for thread creation breakpoint: generic =
 =

error
/var/tmp/kde-GGG/amaroklMhTXG.tmp:6: Error in sourced command file:
Previous frame inner to this frame (corrupt stack?)
Killed: 9
/usr/home/GGG>Running: file `which amarokapp`
1.4.4 [NOTstripped][validity: 0.70][frames:  69][xine]

By the way, I ve tried gnomad2 application. It crashes the similar way:

$ gnomad2 -D 15
....
Enter view_and_sort_list_store(2)...
=3D=3D> NJB_Discover
    =3D=3D> njb_discover
    <=3D=3D njb_discover
<=3D=3D NJB_Discover
Found non-autodetected device "Creative Zen MicroPhoto" on USB bus...
Segmentation fault: 11 (core dumped)

May be this can help to find the bug...

Best regards, GGG.
Comment 3 Rechistov Grigory 2006-12-25 12:31:02 UTC
I found the cause of crashing when connecting to device. libmtp  has  
unsufficient access rights to /dev/ugen0* which is my player. When I  
changed its owner to current user everything works flawlessly. Gnomad2  
also works fine now (except the representing of Russian letter, and this  
is another story)

So there is support of MTP, but one has to assign correct rights to device  
(in /dev/devfs.rules, I suppose). I think it should be mentioned somewhere  
in documentation.

Best regadrs, Grigory Rechistov.
Comment 4 dfilter service freebsd_committer 2006-12-26 15:01:01 UTC
mich        2006-12-26 15:00:46 UTC

  FreeBSD ports repository

  Modified files:
    audio/amarok         Makefile pkg-message 
  Log:
  - add pkg-message explaining user-mount when using iPod and MTP devices
  
  PR:             ports/107158
  Submitted by:   Rechistov Grigory <ggg_mail@inbox.ru>
  
  Revision  Changes    Path
  1.62      +1 -1      ports/audio/amarok/Makefile
  1.4       +5 -3      ports/audio/amarok/pkg-message
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Michael Landin freebsd_committer 2006-12-26 15:01:02 UTC
State Changed
From-To: open->closed

I've added a pkg-message, referring to the handbook's usb-disk section. 
Thanks.