Bug 108031 - [PATCH] lang/python23: fix readline module build with new ncurses
Summary: [PATCH] lang/python23: fix readline module build with new ncurses
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-python (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-01-17 10:30 UTC by Rong-En Fan
Modified: 2010-09-06 18:46 UTC (History)
1 user (show)

See Also:


Attachments
python23-2.3.5_1.patch (1.70 KB, patch)
2007-01-17 10:30 UTC, Rong-En Fan
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Rong-En Fan freebsd_committer 2007-01-17 10:30:20 UTC
Fix python23 build with ncurses 5.6 (readline module). This change
can also found in newer python.

http://pointyhat.freebsd.org/errorlogs/i386-errorlogs/e.7.2007011523/python23-2.3.5_1.log

Added file(s):
- files/patch-Modules-readline.c

Port maintainer (python@FreeBSD.org) is cc'd.

Generated with FreeBSD Port Tools 0.77
Comment 1 Edwin Groothuis freebsd_committer 2007-01-17 10:30:31 UTC
Responsible Changed
From-To: freebsd-ports-bugs->python

Over to maintainer
Comment 2 Rong-En Fan freebsd_committer 2007-01-17 16:30:41 UTC
Actually, it is caused by gcc 4.
Comment 3 dfilter service freebsd_committer 2007-01-21 13:13:30 UTC
rafan       2007-01-21 13:13:23 UTC

  FreeBSD ports repository

  Added files:
    lang/python23/files  patch-Modules-readline.c 
  Log:
  - history_length conflicts with include/readline/history.h.
    Similar fix is in 2.4 and above. This causes an incomplete pkg-plist
    with gcc 4.x + newer ncurses.
  
  PR:             ports/108031
  Approved by:    alexbl
  
  Revision  Changes    Path
  1.1       +44 -0     ports/lang/python23/files/patch-Modules-readline.c (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Rong-En Fan freebsd_committer 2007-01-21 13:13:31 UTC
State Changed
From-To: open->closed

Committed. Thanks!
Comment 5 Philip M. Gollucci freebsd_committer 2010-09-06 18:46:46 UTC
Responsible Changed
From-To: python->freebsd-python

cannonicalize assignment