Bug 115887 - update www/mnogosearch port to 3.3.4
Summary: update www/mnogosearch port to 3.3.4
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-ports-bugs (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-08-27 20:40 UTC by Jaime Bozza
Modified: 2007-09-23 06:10 UTC (History)
0 users

See Also:


Attachments
file.diff (8.84 KB, patch)
2007-08-27 20:40 UTC, Jaime Bozza
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Bozza 2007-08-27 20:40:01 UTC
Update mnogosearch to 3.3.4

Fix: Patch attached with submission follows:
Comment 1 Tilman Keskinoz freebsd_committer 2007-09-02 17:30:02 UTC
State Changed
From-To: open->feedback

This does not compile on CURRENT: 

cc -O2 -fno-strict-aliasing -pipe -rpath=/usr/lib:/usr/local/lib -o .libs/indexer main.o mutex.o  -L/usr/home/arved/ports/mnogosearch/work/mnogosearch-3.3.4/src/.libs ./.libs/libmnogosearch.so /usr/home/arved/ports/mnogosearch/work/mnogosearch-3.3.4/src/.libs/libmnogocharset.so -L/usr/local/lib -L/usr/lib ./.libs/libmnogocharset.so -lm -lz -lsqlite -lssl -lcrypto -Wl,--rpath -Wl,/usr/local/lib 
/usr/lib/crt1.o(.text+0x8d): In function `_start': 
: undefined reference to `main' 


The problem seems to be that CONSOLE is not defined. Adding -DCONSOLE to CFLAGS fixes the build, but i can't verify if the port still works as intended. 

Please test!
Comment 2 Jaime Bozza 2007-09-04 14:50:38 UTC
I noticed the problem after I submitted the patch.  The current version
of the port doesn't actually disable threads so when I added that option
correctly to the Makefile it caused the compile problem.  I had been
running with threads so I didn't catch it originally.

I'm on vacation at the moment, but will test this and update the PR when
I get back later in the week.

Thanks for your quick response.


Sincerely,

Jaime Bozza


-----Original Message-----
From: arved@FreeBSD.org [mailto:arved@FreeBSD.org] 
Sent: Sunday, September 02, 2007 11:31 AM
To: Jaime Bozza; arved@FreeBSD.org; freebsd-ports-bugs@FreeBSD.org
Subject: Re: ports/115887: update www/mnogosearch port to 3.3.4

Synopsis: update www/mnogosearch port to 3.3.4

State-Changed-From-To: open->feedback
State-Changed-By: arved
State-Changed-When: Sun Sep 2 16:30:02 UTC 2007
State-Changed-Why: 
This does not compile on CURRENT:

cc -O2 -fno-strict-aliasing -pipe -rpath=/usr/lib:/usr/local/lib -o
.libs/indexer main.o mutex.o
-L/usr/home/arved/ports/mnogosearch/work/mnogosearch-3.3.4/src/.libs
./.libs/libmnogosearch.so
/usr/home/arved/ports/mnogosearch/work/mnogosearch-3.3.4/src/.libs/libmn
ogocharset.so -L/usr/local/lib -L/usr/lib ./.libs/libmnogocharset.so -lm
-lz -lsqlite -lssl -lcrypto -Wl,--rpath -Wl,/usr/local/lib
/usr/lib/crt1.o(.text+0x8d): In function `_start':
: undefined reference to `main'


The problem seems to be that CONSOLE is not defined. Adding -DCONSOLE to
CFLAGS fixes the build, but i can't verify if the port still works as
intended.

Please test!

http://www.freebsd.org/cgi/query-pr.cgi?pr=115887
Comment 3 Jaime Bozza 2007-09-06 21:33:46 UTC
Adding -DCONSOLE does in fact make the build work.   You only need to
add that to CFLAGS when WITHOUT_MNOGO_THREADS is defined.  Build
compiles and works without it when pthreads are enabled.

Should I update the patch or can you add it to the current one?
Comment 4 dfilter service freebsd_committer 2007-09-23 06:04:20 UTC
edwin       2007-09-23 05:04:11 UTC

  FreeBSD ports repository

  Modified files:
    www/mnogosearch      Makefile distinfo pkg-message pkg-plist 
  Log:
  update www/mnogosearch port to 3.3.4
  
          Update mnogosearch to 3.3.4
  
  PR:             ports/115887
  Submitted by:   Jaime Bozza <jbozza@mindsites.com>
  
  Revision  Changes    Path
  1.69      +7 -5      ports/www/mnogosearch/Makefile
  1.17      +3 -3      ports/www/mnogosearch/distinfo
  1.2       +1 -1      ports/www/mnogosearch/pkg-message
  1.19      +23 -18    ports/www/mnogosearch/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 5 Edwin Groothuis freebsd_committer 2007-09-23 06:04:21 UTC
State Changed
From-To: feedback->closed

Committed, thanks!