Bug 119204 - [patch] editors/OpenOffice.org-2 v2.3 loops when file opened
Summary: [patch] editors/OpenOffice.org-2 v2.3 loops when file opened
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-openoffice (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-12-31 22:10 UTC by Peter Jeremy
Modified: 2009-05-31 11:18 UTC (History)
0 users

See Also:


Attachments
file.diff (1.84 KB, patch)
2007-12-31 22:10 UTC, Peter Jeremy
no flags Details | Diff
smime.p7s (3.10 KB, application/x-pkcs7-signature)
2008-01-14 23:23 UTC, Marcin Cieślak
no flags Details
smime.p7s (3.10 KB, application/x-pkcs7-signature)
2008-02-19 21:32 UTC, Marcin Cieślak
no flags Details
smime.p7s (3.10 KB, application/x-pkcs7-signature)
2008-02-25 22:06 UTC, Marcin Cieślak
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Jeremy 2007-12-31 22:10:02 UTC
	OOo will start but whenever I go to open a file, the "unpacking
	file" boxes will appear across the bottom and then the window will
	freeze (not update) and OOo will go to 100% CPU.  The same effect
	occurs if I specify the file on the command line.  Note that
	the 6.x/i386 system has been freshly rebuilt from scratch (no
	installed ports) so all the ports are consistent.

	This has been reported on the mailing lists as
http://lists.freebsd.org/pipermail/freebsd-openoffice/2007-December/003453.html
http://lists.freebsd.org/pipermail/freebsd-openoffice/2007-December/003487.html
 
	OOo reports the following errors:
(process:81488): GLib-GObject-CRITICAL **: gtype.c:2242: initialization assertion failed, use IA__g_type_init() prior to this function
(process:81488): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
(process:81488): GLib-GObject-CRITICAL **: g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed

	It may be related to the use of WITHOUT_MOZILLA which is the
	default on amd64 and I have it set locally for i386.

Fix: The attached fix is an expanded version of the fix referenced
	in http://lists.freebsd.org/pipermail/freebsd-openoffice/2007-December/003464.html
	due to local problems when I tried to use that patch.
How-To-Repeat: 	Compile OOo with "WITHOUT_MOZILLA=yes" [this may not be required]
	Start OOo and open a document.  The OOo window will stop updating
	(moving other windows over it leaves their image present) and OOo
	will start using 100% CPU.
Comment 1 Edwin Groothuis freebsd_committer 2008-01-02 03:16:42 UTC
Responsible Changed
From-To: freebsd-ports-bugs->openoffice

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Marcin Cieślak 2008-01-14 23:23:33 UTC
Real solution is to completely back-out the change mentioned in

http://www.openoffice.org/issues/show_bug.cgi?id=75190

Removing code related to the "GTK recent file manager" fixes this issue.

-- 
              << Marcin Cieslak // saper@saper.info >>
Comment 3 Martin 2008-02-17 23:03:31 UTC
Hi,

I have got same problem here. The new openoffice.org-2-RC shows same behavior. 
Will this be committed? OpenOffice.org version 2 ports are not usable since 
weeks.

FreeBSD 7.0-PRERELEASE #0: Fri Feb 15 17:37:02 CET 2008, i386

Last tried:
editors/openoffice.org-2-RC (OOo_OOH680_m7_source.tar.bz2)

MAKE_FLAGS:
WITH_TTF_BYTECODE_ENABLED=yes WITH_CUPS=yes LOCALIZED_LANG=de


--
Martin
Comment 4 NAKATA Maho 2008-02-19 02:25:41 UTC
From: Martin Sugioarto <nakal@web.de>
Subject: Re: ports/119204: [patch] editors/OpenOffice.org-2 v2.3 loops when file opened
Date: Sun, 17 Feb 2008 23:10:02 +0000 (GMT)

> The following reply was made to PR ports/119204; it has been noted by GNATS.
> 
> From: Martin Sugioarto <nakal@web.de>
> To: bug-followup@freebsd.org
> Cc: peterjeremy@optushome.com.au,
>  saper@saper.info
> Subject: Re: ports/119204: [patch] editors/OpenOffice.org-2 v2.3 loops when file opened
> Date: Mon, 18 Feb 2008 00:03:31 +0100
> 
>  Hi,
>  
>  I have got same problem here. The new openoffice.org-2-RC shows same behavior. 
>  Will this be committed? OpenOffice.org version 2 ports are not usable since 
>  weeks.
>  
>  FreeBSD 7.0-PRERELEASE #0: Fri Feb 15 17:37:02 CET 2008, i386
>  
>  Last tried:
>  editors/openoffice.org-2-RC (OOo_OOH680_m7_source.tar.bz2)
>  
>  MAKE_FLAGS:
>  WITH_TTF_BYTECODE_ENABLED=yes WITH_CUPS=yes LOCALIZED_LANG=de
>  

Just for record:
FreeBSD 7.0-PRERELASE, without MAKE_FLAGS, i386, editors/openoffice.org-2-RC (OOH680_m7)
, removing ~/.openoffice.org2, and typed
% openoffice.org-OOH680_m7 aaa.odt
I did not see the problem.
I'll try on amd64.

Peter Jeremy, could you please sign to the JCA?
Even though I'm not sure your patch will be committed to the main trunk.

http://porting.openoffice.org/freebsd/

#  If you would like to submit patches for OpenOffice.org, please fill out and submit JCA, otherwise, we won't commit them, even for the FreeBSD ports cvs repo. If you want to learn more, please check the License FAQ. Here is a list of people who have signed the JCA.
# If you would like to provide enhancements in the Makefile in the ports framework, you *don't* need to fill out JCA.
# If you would like to provide bug fix(es) and/or enhancement(s) which won't be integrated into OpenOffice.org, i.e. Ximian patches, you *don't* need to fill out the JCA. 

Actually above is written by me.

-- Nakata Maho (maho@FreeBSD.org)
Comment 5 Peter Jeremy 2008-02-19 06:40:28 UTC
On Tue, Feb 19, 2008 at 11:25:41AM +0900, Maho NAKATA wrote:
>Just for record:
>FreeBSD 7.0-PRERELASE, without MAKE_FLAGS, i386, editors/openoffice.org-2-RC (OOH680_m7)
>, removing ~/.openoffice.org2, and typed
>% openoffice.org-OOH680_m7 aaa.odt
>I did not see the problem.
>I'll try on amd64.


It is not architecture dependent.  Based on the background material
in some of the referenced postings, it appears that OOo makes some
invalid assumptions about its GUI environment.

>Peter Jeremy, could you please sign to the JCA?


I've had a look at the JCA and am not willing to sign it without
some independent legal advice regarding some of the terms used -
and at this stage, I cannot justify that expenditure.

In any case, my patch is basically a cleaned up version of one of
the other patches referenced from the PR so it is possible that I
cannot "contribute" it in any case.

>#  If you would like to submit patches for OpenOffice.org, please fill out and submit JCA, otherwise, we won't commit them, even for the FreeBSD ports cvs repo.


I am unaware of any other port with such draconian requirements.  It
seems that the FreeBSD OOo project is not interested in receiving
patches and I will keep that in mind in future.

-- 
Peter Jeremy
Please excuse any delays as the result of my ISP's inability to implement
an MTA that is either RFC2821-compliant or matches their claimed behaviour.
Comment 6 Martin 2008-02-19 21:21:49 UTC
Hi,

can there be a certain dependency in the build environment that I have in 
common with Peter? I have also a fresh install of RC1 (updated to RELENG_7) 
and all ports are up-to-date.

I just build a fresh editors/openoffice.org-2 package without any MAKE_FLAGS, 
removed ~/.openoffice-org2 as you suggested. Opened with
% openoffice.org-2.3.1 mydoc.odt

And got:
(process:49550): GLib-GObject-CRITICAL **: gtype.c:2242: initialization 
assertion failed, use IA__g_type_init() prior to this function

(process:49550): GLib-CRITICAL **: g_once_init_leave: assertion 
`initialization_value != 0' failed

(process:49550): GLib-GObject-CRITICAL **: g_object_new: assertion 
`G_TYPE_IS_OBJECT (object_type)' failed

You can see, it's exactly the same error as Peter has and the same symptoms. I 
have got i386 running. It's not amd64-specific.

I haven't tried the patch yet.

--
Martin
Comment 7 Marcin Cieślak 2008-02-19 21:32:23 UTC
Gentlemen,

Martin wrote:
> Hi,
> 
> can there be a certain dependency in the build environment that I have in 
> common with Peter? I have also a fresh install of RC1 (updated to RELENG_7) 

This bug will never appear if for some other reason the GTK library gets
initialized properly. I think that having Mozilla integration turned on
can cause proper GTK initialization.

This may explain also why this does not expose in the binary packages on
other platforms or on some Linux distributions with older GTK library.
FreeBSD users tend to run the newest code AND they have more knobs to
control the way their software is build and this is a Good Thing(tm).

I think that patching this does not require some special licensing
arrangements. The whole "gtk2 recent history integration" feature should
be basically removed and re-designed.

-- 
              << Marcin Cieslak // saper@saper.info >>
Comment 8 Martin 2008-02-20 09:26:49 UTC
Hi all,

I switched to Gnome2 and same openoffice.org-2 installation that (still) does 
not work with KDE3 runs perfectly with Gnome2.

It seems something at KDE3 is not working correctly.


Simple workaround:
If you really need to work with OpenOffice, simply don't use KDE.


I don't know what is going on there. Perhaps the KDE team will be interested 
in this PR.

--
Martin
Comment 9 NAKATA Maho 2008-02-25 05:11:00 UTC
Hi, all

From: Martin Sugioarto <nakal@web.de>
Subject: Re: ports/119204: [patch] editors/OpenOffice.org-2 v2.3 loops when file opened
Date: Wed, 20 Feb 2008 10:26:49 +0100

> I switched to Gnome2 and same openoffice.org-2 installation that (still) does 
> not work with KDE3 runs perfectly with Gnome2.
> 
> It seems something at KDE3 is not working correctly.
> 
> 
> Simple workaround:
> If you really need to work with OpenOffice, simply don't use KDE.
> 
> 
> I don't know what is going on there. Perhaps the KDE team will be interested 
> in this PR.
> 

For a record, my environment is:
WITHOUT_MOZILLA and FBSD 7-PRERELEASE, openoffice.org-2.
OOo didn't loop.

Okay I'll try KDE3 and/or others to reproduce...

Thanks,
-- Nakata Maho (maho@FreeBSD.org)
Comment 10 Marcin Cieślak 2008-02-25 22:06:25 UTC
Maho NAKATA wrote:
> Hi, all
> 
> From: Martin Sugioarto <nakal@web.de>
> Subject: Re: ports/119204: [patch] editors/OpenOffice.org-2 v2.3 loops when file opened
> Date: Wed, 20 Feb 2008 10:26:49 +0100
> 
>> I switched to Gnome2 and same openoffice.org-2 installation that (still) does 
>> not work with KDE3 runs perfectly with Gnome2.
>>
>> It seems something at KDE3 is not working correctly.
>>
>>
>> Simple workaround:
>> If you really need to work with OpenOffice, simply don't use KDE.
>>
>>
>> I don't know what is going on there. Perhaps the KDE team will be interested 
>> in this PR.
>>
> 
> For a record, my environment is:
> WITHOUT_MOZILLA and FBSD 7-PRERELEASE, openoffice.org-2.
> OOo didn't loop.

Maybe this is another case of improper GTK initialization?
OOo decides to use GNOME FIle...open dialog when it detects gnome
(running metacity).

Does setting OOO_FORCE_DESKTOP change anything?

-- 
              << Marcin Cieslak // saper@saper.info >>
Comment 11 James VanBokkelen 2008-04-02 03:40:20 UTC
I am getting the same symptom on FreeBSD 7.0-RELEASE with KDE 3.5
after doing cvsup at 8PM on March 31 and building via:

   cd /usr/ports/editors/openoffice.org-2
   make install clean

to build OpenOffice v2.4.0.  So it appears I can a) switch
to Gnome, b) back out the bogus change myself, or c) wait.

jbvb
Comment 12 Martin Wilke freebsd_committer 2009-05-30 23:59:52 UTC
State Changed
From-To: open->feedback

Could you please test if this issue still exists with an fresh ports 
tree? Thanks for your report.
Comment 13 Martin Wilke freebsd_committer 2009-05-31 11:18:04 UTC
State Changed
From-To: feedback->closed

problem is gone.