Bug 122907 - [patch] sysutils/fusefs-kmod dataloss on write shortly (e.g. 15 minutes) before shutdown
Summary: [patch] sysutils/fusefs-kmod dataloss on write shortly (e.g. 15 minutes) befo...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Stefan Walter
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-19 12:30 UTC by kamikaze
Modified: 2008-12-12 15:12 UTC (History)
0 users

See Also:


Attachments
file.diff (307 bytes, patch)
2008-04-19 12:30 UTC, kamikaze
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description kamikaze 2008-04-19 12:30:01 UTC
Fusefs mounts can loose data written shortly before shutdown and cause file system corruption.

The problem is that the cache gets written back when the systems are unmounted. But the short timespan between stopping and thus unmounting and the system reset/powerdown often does not suffice to write all data back.

This will change the rc script so that it hangs around until all data has safely been written back.

It can still be shot by the watchdog, but it greatly reduces the risk of data corruption.

How-To-Repeat: Use fusefs-ntfs or something similar, write some data (~100M split into a couple of files should do) to a mount and immediately run 'shutdown -p now'. The data will be (partly) missing upon the next boot.
Comment 1 Edwin Groothuis freebsd_committer 2008-04-19 12:30:09 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 2 amistry 2008-04-19 15:24:35 UTC
This looks like something that needs to be fixed at the code level.  
The patch is fine for now.  I'm CC'ing Csaba.
-- 
Anish Mistry
amistry@am-productions.biz
AM Productions http://am-productions.biz/
Comment 3 kamikaze 2008-04-23 21:21:17 UTC
There is an OK from the maintainer and this patch can spare people significant 
data loss (like me who lost hours of work because of this).

I dare suggest it ought to be committed until there is a proper fix available.
Comment 4 Gavin Atkinson freebsd_committer freebsd_triage 2008-04-26 12:37:59 UTC
State Changed
From-To: feedback->open

Workaround patch has an OK from the port maintainer
Comment 5 Stefan Walter 2008-10-10 14:32:12 UTC
Hi Anish,

the PR ports/122907 [1] has been around for quite a while now, but a patch
has not been committed by anyone, yet. If the patch is still applicable
and should be committed, I'll do so at the weekend.

Please let me know if this should finally be committed or if the PR should
be closed.

Best regards,
Stefan

[1]: http://www.freebsd.org/cgi/query-pr.cgi?pr=122907
Comment 6 Stefan Walter freebsd_committer 2008-10-10 14:40:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->stefan

Take.
Comment 7 Stefan Walter freebsd_committer 2008-12-12 15:11:26 UTC
State Changed
From-To: open->closed

Tracked in ports/124901.