Bug 123859 - print/ghostscript-gpl-nox11: PKGNAMESUFFIX not being defined
print/ghostscript-gpl-nox11: PKGNAMESUFFIX not being defined
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: doceng
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-05-21 14:00 UTC by Scot Hetzel
Modified: 2008-10-05 04:17 UTC (History)
0 users

See Also:


Attachments
file.diff (1.49 KB, patch)
2008-05-21 14:00 UTC, Scot Hetzel
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Scot Hetzel 2008-05-21 14:00:07 UTC
When rebuilding the INDEX with either make index or portsdb -Uu the following warning is generated:

Warning: Duplicate INDEX entry:  ghostscript-gpl-8.62_2

The cause of the warning is due to the OPTIONSFILE defines at least one of these:

 WITH_GS_x11
 WITH_GS_x11alpha
 WITH_GS_x11cmyk
 WITH_GS_x11cmyk2
 WITH_GS_x11cmyk4
 WITH_GS_x11cmyk8
 WITH_GS_x11gray2
 WITH_GS_x11gray4
 WITH_GS_x11mono
 WITH_GS_x11rg16x
 WITH_GS_x11rg32x

when WITHOUT_X11 is defined.  Which prevents -nox11 being added to PKGNAMESUFFIX.

Fix: apply the attached patch.

Patch attached with submission follows:
How-To-Repeat: $ cd /usr/ports/print/ghoscript-gpl
$ make config

enable one or more of the GS_x11* option

$ make -V PKGNAME
ghostscript-gpl-8.62_2

$ cd ../ghostscript-gpl-nox11
$ make -V PKGNAME
"/usr/ports/print/ghostscript-gpl-nox11/../ghostscript-gpl/Makefile", line 132: warning: drivers incompatible with WITHOUT_X11 will be removed automatically
ghostscript-gpl-8.62_2
Comment 1 Rong-En Fan freebsd_committer 2008-06-01 14:40:24 UTC
Responsible Changed
From-To: freebsd-ports-bugs->doceng

Over to maintainer.
Comment 2 dfilter freebsd_committer 2008-10-05 03:43:43 UTC
hrs         2008-10-05 02:43:30 UTC

  FreeBSD ports repository

  Modified files:
    print/ghostscript8   Makefile 
  Log:
  Fix an issue that print/ghostscript8 does not set
  PKGNAMESUFFIX (-nox11) correctly when WITHOUT_X11=yes and one of
  the X11 drivers are specified at a time.
  
  PR:     ports/123859
  
  Revision  Changes    Path
  1.175     +25 -26    ports/print/ghostscript8/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Hiroki Sato freebsd_committer 2008-10-05 04:17:12 UTC
State Changed
From-To: open->closed

Committed with some minor modification.  Thanks for your report!