Bug 125251 - [panic] kernel panic
Summary: [panic] kernel panic
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: 7.0-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-04 08:20 UTC by Veniamin
Modified: 2011-09-23 21:09 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Veniamin 2008-07-04 08:20:01 UTC
Sorry,
I do not know what impact caused the kernel panic.

ns# kldstat 
Id Refs Address    Size     Name
 1    9 0xc0400000 65d7a0   kernel
 2    1 0xc0a5e000 342c     umodem.ko
 3    2 0xc0a62000 35a4     ucom.ko
 4    1 0xc0a66000 1bdc     wlan_xauth.ko
 5    1 0xc0a68000 6a2c4    acpi.ko

(kgdb) core-file vmcore.1

Unread portion of the kernel message buffer:


Fatal trap 9: general protection fault while in kernel mode
instruction pointer	= 0x20:0xc07b9f80
stack pointer	        = 0x28:0xd4ccec58
frame pointer	        = 0x28:0xd4ccec78
code segment		= base rx0, limit 0xfffff, type 0x1b
			= DPL 0, pres 1, def32 1, gran 1
processor eflags	= interrupt enabled, resume, IOPL = 0
current process		= 12 (swi4: clock)
trap number		= 9
panic: general protection fault
Uptime: 4d13h32m14s
Physical memory: 503 MB
Dumping 111 MB: 95 79 63 47 31 15

Loaded symbols for /boot/kernel/umodem.ko
Loaded symbols for /boot/kernel/ucom.ko
Loaded symbols for /boot/kernel/wlan_xauth.ko
Loaded symbols for /boot/kernel/acpi.ko
#0  doadump () at pcpu.h:195
195	pcpu.h: No such file or directory.
	in pcpu.h
(kgdb) bt 0xc07b9f80
#0  doadump () at pcpu.h:195
#1  0xc060f5e3 in boot (howto=260)
    at /mnt/freebsd/src/7/sys/kern/kern_shutdown.c:418
#2  0xc060f7df in panic (fmt=Variable "fmt" is not available.)
    at /mnt/freebsd/src/7/sys/kern/kern_shutdown.c:572
#3  0xc0884c6c in trap_fatal (frame=0xd4ccec18, eva=0)
    at /mnt/freebsd/src/7/sys/i386/i386/trap.c:899
#4  0xc08859be in trap (frame=0xd4ccec18)
    at /mnt/freebsd/src/7/sys/i386/i386/trap.c:686
#5  0xc086f02b in calltrap ()
    at /mnt/freebsd/src/7/sys/i386/i386/exception.s:139
#6  0xc07b9f80 in nfsrv_timer (arg=0x0) at atomic.h:149
#7  0xc0620dd7 in softclock (dummy=0x0)
    at /mnt/freebsd/src/7/sys/kern/kern_timeout.c:274
#8  0xc05f159b in ithread_loop (arg=0xc2927c00)
    at /mnt/freebsd/src/7/sys/kern/kern_intr.c:1036
#9  0xc05ee416 in fork_exit (callout=0xc05f13f0 <ithread_loop>, 
    arg=0xc2927c00, frame=0xd4cced38)
    at /mnt/freebsd/src/7/sys/kern/kern_fork.c:783
#10 0xc086f0a0 in fork_trampoline ()
    at /mnt/freebsd/src/7/sys/i386/i386/exception.s:205
(kgdb)

ns# dmesg 
Copyright (c) 1992-2008 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
        The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 7.0-STABLE #0: Tue Jun 10 14:16:05 UTC 2008
    admin@ns.p13.net:/usr/obj/mnt/freebsd/src/7/sys/p13
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Unknown CPU Type (1528.98-MHz 686-class CPU)
  Origin = "AuthenticAMD"  Id = 0x681  Stepping = 1
  Features=0x383f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE>
  AMD Features=0xc0400800<SYSCALL,MMX+,3DNow!+,3DNow!>
real memory  = 536805376 (511 MB)
avail memory = 515788800 (491 MB)
ath_hal: 0.9.20.3 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <VIA694 AWRDACPI> on motherboard
acpi0: [ITHREAD]
acpi0: Power Button (fixed)
acpi0: reservation of 0, a0000 (3) failed
acpi0: reservation of 100000, 1fef0000 (3) failed
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x4008-0x400b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
acpi_button0: <Power Button> on acpi0
acpi_button1: <Sleep Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff,0x4000-0x407f,0x4080-0x40ff,0x5000-0x500f on acpi0
pci0: <ACPI PCI bus> on pcib0
agp0: <VIA 8367 (KT266/KY266x/KT333) host to PCI bridge> on hostb0
agp0: aperture size is 256M
pcib1: <PCI-PCI bridge> at device 1.0 on pci0
pci1: <PCI bus> on pcib1
vgapci0: <VGA-compatible display> mem 0xe8000000-0xe8ffffff,0xd8000000-0xdfffffff,0xe0000000-0xe007ffff irq 11 at device 0.0 on pci1
ath0: <Atheros 5212> mem 0xeb000000-0xeb00ffff irq 11 at device 8.0 on pci0
ath0: [ITHREAD]
ath0: using obsoleted if_watchdog interface
ath0: Ethernet address: 00:14:78:ee:d8:c1
ath0: mac 7.8 phy 4.5 radio 5.6
ed0: <RealTek 8029> port 0xd000-0xd01f irq 12 at device 9.0 on pci0
ed0: [ITHREAD]
ed0: using obsoleted if_watchdog interface
ed0: Ethernet address: 00:50:ba:b4:4e:fb
rl0: <RealTek 8139 10/100BaseTX> port 0xd400-0xd4ff mem 0xeb010000-0xeb0100ff irq 5 at device 11.0 on pci0
miibus0: <MII bus> on rl0
rlphy0: <RealTek internal media interface> PHY 0 on miibus0
rlphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
rl0: Ethernet address: 00:e0:4c:7e:df:29
rl0: [ITHREAD]
isab0: <PCI-ISA bridge> at device 17.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <VIA 8233 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0xd800-0xd80f at device 17.1 on pci0
ata0: <ATA channel 0> on atapci0
ata0: [ITHREAD]
ata1: <ATA channel 1> on atapci0
ata1: [ITHREAD]
uhci0: <VIA 83C572 USB controller> port 0xdc00-0xdc1f irq 5 at device 17.2 on pci0
uhci0: [GIANT-LOCKED]
uhci0: [ITHREAD]
usb0: <VIA 83C572 USB controller> on uhci0
usb0: USB revision 1.0
uhub0: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb0
uhub0: 2 ports with 2 removable, self powered
uhci1: <VIA 83C572 USB controller> port 0xe000-0xe01f irq 5 at device 17.3 on pci0
uhci1: [GIANT-LOCKED]
uhci1: [ITHREAD]
usb1: <VIA 83C572 USB controller> on uhci1
usb1: USB revision 1.0
uhub1: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb1
uhub1: 2 ports with 2 removable, self powered
uhci2: <VIA 83C572 USB controller> port 0xe400-0xe41f irq 5 at device 17.4 on pci0
uhci2: [GIANT-LOCKED]
uhci2: [ITHREAD]
usb2: <VIA 83C572 USB controller> on uhci2
usb2: USB revision 1.0
uhub2: <VIA UHCI root hub, class 9/0, rev 1.00/1.00, addr 1> on usb2
uhub2: 2 ports with 2 removable, self powered
pci0: <multimedia, audio> at device 17.5 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
pmtimer0 on isa0
atkbdc0: <Keyboard controller (i8042)> at port 0x60,0x64 on isa0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
atkbd0: [ITHREAD]
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounter "TSC" frequency 1528984779 Hz quality 800
Timecounters tick every 1.000 msec
ad1: 381554MB <SAMSUNG HD400LD WQ100-15> at ata0-slave UDMA100
ad3: 38146MB <WDC WD400BB-75FJA1 14.03G14> at ata1-slave UDMA100
Comment 1 Jaakko Heinonen freebsd_committer 2011-09-23 20:37:51 UTC
State Changed
From-To: open->feedback

Can you still reproduce this on recent FreeBSD versions?
Comment 2 Veniamin 2011-09-23 20:50:52 UTC
I haven't this's problem now.
Comment 3 Jaakko Heinonen freebsd_committer 2011-09-23 21:09:20 UTC
State Changed
From-To: feedback->closed

Submitter can't reproduce anymore.