Bug 127275 - ldd(1) produces uncatchable output
Summary: ldd(1) produces uncatchable output
Status: Closed FIXED
Alias: None
Product: Base System
Classification: Unclassified
Component: amd64 (show other bugs)
Version: Unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-amd64 mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-09-10 18:40 UTC by kamikaze
Modified: 2008-09-15 22:45 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kamikaze 2008-09-10 18:40:03 UTC
Ldd produces the output 'ELF binary type "0" not known.' upon encountering binaries that are listed as 'Unix - System V' by readelf -e.

How-To-Repeat: tcsh:
# ldd /usr/local/Adobe/Reader8/ENU/Adobe/HelpViewer/1.0/intellinux/bin/ahv-binary >& /dev/null

sh:
# ldd /usr/local/Adobe/Reader8/ENU/Adobe/HelpViewer/1.0/intellinux/bin/ahv-binary
> /dev/null 2>&1
Comment 1 kamikaze 2008-09-15 18:51:14 UTC
This can be closed, because what I thought were two distinct problems has
turned out to have the same cause. So this can be considered a duplicate of
amd64/127276.

Ldd invokes the binary and in case of a nonsensical elf-brand the kernel (at
least that is my suspect) posts a message on the terminal.

The workaround is to only run ldd on FreeBSD binaries. The safe solution,
would in my opinion, be a check weather the binary uses the FreeBSD linker,
but this discussion can remain in amd64/127276.
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2008-09-15 22:45:01 UTC
State Changed
From-To: open->closed

See amd64/127276.