Bug 128787 - print/ghostscript8 8.63 fails with -sDEVICE=ijs -sIjsServer=hpijs
print/ghostscript8 8.63 fails with -sDEVICE=ijs -sIjsServer=hpijs
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: doceng
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 13:50 UTC by Peter Orlowski
Modified: 2010-04-25 14:26 UTC (History)
0 users

See Also:


Attachments
patch-base-Makefile.in (2.26 KB, text/plain)
2009-08-13 06:51 UTC, rannumgen
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Orlowski 2008-11-11 13:50:04 UTC
After upgrading from ghostscript8-8.62_5 to 8.63, the following message shows up in the cups/error_log of all our hpijs-printers:
/var/log/cups/error_log.O:D [11/Nov/2008:13:24:20 +0100] [Job 75684] foomatic-gswrapper: gs '-dBATCH' '-dPARANOIDSAFER' '-dQUIET' '-dNOPAUSE' '-sDEVICE=ijs' '-sIjsServer=hpijs' '-sDeviceManufacturer=HEWLETT-PACKARD' '-sDeviceModel=DESKJET 990' '-dDEVICEWIDTHPOINTS=595' '-dDEVICEHEIGHTPOINTS=842' '-dDuplex=false' '-r300' '-sIjsParams=Quality:Quality=0,Quality:ColorMode=0,Quality:MediaType=0,Quality:PenSet=2,PS:MediaPosition=7' '-dIjsUseOutputFD' '-sOutputFile=| cat >&3' '/dev/fd/0' 3>&1 1>&2
/var/log/cups/error_log.O:D [11/Nov/2008:13:26:49 +0100] [Job 75684] GPL Ghostscript 8.63: Can't start ijs server "hpijs"
/var/log/cups/error_log.O:D [11/Nov/2008:13:26:49 +0100] [Job 75684] **** Unable to open the initial device, quitting.


This can be reproduced on the command line.

The hpijs-executable is in place. (From the hplip-port.)

Fix: 

Downgrade to ghostscript8-8.62_5 helps.
How-To-Repeat: Run gs with -sDEVICE=ijs -sIjsServer=hpijs
Comment 1 pav freebsd_committer 2008-11-12 16:19:39 UTC
Responsible Changed
From-To: freebsd-ports-bugs->doceng

Assign to maintainer
Comment 2 petero 2008-11-18 15:41:30 UTC
This seems to be related to the pthread lib. Setting

STDLIBS=-lm
SYNC=nosync

in src/Makefile.in fixes the error.

I forgot to mention that every erroneous print job produces a leftover
gsc process with 100% CPU load each. These have to be killed with
-9 to go away.
Comment 3 petero 2009-04-20 13:18:46 UTC
The bug is still present in print/ghostscript8 8.64 .
Comment 4 tedm 2009-06-14 07:29:55 UTC
It's still broken for me and I just cvsup'ed the ports r2 weeks ago.

Ghostscript7 seems to be no longer building in ports also. :-(

In Ghostscript 8.64 the file is in base/Makefile.in.  Until they fix
it:

make extract
make patch
manually patch the file
make install

is a workaround.  The one change that is needed is here:

331,332c331,332
< #SYNC=nosync
< SYNC=posync
---
 > SYNC=nosync
 > #SYNC=posync

The STDLIBS variable in 8.6.4 seems to have the -lm in it already
Comment 5 rannumgen 2009-08-13 06:51:51 UTC
Modified "patch-base-makefile.in" as per instructions in previous PR
reply. Applied to ghostscript-8.64_6, fixes failure to run HPIJS.
Comment 6 rannumgen 2010-04-05 04:03:33 UTC
This PR can be closed WITH THE COMMITMENT OF THE LAST PATCH. Also, v8.63
of Ghostscript has been superceded by V8.70 (which, by the way, ALSO
requires this same patch!).
Comment 7 Hiroki Sato freebsd_committer 2010-04-10 18:21:44 UTC
State Changed
From-To: open->patched

A patch has been committed to 8.71_1.  Please try it and let us know 
if it works or not.
Comment 8 dfilter freebsd_committer 2010-04-10 18:21:45 UTC
hrs         2010-04-10 17:21:32 UTC

  FreeBSD ports repository

  Modified files:
    print/ghostscript8   Makefile 
    print/ghostscript8/files patch-base-Makefile.in 
  Log:
  Fix "-sDEVICE=ijs -sIjsServer=hpijs" issue.
  
  PR:     ports/128787
  
  Revision  Changes    Path
  1.195     +1 -0      ports/print/ghostscript8/Makefile
  1.3       +2 -2      ports/print/ghostscript8/files/patch-base-Makefile.in
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 Hiroki Sato freebsd_committer 2010-04-25 14:25:16 UTC
State Changed
From-To: patched->closed

This problem has been solved.  Thank you for your report!