Bug 133963 - [MAINTAINER] sysutils/e2fsprogs: update to 1.41.5
[MAINTAINER] sysutils/e2fsprogs: update to 1.41.5
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Any Any
: Normal Affects Only Me
Assigned To: Martin Wilke
Depends on:
  Show dependency treegraph
Reported: 2009-04-24 09:50 UTC by matthias.andree
Modified: 2009-04-25 23:30 UTC (History)
0 users

See Also:

e2fsprogs-1.41.5.patch (3.46 KB, patch)
2009-04-24 09:50 UTC, matthias.andree
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description matthias.andree 2009-04-24 09:50:02 UTC
1) Critical update, fixes data corruption bugs.
   Please backport (shift tags/rebuild packages) for upcoming 7.2.

2) this PR modifies the misc/e2fsprogs-libuuid slave port (reset PORTREVISION),
                and the sysutils/e2fsprogs master port (updates PORTVERSION)

    No effort was made to use fully qualified filenames, so please save
    this message and break it out into patches with your favourite text

NOTE that these modified port updates must be committed together to
avoid the dreaded "port version going backwards" issue on the slave

- Update to 1.41.5, relevant changes from upstream release notes,
excluding Debian-specific and Programmer's Notes:
Fix a number of filesystem corruption bugs in resize2fs when growing or
shrinking ext4 filesystems off-line (i.e., when the ext4 filesystem is
not mounted).

Debugfs can now set i_file_acl_high via the set_inodes_field command,
and print a 64-bit file acl. This is useful for debugging filesystem
corruptions where the high bits of i_file_acl_high are set. E2fsck will
detect and fix non-zero i_file_acl_high on 32-bit filesystems since some
Linux kernel versions pay attention to this field even when they

Speed up e2fsck when checking clean filesystems by avoiding unnecessary
block reads, and coalescing the block group descriptor blocks so they
are read using a single read operation.

The libuuid library will now close all file descriptors before running
uuidd. This avoids problems when the calling program has open sockets
which then never get closed because uuidd is a long-running helper
daeomn. (Addresses Launchpad bug: #305057)

In order to avoid unnecessary full filesystem checks by e2fsck after an
on-line resize, e2fsck will ignore the NEEDS_RECOVERY flag set on the
backup superblocks. (Addresses Red Hat Bugzilla: #471925)

Mke2fs will avoid trying to create the journal when run in
superblock-only mode (mke2fs -S), since the left-over journal in the
inode table will cause mke2fs to fail.

Fix a bug in libext2fs functions that check to see if a particular
device or filesystem image is mounted, which would cause these functions
to report that a file identical to the (relative) pathname used by a
pseudo-filesystem was mounted when in fact it was not.

Update Czech translation from the Translation Project.

Add Chinese (simplified) translation from the Translation Project.

Fix support for external journals (which was broken in e2fsprogs

Fix a regression in debugfs where the "stat" command when no filesystem
was open would cause debugfs to crash with a segmentation violation.

Starting in the 2.6.29 linux kernel, the ext4 filesystem driver can be
used to support filesystems without a journal. Update the blkid library
so it understands this.

The blkid library will remove an entry from the blkid cache representing
the entire disk if partitions are found, since presuambly the device
previously had no partition table, but has now transitioned to using a
partition table.

Add a check to mke2fs and tune2fs that the argument to the -m option
(which specifies the reserved ratio) must be greater than zero.
(Addresses Debian Bug: #517015)

Add support for tracking the number kilobytes written to the filesystem
via the superblock field s_kbytes_written. It will be updated by the
kernel as well as by e2fsprogs programs which write to the filesystem.
This is useful for tracking the wear to filesystems on Solid Sstate

Fix compatibility issue in the libext2fs info file and makeinfo version
4.12. (Addresses Red Hat Bugzilla: #481620)

Update/clarify man pages. (Addresses Debian Bug: #515693, #365619)

Generated with FreeBSD Port Tools 0.77

Fix: --- misc/e2fsprogs-libuuid patch begins here ---
Index: Makefile
RCS file: /home/ncvs/ports/misc/e2fsprogs-libuuid/Makefile,v
retrieving revision 1.8
diff -u -r1.8 Makefile
--- Makefile	6 May 2008 22:29:03 -0000	1.8
+++ Makefile	24 Apr 2009 08:34:40 -0000
@@ -5,7 +5,7 @@
 # $FreeBSD: ports/misc/e2fsprogs-libuuid/Makefile,v 1.8 2008/05/06 22:29:03 itetcu Exp $
 CATEGORIES=	misc devel
--- misc/e2fsprogs-libuuid patch ends here ---
Comment 1 Martin Wilke freebsd_committer 2009-04-24 10:56:33 UTC
Responsible Changed
From-To: freebsd-ports-bugs->miwi

I'll take it.
Comment 2 dfilter freebsd_committer 2009-04-25 23:25:23 UTC
miwi        2009-04-25 22:25:12 UTC

  FreeBSD ports repository

  Modified files:
    sysutils/e2fsprogs   Makefile distinfo pkg-plist 
    sysutils/e2fsprogs/files patch-misc_Makefile.in 
    misc/e2fsprogs-libuuid Makefile 
  - Update to 1.41.5
  PR:             133963
  Submitted by:   Matthias Andree <matthias.andree@gmx.de>
  Revision  Changes    Path
  1.9       +1 -1      ports/misc/e2fsprogs-libuuid/Makefile
  1.55      +4 -2      ports/sysutils/e2fsprogs/Makefile
  1.29      +3 -3      ports/sysutils/e2fsprogs/distinfo
  1.8       +6 -6      ports/sysutils/e2fsprogs/files/patch-misc_Makefile.in
  1.20      +2 -1      ports/sysutils/e2fsprogs/pkg-plist
cvs-all@freebsd.org mailing list
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 3 Martin Wilke freebsd_committer 2009-04-25 23:25:26 UTC
State Changed
From-To: open->closed

Committed. Thanks!