Bug 134732 - editors/abiword shows spacing corruption
Summary: editors/abiword shows spacing corruption
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-gnome (Nobody)
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-05-20 01:10 UTC by Joseph S. Atkinson
Modified: 2009-05-23 20:30 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joseph S. Atkinson 2009-05-20 01:10:02 UTC

I have seen this before, it seems to come and go.

I experinced this on amd64 early last month, but it went away. Now, I see this on amd64 and i386 with up to date ports again.

Screenshot:
http://wickedmachine.net/~jsa/FreeBSD/bugs/abiword-report.png

What is above is a 3200 word report I was working on at the time, as it started appearing after the original udpate to 2.6.8. The current problem is identical on both machines.

cc: Koop Mast <kwm@FreeBSD.org>

How-To-Repeat: 

Build and install abiword, open it up, start typing.
Comment 1 Edwin Groothuis freebsd_committer 2009-05-20 01:10:14 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Joseph S. Atkinson 2009-05-20 03:30:59 UTC
I've solved this... kinda...

The issue is that the fonts it wants do not exist and... can't be 
shipped with it either. The default fonts are MS fonts found in 
x11-fonts/webfonts.

The solution, seemingly, would thus be to change the default font in 
abiword to something more F/OSS friendly...

However, documents written in the MS fonts will still cause this garbage 
  to render out. This should really be falling back to a sane font 
proper though.

Currently, the only real fix is to install webfonts.
Comment 3 Joe Marcus Clarke freebsd_committer 2009-05-23 20:29:30 UTC
State Changed
From-To: open->closed

This has been fixed by changing the default font to DejaVu Serif.
Comment 4 dfilter service freebsd_committer 2009-05-23 20:29:39 UTC
marcus      2009-05-23 19:29:25 UTC

  FreeBSD ports repository

  Modified files:
    editors/abiword      Makefile 
  Added files:
    editors/abiword/files patch-default-font 
  Log:
  Merge a patch from Fedora to chaneg the default font from Times Roman
  to DejaVu Serif.  This will fix the font corruption issue on machines
  which don't have webfonts installed, and still allow us to package
  abiword.
  
  PR:             134732
  
  Revision  Changes    Path
  1.133     +2 -0      ports/editors/abiword/Makefile
  1.1       +732 -0    ports/editors/abiword/files/patch-default-font (new)
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"