Bug 138872 - www/epiphany doesn't work when WITH_GECKO=libxul
www/epiphany doesn't work when WITH_GECKO=libxul
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: gnome
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-09-16 09:40 UTC by areilly
Modified: 2009-11-28 20:27 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description areilly 2009-09-16 09:40:02 UTC
	As part of the firefox2 eradication project I undertook
	recently, I rebuilt all of the firefox2 dependencies
	with WITH_GECKO=libxul defined in /etc/make.conf (and
	installed libxul, of course.)  Most things seem happy,
	but not epiphany.  It built cleanly, (and continues to
	build cleanly as I occasionally deinstall and reinstall
	it), but it doesn't run.  Instead, it produces
	stdout/stderr output something like:

###!!! ASSERTION: Failed to write xpti manifest!: 'Error', file xptiInterfaceInfoManager.cpp, line 1946
###!!! ASSERTION: Failed to write xpti manifest!: 'Error', file xptiInterfaceInfoManager.cpp, line 1946
*** Registering components in: xpconnect
*** Registering components in: nsUCvMathModule
*** Registering components in: nsUConvModule
*** Registering components in: nsI18nModule
*** Registering components in: nsChardetModule
*** Registering components in: nsUniversalCharDetModule
*** Registering components in: necko
[many more lines]
*** Registering components in: nsIconDecoderModule
LoadPlugin() /usr/local/lib/libxul/plugins/libnullplugin.so returned 80d5eb040
GetMIMEDescription() returned "*:.*:All types"
LoadPlugin() /usr/local/lib/libxul/plugins/libunixprintplugin.so returned 80d5eb1f0
GetMIMEDescription() returned "application/x-print-unix-nsplugin:.pnt:Demo Print Plugin for Unix/Linux"
###!!! ASSERTION: Failed to write xpti manifest!: 'Error', file xptiInterfaceInfoManager.cpp, line 1946
###!!! ASSERTION: nsTHashtable::Init() should not be called twice.: 'Error', file ../../dist/include/xpcom/nsTHashtable.h, line 321
###!!! ASSERTION: nsDirectoryService::RealInit Mustn't initialize twice!: '!gService', file nsDirectoryService.cpp, line 506
###!!! ASSERTION: CompMgr not null at init: 'nsComponentManagerImpl::gComponentManager == NULL', file nsXPComInit.cpp, line 567
###!!! ASSERTION: Forgot to call nsCycleCollector_shutdown?: '!sCollector', file nsCycleCollector.cpp, line 2922
###!!! ASSERTION: Failed to write xpti manifest!: 'Error', file xptiInterfaceInfoManager.cpp, line 1946

	The epiphany GUI window opens, but it is blank, and all
	mouse activity in the window causes more of the same
	sort of messages to stream forth on the controlling
	terminal.

	Clearly, this xpti manifest is a big issue, but I can't
	figure it out.  Anyone know what it's looking for, and
	where to find it?

Fix: 

I just use firefox3.5.3 at the moment, but since
	epiphany is still my defualt browser, functionality is
	impaired...
How-To-Repeat: 	# on a working and current GNOME system:
	cd /usr/ports/www/epiphany
	env WITH_GECKO=libxul make build deinstall reinstall clean
	epiphany
Comment 1 Mark Linimon freebsd_committer 2009-09-16 13:13:32 UTC
Responsible Changed
From-To: freebsd-ports-bugs->gnome

Fix synopsis and assign.
Comment 2 linimon 2009-09-16 22:59:51 UTC
----- Forwarded message from Kevin Downey <redchin@gmail.com> -----

Subject: Re: ports/138872: www/epiphany doesn't work when WITH_GECKO=libxul
From: Kevin Downey <redchin@gmail.com>
To: linimon@freebsd.org
Cc: freebsd-ports-bugs@freebsd.org, gnome@freebsd.org

epiphany ditched gecko for webkit a while back, the next gnome release
(2.28?) which will apparently land sometime after the 8.0 release will
have the webkit backed epiphany. the webkit version of epiphany is in
marcuscom ports: http://www.freebsd.org/gnome/docs/develfaq.html

----- End forwarded message -----
Comment 3 linimon 2009-09-16 23:00:30 UTC
On Wed, Sep 16, 2009 at 02:07:41PM -0700, Kevin Downey wrote:
> epiphany ditched gecko for webkit a while back, the next gnome release
> (2.28?) which will apparently land sometime after the 8.0 release will
> have the webkit backed epiphany. the webkit version of epiphany is in
> marcuscom ports: http://www.freebsd.org/gnome/docs/develfaq.html

ok, should this PR just be closed then?  I don't understand.

mcl
Comment 4 Joe Marcus Clarke freebsd_committer 2009-09-19 17:52:21 UTC
State Changed
From-To: open->analyzed

It works just fine for me.  Chances are you still have firefox installed. 
Uninstall www/firefox, then rebuild libxul and ephy, and everything should 
work.  Note, this PR will be moot when GNOME 2.28 is released as ephy will 
be using webkit-gtk2.
Comment 5 areilly 2009-09-27 06:24:57 UTC
Still broken for me, I'm afraid.  I had uninstalled firefox2
before I installed libxul, but this weekend I uninstalled
firefox3, and removed (I think) all trace of foxes from my
system, then reinstalled libxul and epiphany and it still breaks
as per the original bug submission.  I even moved my .mozilla
directory aside: no change.

Looking forward to webkit-gtk2 in 2.28...
Comment 6 areilly 2009-10-26 21:34:31 UTC
In the interests of trying every last avenue, I have now moved my
entire /usr/local tree (and associated /var/db details) aside and
re-installed all of my active ports from scratch.
Epiphany+libxul still does not work, as described above.  I
submit that anyone who does see it work is running something
old.  Well, that's not strictly true: the possibility still
exists that there is some cruft in my own user directory that is
confusing it, but I have moved ~/.mozilla aside without effect,
too.  Any other dotfile state that might have an impact?

Cheers,

-- 
Andrew
Comment 7 Joe Marcus Clarke freebsd_committer 2009-11-28 20:26:59 UTC
State Changed
From-To: analyzed->closed

This PR is now obsolete as Epiphany uses WebKit instead of Gecko.