Bug 138926 - [patch] freebsd-update(8): allow unattended upgrade
Summary: [patch] freebsd-update(8): allow unattended upgrade
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: bin (show other bugs)
Version: 7.2-RELEASE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-bugs mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-09-18 01:40 UTC by Tom Smith
Modified: 2019-06-01 22:22 UTC (History)
1 user (show)

See Also:


Attachments
file.diff (7.87 KB, patch)
2009-09-18 01:40 UTC, Tom Smith
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Smith 2009-09-18 01:40:01 UTC
This patch enables unattended upgrades by a setting in
the config file. When Unattended=yes is set, freebsd-update
assumes yes for all user prompts and writes everything
it would have written and confirmed with the user to standard
out without paging. This allows for unattended upgrades to
take place only if the user knows what they are doing and
specifically takes steps to enable this behavior. It is 
intended for environments with large numbers of identical
or very similar machines where a staging server is used
beforehand to verify that the unattended install will
proceed correctly. The administrator can send the output
to a file or through tee to keep a record of what happened
and review it after each step in the upgrade process.

Fix: The attached patch is for both the freebsd-update script and
the default configuration file (where Unattended defaults
to no and comments explain impact of setting to yes).

Patch attached with submission follows:
How-To-Repeat: To perform an unattended install with this patch, set
Unattended=yes in the freebsd-update.conf file and
run freebsd-update as directed in the FreeBSD Handbook.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2009-09-18 01:42:07 UTC
Responsible Changed
From-To: freebsd-bugs->cperciva

Over to maintainer.
Comment 2 Eitan Adler freebsd_committer freebsd_triage 2018-05-28 19:49:30 UTC
batch change:

For bugs that match the following
-  Status Is In progress 
AND
- Untouched since 2018-01-01.
AND
- Affects Base System OR Documentation

DO:

Reset to open status.


Note:
I did a quick pass but if you are getting this email it might be worthwhile to double check to see if this bug ought to be closed.
Comment 3 Colin Percival freebsd_committer 2019-03-12 23:00:10 UTC
Drop freebsd-update PRs which were assigned to me.  I'm not working on this code any more.
Comment 4 Tom Smith 2019-06-01 22:22:49 UTC
At least as of commit bd102b7 on master, freebsd-update.sh has a --not-running-from-cron option that appears to accomplish the intent of this change.  Withdrawing and closing.