Bug 139347 - [patch]finance/kmymoney2 port update to 1.0.0
Summary: [patch]finance/kmymoney2 port update to 1.0.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Sylvio Cesar Teixeira
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-04 16:30 UTC by Oleg Sidorkin
Modified: 2010-03-02 00:10 UTC (History)
0 users

See Also:


Attachments
file.diff (63.31 KB, patch)
2009-10-04 16:30 UTC, Oleg Sidorkin
no flags Details | Diff
patch2.diff (52.64 KB, patch)
2009-11-20 22:39 UTC, Oleg Sidorkin
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Sidorkin 2009-10-04 16:30:06 UTC

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2009-10-04 16:30:16 UTC
Maintainer of finance/kmymoney2,

Please note that PR ports/139347 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/139347

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2009-10-04 16:30:21 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Sylvio Cesar Teixeira freebsd_committer 2009-11-14 00:16:52 UTC
Responsible Changed
From-To: freebsd-ports-bugs->sylvio

I'll take it.
Comment 4 Sylvio Cesar Teixeira freebsd_committer 2009-11-20 21:22:06 UTC
Hi,

The patch is wrong, MASTER_SITES not found with release "1.0.0". The =
port too already have version 1.0.2.=20
It would be interesting you send the patch to the new version.
Comment 5 Oleg Sidorkin 2009-11-20 22:39:24 UTC
> Hi,
> 
> The patch is wrong, MASTER_SITES not found with release "1.0.0". The port
>  too already have version 1.0.2. It would be interesting you send the patch
>  to the new version.
> 

Hi,

I'm already using 1.0.2. 
The updated patch is in attachment.

Note that I've disabled sqlite3 because I don't know how to build and place 
the qt plugin required correctly.



Comment 6 Sylvio Cesar Teixeira freebsd_committer 2009-11-20 23:59:00 UTC
Sorry, but without the correct plugin I can not do the committ, we expect the maintainer to fix with the correct plugin, otherwise I will close without committing.=
Comment 7 Oleg Sidorkin 2009-11-21 08:52:59 UTC
Sorry, but without the correct plugin I can not do the committ, we expect
> the maintainer to fix with the correct plugin, otherwise I will close
> without committing.
>

KMymoney SQLite plugin works via qt sqlite plugin that is distributed with
KMyMoney. Is this right to install qt plugins with kmymoney? I don't know
what the exact policies are.

Thanks for your attention.

-- 
Oleg Sidorkin
Comment 8 Sylvio Cesar Teixeira freebsd_committer 2009-11-21 11:21:02 UTC
The maintainer of port is the better to answer this.
Comment 9 Sylvio Cesar Teixeira freebsd_committer 2010-02-09 12:44:39 UTC
Hi,

Please, fix this error:

http://people.freebsd.org/~sylvio/kmymoney2-1.0.2.log

Thanks.
Comment 10 Oleg Sidorkin 2010-02-16 08:48:18 UTC
>Hi,
>
>Please, fix this error:
>
>http://people.freebsd.org/~sylvio/kmymoney2-1.0.2.log
>
>Thanks.

Hi,

It seems that patch was not applied clean but I cannot identify the cause of 
the problem (was it diff or port itself).

Here is my version of the patched port I've build kmymoney-1.0.2 from:
http://komanda.troitsk.ws/kmymoney2.tar.gz

files/patch-ab fixes the command failed according to the log

Thanks.
Comment 11 Sylvio Cesar Teixeira freebsd_committer 2010-02-16 15:41:50 UTC
Ok, have a new version to port, 1.0.3, I am always working it.


Em 16/02/2010, =E0s 06:48, Oleg Sidorkin escreveu:

>> Hi,
>>=20
>> Please, fix this error:
>>=20
>> http://people.freebsd.org/~sylvio/kmymoney2-1.0.2.log
>>=20
>> Thanks.
>=20
> Hi,
>=20
> It seems that patch was not applied clean but I cannot identify the =
cause of=20
> the problem (was it diff or port itself).
>=20
> Here is my version of the patched port I've build kmymoney-1.0.2 from:
> http://komanda.troitsk.ws/kmymoney2.tar.gz
>=20
> files/patch-ab fixes the command failed according to the log
>=20
> Thanks.
Comment 12 Oleg Sidorkin 2010-02-18 07:37:56 UTC
Updated port:
http://komanda.troitsk.ws/kmymoney2-1.0.3.tar.gz

> Ok, have a new version to port, 1.0.3, I am always working it.
>
>
> Em 16/02/2010, às 06:48, Oleg Sidorkin escreveu:
>
>    
>>> Hi,
>>>
>>> Please, fix this error:
>>>
>>> http://people.freebsd.org/~sylvio/kmymoney2-1.0.2.log
>>>
>>> Thanks.
>>>        
>> Hi,
>>
>> It seems that patch was not applied clean but I cannot identify the cause of
>> the problem (was it diff or port itself).
>>
>> Here is my version of the patched port I've build kmymoney-1.0.2 from:
>> http://komanda.troitsk.ws/kmymoney2.tar.gz
>>
>> files/patch-ab fixes the command failed according to the log
>>
>> Thanks.
>>      
>
Comment 13 dfilter service freebsd_committer 2010-03-02 00:07:20 UTC
sylvio      2010-03-02 00:07:06 UTC

  FreeBSD ports repository

  Modified files:
    finance/kmymoney2    Makefile distinfo pkg-plist 
    finance/kmymoney2/files extra-patch-Makefile.in 
                            extra-patch-doc__en__Makefile.in 
                            patch-developer-doc__phb__Makefile.in 
                            patch-doc__en__Makefile.in 
  Added files:
    finance/kmymoney2/files patch-developer-doc__phb__Makefile.am 
                            patch-doc__en__Makefile.am 
  Removed files:
    finance/kmymoney2/files patch-kmymoney2__plugins__Makefile.in 
  Log:
  - Update to 1.0.3
  - Add new dependencies
  - Changed NOPORTS to stay of accord with the default.
  
  PR:             ports/139347
  Submitted by:   Oleg Sidorkin <OSidorkin@gmail.com>
  Approved by:    maintainer (timeout > 60 days), itetcu (mentor)
  Feature safe:   yes
  
  Revision  Changes    Path
  1.28      +11 -9     ports/finance/kmymoney2/Makefile
  1.10      +3 -3      ports/finance/kmymoney2/distinfo
  1.2       +9 -9      ports/finance/kmymoney2/files/extra-patch-Makefile.in
  1.2       +9 -9      ports/finance/kmymoney2/files/extra-patch-doc__en__Makefile.in
  1.1       +10 -0     ports/finance/kmymoney2/files/patch-developer-doc__phb__Makefile.am (new)
  1.2       +18 -29    ports/finance/kmymoney2/files/patch-developer-doc__phb__Makefile.in
  1.1       +20 -0     ports/finance/kmymoney2/files/patch-doc__en__Makefile.am (new)
  1.2       +28 -66    ports/finance/kmymoney2/files/patch-doc__en__Makefile.in
  1.2       +0 -11     ports/finance/kmymoney2/files/patch-kmymoney2__plugins__Makefile.in (dead)
  1.11      +896 -81   ports/finance/kmymoney2/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 14 Sylvio Cesar Teixeira freebsd_committer 2010-03-02 00:07:51 UTC
State Changed
From-To: feedback->closed

Committed, with minor changes. Thanks!