Bug 140067 - [boot] 8.0-RC2 from ISO, after install, hangs on boot right before loader
Summary: [boot] 8.0-RC2 from ISO, after install, hangs on boot right before loader
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: Warner Losh
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-10-29 03:30 UTC by Weldon Godfrey
Modified: 2019-01-07 07:47 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Weldon Godfrey 2009-10-29 03:30:01 UTC
I installed FreeBSD8.0-RC2 on a Dell 2950-iii, with the intention of moving the disks to another Dell 2950-iii.  The install won't boot.  After the boot loader, it just hangs with the "-" and doesn't get to the BSD loader menu.

I went ahead and tried to reinstall FreeBSD 8.0-RC2 on those disks, the installer was able to find the label and particians.  I went ahead and had it re-install over the disks (the holographic shell showed that the old data was there while it was reinstalling).  When it rebooted to boot up for the 1st time, it hung in the same part.  I took those disks back to the 2950-iii I originally installed it on and it booted fine.

The difference with the 2950-iii that will not boot 8.0-RC2 is:
1.  it is 16GB RAM instead of 8GB
2.  it has a 3ware 9690SE8 controller, with 24 SAS drives attached.

Both 2950-iii's are running the same version of BIOS

I am installing FreeBSD onto a set of RAID1 disks on PERC/6i controllers. 

Is there a problem with the loader with lots of disks visible?  or is it a problem having two controllers and/or a issue with the 3ware controller?

I put back my old disks running an old version of 8.0-CURRENT (DEC 12th i think), it came back up.   However, I remember that I had to use a loader from 7.0-CURRENT because newer loaders would not load (however, it would hang after the loader menu).

How-To-Repeat: see full descr.
Comment 1 Weldon Godfrey 2009-10-29 12:58:43 UTC
Ok, after coming in this morning I carefully checked the PERC controller
versions in the two Dells, the one that can book 8.0-RC2 is a PERC 5/I,
the one that cannot is a PERC 6/i.  Is there any known issues with
PERC6/I controllers?

Thanks!

-----Original Message-----
From: FreeBSD-gnats-submit@FreeBSD.org
[mailto:FreeBSD-gnats-submit@FreeBSD.org]=20
Sent: Wednesday, October 28, 2009 10:30 PM
To: Weldon Godfrey
Subject: Re: amd64/140067: [boot] 8.0-RC2 from ISO, after install, hangs
on boot right before loader

Thank you very much for your problem report.
It has the internal identification `amd64/140067'.
The individual assigned to look at your
report is: freebsd-amd64.=20

You can access the state of your problem report at any time
via this link:

http://www.freebsd.org/cgi/query-pr.cgi?pr=3D140067

>Category:       amd64
>Responsible:    freebsd-amd64
>Synopsis:       [boot] 8.0-RC2 from ISO, after install, hangs on boot
right before loader
>Arrival-Date:   Thu Oct 29 03:30:01 UTC 2009
Comment 2 Weldon Godfrey 2009-11-01 16:30:29 UTC
I went ahead and tested booting 8.0-RC2 in the Dell with the Perc5/I and
a spare 3ware card, it booted

Ok, I swapped the computers around, this would mean I would try to boot
with our 3ware controller and with our drive chasis attached and using
the Perc5/I, it hung at "-" after boot manager again.

I disconnected the drive chasis (we have two SAS chasis with a total of
24 drive).  It booted.  I had thought I tried this before bit this time
it worked.  I tried just attaching 1 chasis and 12 drives.  It locked up
at the "-" again

I went into the 3ware controller and disabled the ability to boot from
the 3ware card (we don't need to boot from it anyway), and with both
chasis attached, it worked.

We went ahead and went back to the computer with a PERC6/I controller
and it worked with the 3ware BIOS set not able to boot.


So it appears, that something has happened during the boot/loader
process in 8.0-RC2 that doesn't like the 3ware controller advertising
its drives as bootable.

This ticket is attached to amd64 but that was my mistake.  This problem
happens pre-kernel.   Let me know if someone can change the category of
if you prefer for me to submit a new PR.

Thanks!!!

Weldon =20
Comment 3 Mark Linimon freebsd_committer freebsd_triage 2009-11-01 16:41:28 UTC
Responsible Changed
From-To: freebsd-amd64->freebsd-bugs

Reclassified at submitter's request.
Comment 4 kah42pub 2009-12-06 22:59:24 UTC
This same problem is present with 8.0-RELEASE.  3Ware 9650SE card with  
the same problem if any drives are presented.  The boot loader hangs.
Comment 5 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:00 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped