Bug 140074 - www/oops does not compile
www/oops does not compile
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: pav
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-10-29 10:10 UTC by Dmitry Afanasiev
Modified: 2009-12-18 18:10 UTC (History)
0 users

See Also:


Attachments
file.diff (297 bytes, patch)
2009-10-29 10:10 UTC, Dmitry Afanasiev
no flags Details | Diff
make.conf (1.29 KB, text/plain)
2009-12-17 15:16 UTC, Dmitry Afanasiev
no flags Details
make.out (848 bytes, text/plain)
2009-12-17 15:16 UTC, Dmitry Afanasiev
no flags Details
make_showconfig.out (301 bytes, text/plain)
2009-12-17 15:16 UTC, Dmitry Afanasiev
no flags Details
uname-a.out (143 bytes, text/plain)
2009-12-17 15:16 UTC, Dmitry Afanasiev
no flags Details
config.log (90.78 KB, text/plain)
2009-12-18 11:30 UTC, Dmitry Afanasiev
no flags Details
make_configure.out (6.22 KB, text/plain)
2009-12-18 11:30 UTC, Dmitry Afanasiev
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitry Afanasiev 2009-10-29 10:10:00 UTC
# cd /usr/ports/www/oops && make
[skipped]
cd modules; make
cc -O2 -pipe -fno-strict-aliasing -fPIC -D_REENTRANT -DFREEBSD -D_THREAD_SAFE -DFD_SETSIZE=2048 -I. -DWITH_LARGE_FILES  -I/usr/local/include/db4 -export-dynamic -DHAVE_CONFIG_H -I/usr/local/include/db4 -shared  -c log_dummy.c
ld -shared  -o log_dummy.so log_dummy.o -pthread -lfl -lfl -lpam  -lcrypt  -L/usr/local/lib -ldb4
ld: unrecognized option '-pthread'
ld: use the --help option for usage information
*** Error code 1

Stop in /var/ports/usr/ports/www/oops/work/oops-1.5.24/src/modules.
*** Error code 1

Stop in /var/ports/usr/ports/www/oops/work/oops-1.5.24/src.
*** Error code 1

Stop in /var/ports/usr/ports/www/oops/work/oops-1.5.24.
*** Error code 1

Stop in /usr/ports/www/oops.
*** Error code 1

Stop in /usr/ports/www/oops.
*** Error code 1

Stop in /usr/ports/www/oops.

Fix: I'm not sure of the correctness of the patch, but with this patch www/oops builds successfully:
How-To-Repeat: cd /usr/ports/www/oops && make
Comment 1 Edwin Groothuis freebsd_committer 2009-10-29 10:10:12 UTC
Responsible Changed
From-To: freebsd-ports-bugs->marck

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 pav freebsd_committer 2009-12-14 22:20:21 UTC
State Changed
From-To: open->feedback

Cannot reproduce. 

Somehow -pthread is getting into your LDFLAGS. Can you copy "make showconfig" 
output for www/oops, and your /etc/make.conf ? 


Comment 3 pav freebsd_committer 2009-12-14 22:20:21 UTC
Responsible Changed
From-To: marck->pav

Cannot reproduce. 

Somehow -pthread is getting into your LDFLAGS. Can you copy "make showconfig" 
output for www/oops, and your /etc/make.conf ?
Comment 4 Dmitry Afanasiev 2009-12-17 15:16:50 UTC
Hello!

> Somehow -pthread is getting into your LDFLAGS. Can you copy "make showconfig"
> output for www/oops, and your /etc/make.conf ?
Attached /etc/make.conf and outputs of commands:
uname -a
make showconfig
make

I reproduced the problem on fresh installed in virtualbox fbsd 9.0 
builded with my make.conf.
Comment 5 pav freebsd_committer 2009-12-17 15:46:26 UTC
Can I also see the output of `make configure' in the port, and a copy of
work/oops-1.5.24/config.log file?

-- 
Pav Lucistnik <pav@oook.cz>
              <pav@FreeBSD.org>

Go back to bed America, your government is in control again.  Here's
American Gladiators.  Watch this, shut up.  Here's 56 channels of it.
Watch these pituitary retards bang their fuckin skulls together and
congratulate you on living in the land of freedom.
  -- Bill Hicks
Comment 6 Dmitry Afanasiev 2009-12-18 11:30:32 UTC
Pav Lucistnik wrote:
> Can I also see the output of `make configure' in the port, and a copy of
> work/oops-1.5.24/config.log file?
Requested files attached.
Also I can send you a virtualvox's image with installed fbsd 9.0 amd64, 
where you can see the problem :)
Comment 7 Dmitry Afanasiev 2009-12-18 17:58:30 UTC
Pav Lucistnik wrote:
> I think I see the problem. It's limited to 9-CURRENT, that's why I
> couldn't see it first.

> Try attached patch.
Omg. Yes, this patch solves the problem...

-+ 	    [[5678]]*)
++ 	    [[56789]]*)
It was really difficult problem. :)
I had to have known about the decision :(
Comment 8 pav freebsd_committer 2009-12-18 18:05:31 UTC
State Changed
From-To: feedback->closed

Fixed
Comment 9 dfilter freebsd_committer 2009-12-18 18:05:59 UTC
pav         2009-12-18 18:05:45 UTC

  FreeBSD ports repository

  Modified files:
    www/oops/files       patch-configure.in 
  Log:
  - Fix on 9.x
  
  PR:             ports/140074
  Reported by:    Dmitry Afanasiev <KOT@MATPOCKuH.Ru>
  
  Revision  Changes    Path
  1.13      +1 -1      ports/www/oops/files/patch-configure.in
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"