Bug 141885 - [MAINTAINER] audio/murmur: update to 1.2.0
Summary: [MAINTAINER] audio/murmur: update to 1.2.0
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dmitry Marakasov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-12-22 10:30 UTC by Ayumi M
Modified: 2010-01-12 18:30 UTC (History)
0 users

See Also:


Attachments
murmur-1.2.0.patch (6.99 KB, patch)
2009-12-22 10:30 UTC, Ayumi M
no flags Details | Diff
murmur-1.2.0.patch (7.48 KB, patch)
2009-12-22 11:30 UTC, Ayumi M
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Ayumi M 2009-12-22 10:30:06 UTC
- Update to 1.2.0

Added file(s):
- files/freebsd6-patch-compiler.pri

Removed file(s):
- files/patch-src__CryptState.cpp
- files/patch-src__murmur__murmur_pch.h

Tested with Tinderbox
http://tb-amd64.commun.jp/index.php?action=describe_port&id=1
http://tb-i386.commun.jp/index.php?action=describe_port&id=3

Generated with FreeBSD Port Tools 0.99
Comment 1 Ayumi M 2009-12-22 11:16:05 UTC
rc.d script problem in the patch, sorry...
attached new patch.

http://ayu.commun.jp/files/murmur-1.2.0.patch
Comment 2 Dmitry Marakasov freebsd_committer 2009-12-22 11:19:43 UTC
Responsible Changed
From-To: freebsd-ports-bugs->amdmi3

I'll take it.
Comment 3 Ayumi M 2009-12-22 11:30:17 UTC
rc.d script problem in the patch, sorry...
attached new patch.

-- 
Ayumi Mitsui        http://ayu.commun.jp/
PGP: EE97 796C 77F6 CFC9 1FBC  C56A 318B F019 E605 D988
Comment 4 Pascal G. Hofstee 2009-12-25 11:48:04 UTC
Moin,

After manually applying the patch provided in the PR to my ports-tree
the build bails out during the final linking stage of murmurd.
The cause of the linking problem seems to be a missing
-fstack-protector in src/murmur/Makefile.Debug LFLAGS specification.
After adding -fstack-protector there the build completed as expected.

With kind regards,
  Pascal Hofstee
Comment 5 Dmitry Marakasov 2009-12-29 02:15:22 UTC
Hi!

> Synopsis: [MAINTAINER] audio/murmur: update to 1.2.0
> 
> http://www.freebsd.org/cgi/query-pr.cgi?pr=141885

How about this patch:
http://people.freebsd.org/~amdmi3/murmur.patch

added -fstack-protector fix, also remove unneeded HAS_CONFIGURE
and add QMAKEFLAGS (so CC/CXX/FLAGS are respected).

-- 
Dmitry Marakasov   .   55B5 0596 FF1E 8D84 5F56  9510 D35A 80DD F9D2 F77D
amdmi3@amdmi3.ru  ..:  jabber: amdmi3@jabber.ru    http://www.amdmi3.ru
Comment 6 Dmitry Marakasov freebsd_committer 2010-01-12 18:26:33 UTC
State Changed
From-To: open->closed

Committed, with minor changes. Thanks!
Comment 7 dfilter service freebsd_committer 2010-01-12 18:26:35 UTC
amdmi3      2010-01-12 18:26:26 UTC

  FreeBSD ports repository

  Modified files:
    audio/murmur         Makefile distinfo pkg-plist 
    audio/murmur/files   murmur.in patch-compiler.pri 
  Added files:
    audio/murmur/files   freebsd6-patch-compiler.pri 
  Removed files:
    audio/murmur/files   patch-src__CryptState.cpp 
                         patch-src__murmur__murmur_pch.h 
  Log:
  - Update to 1.2.0
  
  PR:             141885
  Submitted by:   Ayumi Mitsui <ayu@commun.jp> (maintainer)
  
  Revision  Changes    Path
  1.4       +21 -6     ports/audio/murmur/Makefile
  1.2       +3 -3      ports/audio/murmur/distinfo
  1.1       +24 -0     ports/audio/murmur/files/freebsd6-patch-compiler.pri (new)
  1.2       +2 -2      ports/audio/murmur/files/murmur.in
  1.2       +11 -13    ports/audio/murmur/files/patch-compiler.pri
  1.2       +0 -11     ports/audio/murmur/files/patch-src__CryptState.cpp (dead)
  1.2       +0 -10     ports/audio/murmur/files/patch-src__murmur__murmur_pch.h (dead)
  1.2       +1 -1      ports/audio/murmur/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"