Bug 145171 - cannot compile editors/emacs after graphics/png upgrade
Summary: cannot compile editors/emacs after graphics/png upgrade
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Dirk Meyer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-29 16:00 UTC by rotkap
Modified: 2010-03-30 19:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rotkap 2010-03-29 16:00:17 UTC
Since I updated my port graphics/png with portupgrade -fr graphics/png  like mentioned in $PORTSDIR/UPDATING  I cannot compile editors/emacs:


cc -nostdlib `./prefix-args -Xlinker  -L/usr/local/lib -znocombreloc` -L/usr/local/lib -lintl -Wl,-znocombreloc -L/usr/local/lib -o temacs pre-crt0.o /usr/lib/crt1.o /usr/lib/crti.o /usr/lib/crtbegin.o dispnew.o frame.o scroll.o xdisp.o menu.o xmenu.o window.o charset.o coding.o category.o ccl.o character.o chartab.o cm.o term.o terminal.o xfaces.o xterm.o xfns.o xselect.o xrdb.o fontset.o xsmfns.o fringe.o image.o gtkutil.o dbusbind.o emacs.o keyboard.o macros.o keymap.o sysdep.o buffer.o filelock.o insdel.o marker.o minibuf.o fileio.o dired.o filemode.o cmds.o casetab.o casefiddle.o indent.o search.o regex.o undo.o alloc.o data.o doc.o editfns.o callint.o eval.o floatfns.o fns.o font.o print.o lread.o syntax.o unexelf.o bytecode.o process.o callproc.o region-cache.o sound.o atimer.o doprnt.o strftime.o intervals.o textprop.o composite.o md5.o    xfont.o ftfont.o xftfont.o ftxfont.o terminfo.o lastfile.o gmalloc.o  vm-limit.o      -L/usr/local/lib -pthread -L/usr/local/lib -
 lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangocairo-1.0 -lgio-2.0 -lXext -lXrender -lXinerama -lXi -lXrandr -lXcursor -lXcomposite -lXdamage -lpangoft2-1.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm -lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lpthread -lSM -lICE -ltiff -ljpeg -lpng -lz -lm -lungif -lXpm -lX11 -L/usr/local/lib -lXft -lXrender -lfontconfig -lfreetype -lX11  -pthread -L/usr/local/lib -lrsvg-2 -lgdk_pixbuf-2.0 -lm -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -pthread -L/usr/local/lib -ldbus-1 -lutil -lncurses  -L/usr/local/lib -lz -lotf -lfreetype -L/usr/local/lib -lm17n-flt -lm17n-core  -lm -lgcc -lc -lgcc /usr/lib/crtend.o /usr/lib/crtn.o
image.o(.text+0x65d3): In function `png_load':
: undefined reference to `png_check_sig'
image.o(.text+0x6c01): In function `png_load':
: undefined reference to `png_check_sig'
gmake[1]: *** [temacs] Error 1
gmake[1]: Leaving directory `/usr/ports/editors/emacs/work/emacs-23.1/src'
gmake: *** [src] Error 2
*** Error code 1

Stop in /usr/ports/editors/emacs.
*** Error code 1

Stop in /usr/ports/editors/emacs.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20100329-51433-2juqds-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=emacs-23.1_3,1 UPGRADE_PORT_VER=23.1_3,1 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! editors/emacs (emacs-23.1_3,1)        (linker error)

How-To-Repeat: cd /usr/ports/editors/emacs ; make
Comment 1 Edwin Groothuis freebsd_committer 2010-03-29 16:00:29 UTC
Maintainer of editors/emacs,

Please note that PR ports/145171 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/145171

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2010-03-29 16:00:31 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Frédéric Perrin 2010-03-29 19:33:43 UTC
Hello,

The problem is known and fixed upstream, with a rather small patch:

Initial patch:
<http://repos.archlinux.org/wsvn/packages/emacs/trunk/libpng14.patch>

emacs-devel, libpng 1.4.x, Herbert J. Skuhr & Chong Yidong:
<http://lists.gnu.org/archive/html/emacs-devel/2010-01/msg01144.html>

-- 
Fred
Comment 4 Dirk Meyer freebsd_committer 2010-03-30 05:30:15 UTC
Responsible Changed
From-To: freebsd-ports-bugs->dinoex

I will take care of it.
Comment 5 Dirk Meyer freebsd_committer 2010-03-30 08:21:38 UTC
Responsible Changed
From-To: dinoex->closed
Comment 6 Dirk Meyer freebsd_committer 2010-03-30 08:21:52 UTC
Responsible Changed
From-To: closed->dinoex

- undo
Comment 7 Dirk Meyer freebsd_committer 2010-03-30 08:22:06 UTC
State Changed
From-To: feedback->closed

committed, thanks.
Comment 8 Frédéric Perrin 2010-03-30 18:35:30 UTC
Hello dinoex,

I'm afraid the patch you committed is wrong: png_sig_cmp() is true when
the signature does *not* correspond to that of a proper PNG file, so
you shouldn't invert the result of png_sig_cmp().  Indeed, when opening
a file that is a PNG, emacs no longer displays it.

Would it be possible to use the patch that was installed upstream?

Discussion about the proper fix:
Re: libpng-1.4.x
<http://lists.gnu.org/archive/html/emacs-devel/2010-01/msg01144.html>
Chong Yidong & Herbert J. Skuhra.

Upstream bzr commit:
revno: 99377.1.36
committer: Chong Yidong <cyd (@) stupidchicken.com>
branch nick: trunk
timestamp: Sun 2010-01-24 18:03:13 -0500

(No direct HTTP link, with Savannah's broken loggerhead)

Thanks,

-- 
Fred
Comment 9 dfilter service freebsd_committer 2010-03-30 19:15:52 UTC
dinoex      2010-03-30 18:15:38 UTC

  FreeBSD ports repository

  Modified files:
    editors/emacs        Makefile 
    editors/emacs/files  patch-src-image.c 
    editors/emacs-devel  Makefile 
    editors/emacs-devel/files patch-src-image.c 
    editors/emacs22      Makefile 
    editors/emacs22/files patch-src-image.c 
  Log:
  - update patch png14
  PR:             145171
  
  Revision  Changes    Path
  1.38      +1 -1      ports/editors/emacs-devel/Makefile
  1.2       +2 -2      ports/editors/emacs-devel/files/patch-src-image.c
  1.91      +1 -1      ports/editors/emacs/Makefile
  1.3       +2 -2      ports/editors/emacs/files/patch-src-image.c
  1.89      +1 -1      ports/editors/emacs22/Makefile
  1.2       +2 -2      ports/editors/emacs22/files/patch-src-image.c
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"