Bug 148004 - [em] Inconsistent networking with em driver on FreeBSD 8.0-p2
Summary: [em] Inconsistent networking with em driver on FreeBSD 8.0-p2
Status: Closed Overcome By Events
Alias: None
Product: Base System
Classification: Unclassified
Component: kern (show other bugs)
Version: unspecified
Hardware: Any Any
: Normal Affects Only Me
Assignee: jfv
URL:
Keywords: IntelNetworking
Depends on:
Blocks:
 
Reported: 2010-06-20 06:20 UTC by Bill Clark
Modified: 2015-06-30 17:45 UTC (History)
1 user (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bill Clark 2010-06-20 06:20:02 UTC
Machine with dual Intel(R) PRO/1000 Network Connection using em driver, updated to latest version 6.9.21 from Intel website (initially 6.9.14 with same problem) will connect fine to one (older) switch but completely non-functional (despite link lights) on another (newer) switch.  There's nothing wrong with the switch, since a dozen other FreeBSD machines (using bge or fxp) all work fine on it.  I've looked through many similar problem reports online and none of the diagnostic steps or fixes have helped.  No errors of any kind are reported.. the networking simply does not work, as if the interface were down.  Changing to the other switch, it works perfectly.  I unfortunately do not have the details about what models the two different switches are, as they're in a remote datacenter and my remote assistant gave up in frustration after the millionth time I had him juggle connections around.

dmesg:

em0: <Intel(R) PRO/1000 Network Connection 6.9.21> port 0xcc00-0xcc3f mem 0xfc9e0000-0xfc9fffff irq 74 at device 1.0 on pci5
em0: [FILTER]
em0: Ethernet address: 00:30:48:85:b0:44

sysctl -a:

dev.em.0.%desc: Intel(R) PRO/1000 Network Connection 6.9.21
dev.em.0.%driver: em
dev.em.0.%location: slot=1 function=0
dev.em.0.%pnpinfo: vendor=0x8086 device=0x1076 subvendor=0x15d9 subdevice=0x1076 class=0x020000
dev.em.0.%parent: pci5
dev.em.0.debug: -1
dev.em.0.stats: -1
dev.em.0.rx_int_delay: 0
dev.em.0.tx_int_delay: 66
dev.em.0.rx_abs_int_delay: 66
dev.em.0.tx_abs_int_delay: 66
dev.em.0.rx_processing_limit: 100

ifconfig -a:

em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=389b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,WOL_UCAST,WOL_MCAST,WOL_MAGIC>
        ether 00:30:48:85:b0:44
        inet 10.0.0.104 netmask 0xffffff00 broadcast 10.0.0.255
        media: Ethernet autoselect (1000baseT <full-duplex>)
        status: active

netstat -rn:

Destination        Gateway            Flags    Refs      Use  Netif Expire
10.0.0.0/24        link#1             U           0        8    em0
Comment 1 Bill Clark 2010-06-20 07:15:58 UTC
I tried the steps from this recommendation in the README for the
driver from Intel (since it sounded very much like the problem I'm
experiencing) but it did not help:

 82541/82547 can't link or is slow to link with some link partners
  -----------------------------------------------------------------

  There is a known compatibility issue where time to link is slow or link i=
s not
  established between 82541/82547 controllers and some switches.  Known swi=
tches
  include:
        Planex FXG-08TE
        I-O Data ETG-SH8

  The driver can be compiled with the following changes:

  Edit ./em.x.x.x/src/if_em.h to change the #define EM_MASTER_SLAVE
  For example, change from:

      #define EM_MASTER_SLAVE   e1000_ms_hw_default
  to:
      #define EM_MASTER_SLAVE   2

On Sat, Jun 19, 2010 at 10:20 PM,  <FreeBSD-gnats-submit@freebsd.org> wrote=
:
> Thank you very much for your problem report.
> It has the internal identification `kern/148004'.
> The individual assigned to look at your
> report is: freebsd-bugs.
>
> You can access the state of your problem report at any time
> via this link:
>
> http://www.freebsd.org/cgi/query-pr.cgi?pr=3D148004
>
>>Category: =A0 =A0 =A0 kern
>>Responsible: =A0 =A0freebsd-bugs
>>Synopsis: =A0 =A0 =A0 Inconsistent networking with em driver on FreeBSD 8=
.0-p2
>>Arrival-Date: =A0 Sun Jun 20 05:20:02 UTC 2010
>
Comment 2 Mark Linimon freebsd_committer freebsd_triage 2010-06-20 10:12:56 UTC
Responsible Changed
From-To: freebsd-bugs->freebsd-net

Over to maintainer(s).
Comment 3 Andre Oppermann freebsd_committer 2010-08-23 15:30:22 UTC
Responsible Changed
From-To: freebsd-net->jfv

Over to maintainer.
Comment 4 Sean Bruno freebsd_committer 2015-06-30 17:45:23 UTC
There have been significant updates to the em(4) driver over the last 4 years.  I suspect this works now.