Bug 149430 - [patch] net/mDNSResponder mark MAKE_JOBS_UNSAFE
Summary: [patch] net/mDNSResponder mark MAKE_JOBS_UNSAFE
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Rene Ladan
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-08-08 15:50 UTC by Ivan Klymenko
Modified: 2010-08-20 22:20 UTC (History)
0 users

See Also:


Attachments
file.diff (324 bytes, patch)
2010-08-08 15:50 UTC, Ivan Klymenko
no flags Details | Diff
patch-mdnsresponder (1.15 KB, text/plain)
2010-08-14 17:50 UTC, Tilman Keskinoz
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Klymenko 2010-08-08 15:50:07 UTC
The port sometimes doesn't build when FORCE_MAKE_JOBS is defined.

===>  Building for mDNSResponder-214.3.2
gmake[1]: Entering directory `/usr/ports_build/usr/ports/net/mDNSResponder/work/mDNSResponder-214.3.2/Clients'
mkdir build
cc dns-sd.c ClientCommon.c -L../mDNSPosix/build/prod/ -ldns_sd -I../mDNSShared -Wall -o build/dns-sd
/usr/bin/ld: cannot find -ldns_sd
distcc[24109] ERROR: compile dns-sd.c on localhost failed
gmake[1]: *** [build/dns-sd] Ошибка 1
gmake[1]: Leaving directory `/usr/ports_build/usr/ports/net/mDNSResponder/work/mDNSResponder-214.3.2/Clients'
gmake: *** [../Clients/build/dns-sd] Ошибка 2
gmake: *** Ожидание завершения заданий...
===> Compilation failed unexpectedly.
You have chosen to use multiple make jobs (parallelization) for all ports.
This port was not tested for this setting.  Please remove FORCE_MAKE_JOBS and
retry the build before reporting the failure to the maintainer.
*** Error code 1

Stop in /usr/ports/net/mDNSResponder.

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2010-08-08 15:50:14 UTC
Maintainer of net/mDNSResponder,

Please note that PR ports/149430 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/149430

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2010-08-08 15:50:16 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Rene Ladan freebsd_committer 2010-08-08 16:07:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->rene

Grab
Comment 4 Tilman Keskinoz freebsd_committer 2010-08-14 17:50:00 UTC
The problem seems to be easy to fix.

See attachment.
Comment 5 Rene Ladan freebsd_committer 2010-08-17 17:08:41 UTC
On 17-08-2010 17:37, Sunpoet Hsieh wrote:
> On Sun, Aug 8, 2010 at 11:07 PM,<rene@freebsd.org>  wrote:
>> Synopsis: [patch] net/mDNSResponder mark MAKE_JOBS_UNSAFE
>>
>> Responsible-Changed-From-To: freebsd-ports-bugs->rene
>> Responsible-Changed-By: rene
>> Responsible-Changed-When: Sun Aug 8 15:07:25 UTC 2010
>> Responsible-Changed-Why:
>> Grab
>>
>> http://www.freebsd.org/cgi/query-pr.cgi?pr=149430
>>
>
> Hi Rene,
>
> arved@ has submitted a patch which solves the problem.
> It works fine.
> Would you please review it?

I could not reproduce the error on some tinderboxes with the
old version, so I think the patch is fine.

It also looks like this patch fixes the name of the manual page
(mDNSResponderPosix(8) instead of mDNSResponder(8) ).

Regards,
Rene
-- 
http://www.rene-ladan.nl/

GPG fingerprint = ADBC ECCD EB5F A6B4 549F  600D 8C9E 647A E564 2BFC 
(subkeys.pgp.net)
Comment 6 dfilter service freebsd_committer 2010-08-20 22:13:47 UTC
rene        2010-08-20 21:13:38 UTC

  FreeBSD ports repository

  Modified files:
    net/mDNSResponder/files patch-mDNSPosix_Makefile 
  Log:
  - make multi-job safe
  - fix filename of manual page (should be mDNSResponderPosix(8))
  
  PR:             ports/149430
  Submitted by:   Ivan Klymenko [fidaj ukr.net], actual patch from arved
  Approved by:    maintainer
  
  Revision  Changes    Path
  1.5       +24 -2     ports/net/mDNSResponder/files/patch-mDNSPosix_Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Rene Ladan freebsd_committer 2010-08-20 22:13:51 UTC
State Changed
From-To: feedback->closed

Committed, thanks