Bug 152400 - [PATCH] x11/nvidia-driver, x11/nvidia-settings, x11/nvidia-xconfig: Update from 256.53 to 260.19.21
Summary: [PATCH] x11/nvidia-driver, x11/nvidia-settings, x11/nvidia-xconfig: Update fr...
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Alexey Dokuchaev
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-19 12:00 UTC by Sender Ghost
Modified: 2011-05-23 13:10 UTC (History)
0 users

See Also:


Attachments
nv.patch (4.66 KB, patch)
2010-12-15 02:01 UTC, Sender Ghost
no flags Details | Diff
nv.patch (7.33 KB, patch)
2011-01-16 01:40 UTC, Sender Ghost
no flags Details | Diff
nv.patch (7.33 KB, patch)
2011-01-22 03:20 UTC, Sender Ghost
no flags Details | Diff
nv.patch (4.18 KB, patch)
2011-02-01 17:28 UTC, Sender Ghost
no flags Details | Diff
nvidia-driver.patch (4.37 KB, patch)
2011-02-23 08:22 UTC, Sender Ghost
no flags Details | Diff
nvidia-settings.patch (2.01 KB, patch)
2011-02-23 08:22 UTC, Sender Ghost
no flags Details | Diff
nvidia-xconfig.patch (1.73 KB, patch)
2011-02-23 08:22 UTC, Sender Ghost
no flags Details | Diff
nvidia-driver.patch (4.69 KB, patch)
2011-03-09 03:27 UTC, Sender Ghost
no flags Details | Diff
nvidia-settings.patch (1.73 KB, patch)
2011-03-09 03:27 UTC, Sender Ghost
no flags Details | Diff
nvidia-xconfig.patch (1.74 KB, patch)
2011-03-09 03:27 UTC, Sender Ghost
no flags Details | Diff
nvidia-driver.patch (3.91 KB, patch)
2011-04-22 17:12 UTC, Sender Ghost
no flags Details | Diff
nvidia-settings.patch (2.02 KB, patch)
2011-04-22 17:12 UTC, Sender Ghost
no flags Details | Diff
nvidia-xconfig.patch (1.74 KB, patch)
2011-04-22 17:12 UTC, Sender Ghost
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Sender Ghost 2010-11-19 12:00:19 UTC
Patch to update x11/nvidia-driver, x11/nvidia-settings, x11/nvidia-xconfig ports from 256.53 to 260.19.21 version.

Look following links for changes:
http://www.nvidia.com/object/freebsd-x86-260.19.21-driver.html
http://www.nvidia.com/object/freebsd-x64-260.19.21-driver.html

Descending changelog from 260.19.21 to 256.53 (not inclusive) version:
2010-11-11 version 260.19.21

    * Fixed a bug that may cause OpenGL applications which fork to crash.

    * Fixed a bug in VDPAU that caused it to attempt allocation of huge
      blocks of system memory. This regression was introduced in the
      260.* driver series.

2010-10-13 version 260.19.12

    * Added support for the following GPUs:

        * GeForce GTS 450
        * GeForce GTX 460M
        * GeForce GT 415M
        * GeForce GT 425M
        * GeForce GT 420M
        * GeForce GT 435M

        * Quadro 2000
        * Quadro 600

2010-09-15 version 260.19.06

    * Fixed an interaction problem with a change in X server behavior that
      caused slow text rendering on X.Org xserver 1.9.

    * Enhanced VDPAU to support interop with CUDA and OpenGL when Xinerama
      is active.

    * Fixed a bug in VDPAU that prevented temporal-spatial de-interlacing from
      operating when temporal de-interlacing was not also enabled.

    * Added support for configuring the dithering depth used when driving
      a flat panel with a GeForce 8 family or Quadro 4600/5600 or
      newer GPU.  See the "Dithering Controls" in the Flat Panel page
      in nvidia-settings.

2010-09-08 version 260.19.04

    * Stopped packaging and installing OpenGL and VDPAU header files
      with the driver.  Those interested in these files can get them from
      their distributions' packages, where available, or upstream from:

        OpenGL header files (gl.h, glext.h glx.h, glxext.h):
            http://www.opengl.org/registry/

        VDPAU header files (vdpau.h and vdpau_x11.h):
            http://freedesktop.org/wiki/Software/VDPAU

      Note that while libvdpau.so is still included in 260.xx drivers,
      it will be removed from a future release series in early 2011.
      Distributors are encouraged to package libvdpau.so from
      http://freedesktop.org/wiki/Software/VDPAU

    * Fixed a bug in VDPAU that could cause a "display preemption" when
      toggling MPlayer to full-screen the first time.

    * Added OpenGL 4.1 support for Quadro Fermi, GeForce GTX 4xx, and
      later GPUs.

    * Enhanced VDPAU to fully support Xinerama.

    * Fixed a bug in the X driver that prevented operation of Xinerama when
      using multiple NVIDIA GPUs from different major hardware generations
      on X with ABI 4 or greater.

    * Fixed a bug in the OpenGL driver's Xinerama support.

      Rendering should have ocurred to all physical X screens driven by an
      NVIDIA GPU compatible with the NVIDIA GPU driving physical X screen 0.
      However, if some physical X screen did not satisfy that requirement,
      then not only would that physical X screen not be rendered to (as
      expected), but also all physical X screens with a higher number would
      not be rendered to (which was unexpected).

    * Added GPU "Processor Clock" reporting to the nvidia-settings PowerMizer
      page.

    * Implemented support for SLI Mosaic Mode on Quadro FX 5800 and
      Quadro Fermi and newer Quadro GPUs.

    * Enhanced the VDPAU overlay-based presentation queue to allow it to be
      used when SLI is active, and in some cases when the X composite
      extension is enabled. See the README for further details.

    * Added support for configuring the dithering mode used when driving
      a flat panel with a GeForce 8 family or Quadro 4600/5600 or
      newer GPU.  See the "Dithering Controls" in the Flat Panel page
      in nvidia-settings.

    * Added unofficial GLX protocol support (i.e., for GLX indirect
      rendering) for the following OpenGL extensions:
      GL_EXT_texture_integer
      GL_ARB_stencil_two_side
      GL_EXT_transform_feedback2
      GL_NV_transform_feedback2
      GL_NV_conditional_render

    * Added GLX protocol support (i.e., for GLX indirect rendering)
      for the following OpenGL extensions:
      GL_NV_point_sprite
      GL_EXT_stencil_two_side
      GL_EXT_point_parameters
      GL_ARB_transpose_matrix
      GL_EXT_framebuffer_blit
      GL_EXT_framebuffer_multisample

    * GLX protocol for the following OpenGL extension is promoted
      from unofficial GLX ptotocol to ARB approved GLX protocol:
      GL_EXT_geometry_shader4
      GL_ARB_shader_objects
      GL_ARB_vertex_shader
      GL_ARB_fragment_shader

    * Added support for configuring individual displays as any eye in passive
      stereo mode "4" when using TwinView or SLI Mosaic through extensions to
      the MetaMode syntax.

    * Added ColorSpace and ColorRange features for HDMI. These give
      the ability to output YUV over HDMI and select full/reduced
      color range on RGB over HDMI. ColorSpace and ColorRange
      are X Configuration options and can be changed dynamically
      through nvidia-settings.

Fix: 

Use attached diff from /usr/ports/x11 directory.
Additional manual fixing of x11/nvidia-driver/pkg-plist file (for libglx.la, libglx.so, libGL.so.1 files) needed.
Comment 1 Edwin Groothuis freebsd_committer 2010-11-19 12:01:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->danfe

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Sender Ghost 2010-12-15 02:01:47 UTC
There is new 260.19.29 version of the certified NVIDIA drivers:
http://www.nvidia.com/object/freebsd-x86-260.19.29-driver.html
http://www.nvidia.com/object/freebsd-x64-260.19.29-driver.html

With following changes between 260.19.21 and 260.19.29 drivers:
2010-12-13 version 260.19.29

      * Added support for the following GPUs:

          * GeForce GTX 460 SE
          * GeForce GTX 570
          * Quadro 5000M
          * NVS 300

      * Fixed a bug that caused some OpenGL applications to become
        unresponsive for up to a minute on some GPUs when changing
        the resolution or refresh rate.

---

I created new patch and included it as an attachment.

Some people mailed me directly and asked about "manual fixing of 
x11/nvidia-driver/pkg-plist file".
I wrote it because I had following error while installing new driver 
after 256.53 version:
-8<--
mv: rename /usr/local/lib/XXX-libGL.so.1.%%.libGL-7.4.4 to 
/usr/local/lib/libGL.so.1: No such file or directory
pkg_delete: unexec command for 'mv -f 
/usr/local/lib/XXX-libGL.so.1.%%.libGL-7.4.4 /usr/local/lib/libGL.so.1' 
failed
pkg_delete: couldn't entirely delete package (perhaps the packing list 
is incorrectly specified?)
-->8-

Then I found that "XXX-libGL.so.1.%%.libGL-7.4.4" file named 
"XXX-libGL.so.1.%%.orig-20100618" in the system.

Inside /usr/ports/x11/nvidia-driver/pkg-plist file I found following 
comments:
-8<--
@comment I can't add the below files to the package because pkg_delete
@comment will complain when removing this package:
@comment     %%MODULESDIR%%/extensions/XXX-libglx.la.%%%%.%%XSERVVERSION%%
@comment     %%MODULESDIR%%/extensions/XXX-libglx.so.%%%%.%%XSERVVERSION%%
@comment     lib/XXX-libGL.so.1.%%%%.%%LIBGLVERSION%%
@comment They are however restored when this package is removed:
@exec mv -f %D/%%MODULESDIR%%/extensions/libglx.la 
%D/%%MODULESDIR%%/extensions/XXX-libglx.la.%%%%.%%XSERVVERSION%%
@unexec mv -f 
%D/%%MODULESDIR%%/extensions/XXX-libglx.la.%%%%.%%XSERVVERSION%% 
%D/%%MODULESDIR%%/extensions/libglx.la
@exec mv -f %D/%%MODULESDIR%%/extensions/libglx.so 
%D/%%MODULESDIR%%/extensions/XXX-libglx.so.%%%%.%%XSERVVERSION%%
@unexec mv -f 
%D/%%MODULESDIR%%/extensions/XXX-libglx.so.%%%%.%%XSERVVERSION%% 
%D/%%MODULESDIR%%/extensions/libglx.so
@exec mv -f %D/lib/libGL.so.1 %D/lib/XXX-libGL.so.1.%%%%.%%LIBGLVERSION%%
@unexec mv -f %D/lib/XXX-libGL.so.1.%%%%.%%LIBGLVERSION%% %D/lib/libGL.so.1
-->8-

Therefore XSERVVERSION variable expanded incorrectly in the port 
Makefile for libGL.so.1 file:
-8<--
XSERVVERSION!=	/usr/sbin/pkg_info -qO x11-servers/xorg-server 
2>/dev/null || true
LIBGLVERSION!=	/usr/sbin/pkg_info -qO graphics/libGL 2>/dev/null || true
-->8-

Then I found following code inside lib/Makefile of the nvidia-driver sources
-8<--
FIND_FILES!=(find ${FIND_DIRS} \
		-name libGL.a\* -or \
		-name libGL.so\* -or \
		-name libnvidia-tls.so\* -or \
		-name libnvidia-cfg.so\* -or \
		-name libnvidia-glcore.\* -or \
		-name libvdpau\* -or \
		-name libXvMCNVIDIA.\* -or \
		-name libglx.\* \
		| xargs ${ECHO})
DATE=`date "+%Y%m%d"`

GREP=/usr/bin/grep
ECHO=/usr/bin/true

beforeinstall:
	@-for __file in ${FIND_FILES}; do \
		${ECHO} "===> Checking file: $${__file}" ; \
		if [ -L $${__file} ] ; then \
			${ECHO} "	- File is a symlink, removing." ; \
			rm -f $${__file} ; \
			continue ; \
		fi ; \
		if [ ! -e $${__file} ] ; then \
			${ECHO} "	- File does not exist." ; \
			continue ; \
		fi ; \
		${GREP} 'nvidia id:' $${__file} > /dev/null 2>&1 ; RESULT=$$? ; \
		${ECHO} $${__file} | ${GREP} libXvMCNVIDIA > /dev/null 2>&1 ; 
RESULT2=$$? ; \
		if [ $${RESULT2} -eq 0 ] ; then \
			RESULT=0 ; \
		fi ; \
		if [ $${RESULT} -eq 0 ] ; then \
			${ECHO} "	- File has NVIDIA signature, removing." ; \
			rm -f $${__file} ; \
			continue ; \
		fi ; \
		SUFFIX=`pkg_info -qW $${__file}` ; RESULT=$$? ; \
		if [ -n "$${SUFFIX}" ] ; then \
			${ECHO} "	- File was installed by package $${SUFFIX}" ; \
		else \
			${ECHO} "	- File is unknown or orphaned." ; \
			SUFFIX="orig-${DATE}" ; \
		fi ; \
		${ECHO} "	- Creating backup." ; \
		FILE_NAME=`basename $${__file}` ; \
		DIR_NAME=`dirname $${__file}` ; \
		mv -f $${__file} $${DIR_NAME}/XXX-$${FILE_NAME}.%%.$${SUFFIX} ; \
	done

include <bsd.subdir.mk>
-->8-
Briefly, it says:
When "File is unknown or orphaned" then SUFFIX="orig-${DATE}" and moves 
such file with XXX prefix and SUFFIX postfix. This was true for 
libGL.so.1 in my case. Therefore, such or the same logic need to be 
added to complete/fix this port.

On the other hand, new driver works even with such pkg-plist error(s).
This was a reason to submit this problem report.
Comment 3 Sender Ghost 2011-01-16 01:40:07 UTC
I created new patch based on ports/153840.
It solved previous issue with pkg-plist file.

Thank you, Alex Dupre.
Comment 4 Sender Ghost 2011-01-22 03:20:51 UTC
There is new 260.19.36 version of the certified NVIDIA drivers:
http://www.nvidia.com/object/freebsd-x86-260.19.36-driver.html
http://www.nvidia.com/object/freebsd-x64-260.19.36-driver.html

With following changes between 260.19.29 and 260.19.36 drivers:
2011-01-21 version 260.19.36

* Updated the NVIDIA kernel module to ensure that all system memory
   allocated by it for use with GPUs or within user-space components of the
   NVIDIA driver stack is initialized to zero.  A new NVIDIA kernel module
   option, InitializeSystemMemoryAllocations, allows administrators to
   revert to the previous behavior.

* Fixed a bug that caused X servers version 1.9 and higher to crash when
   color index overlays were enabled.

* Fixed a bug that caused pixel value 255 to be treated as transparent in
   color index overlays.
Comment 5 Sender Ghost 2011-02-01 17:28:50 UTC
The maintainer of x11/nvidia-settings, x11/nvidia-xconfig ports updated 
them to 270.18 BETA version.
Therefore, I created new patch for x11/nvidia-driver:
http://www.nvidia.com/object/freebsd-x86-270.18-driver.html
http://www.nvidia.com/object/freebsd-x64-270.18-driver.html

With following changes between 260.19.36 and 270.18 drivers:
2011-01-21 version 270.18

* Added preliminary support for xserver 1.10.

* Fixed several bugs relating to hardware-accelerated gradients, which were
   causing visual corruption in some of the default Ubuntu GNOME themes.

* Modified colormap updates to no longer be synchronized to vblank.  This
   allows applications to send XStoreColor and XStoreColors requests faster
   than the screen's refresh rate.

   This behavior can be controlled by a new NV-CONTROL attribute,
   NV_CONTROL_SYNC_LUT_UPDATES.  By default, LUT updates are not
   synchronized.  This may cause flickering in some applications that 
use the
   colormap to perform animation, such as xpilot running on a depth 8 X
   screen.  If you experience flickering, try running

       nvidia-settings -a [gpu:0]/SynchronousPaletteUpdates=1
Comment 6 Sender Ghost 2011-02-23 08:22:49 UTC
There is new 270.26 version of BETA NVIDIA drivers:
http://www.nvidia.com/object/freebsd-x86-270.26-driver.html
http://www.nvidia.com/object/freebsd-x64-270.26-driver.html

With following changes between 270.18 and 270.26 drivers:
2011-02-21 version 270.26
* Added NV-CONTROL event notification for NV_CTRL_FRAMELOCK_SYNC_READY
   status changes.

* Added support for the following GPUs:

     * GeForce GTX 560 Ti
     * Quadro 2000 D
     * Quadro 400

* Added a new X configuration option "Interactive", which defaults to
   enabled, but can be disabled to allow long-running GPU compute programs
   to run concurrently with X.

* Fixed a bug in the VDPAU presentation queue that could cause VDPAU
   "display preemption" when rendering to tiny or zero-sized windows or
   pixmaps.

* Fixed a bug in VDPAU which prevented use of the overlay presentation
   queue following an application exiting without gracefully destroying its
   VDPAU presentation queue.
---

- Added license information for each port.
- Fixed incorrectly defined program name for x11/nvidia-settings port.
Comment 7 rnejdl 2011-03-05 22:48:54 UTC
  

I was wondering what was holding up the update of the nvidia-driver
to at least the 260 stable release. The ports freeze is over and this
one should be relatively straight forward to commit. 

Sincerely,
Rusty
Nejdl 
Comment 8 Sender Ghost 2011-03-06 17:11:15 UTC
Rusty Nejdl wrote:
> I was wondering what was holding up the update of the nvidia-driver to 
> at least the 260 stable release.  The ports freeze is over and this 
> one should be relatively straight forward to commit.
> Sincerely,
> Rusty Nejdl 
Hello, Rusty Nejdl.

As far as I know, there need response from maintainers: danfe (for 
nvidia-driver port) and bland (for nvidia-settings, nvidia-xconfig 
ports). These ports need to be updated synchronously, because they are 
interrelated.
I had private response from bland, so far. Also, there is some closed 
problem report response from danfe 
(http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/153840). Additionally, 
most of the patches sent to maintainers directly, so, they can review them.

 From my point of view, I agree with incremental updates to WHQL 
certified NVIDIA drivers. The 260.19.36 version can be good candidate 
before new release. But need to consider various reports from NVIDIA 
forums (http://www.nvnews.net/vbulletin/forumdisplay.php?f=47). The 
ports tree exists in source configuration management system (e.g. cvs, 
svn, git), therefore it possible to revert changes back on user level.
Comment 9 Sender Ghost 2011-03-09 03:27:39 UTC
There is new 260.19.44 version of the certified NVIDIA drivers:
http://www.nvidia.com/object/freebsd-x86-260.19.44-driver.html
http://www.nvidia.com/object/freebsd-x64-260.19.44-driver.html

With following changes between 260.19.36 and 260.19.44 drivers:
2011-03-07 version 260.19.44

* Updated the NVIDIA X driver to not update mode timings for G-Sync
   compatibility when NVIDIA 3D Vision or NVIDIA 3D VisionPro is
   enabled along with a G-Sync device.

* Added support for the following GPUs:

* Quadro 2000 D
* Quadro 400
Comment 10 dfilter service freebsd_committer 2011-04-07 09:15:15 UTC
danfe       2011-04-07 08:14:57 UTC

  FreeBSD ports repository

  Modified files:
    x11/nvidia-driver    Makefile 
  Log:
  Add license information.
  
  PR:     ports/152400 (part of)
  
  Revision  Changes    Path
  1.105     +5 -0      ports/x11/nvidia-driver/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 11 rnejdl 2011-04-19 19:44:16 UTC
  

Nvidia now has 270.41.03 out whereas the port is still on 256.53. I
was wondering what is holding up the update(s) as we seem to be at least
one or two versions behind per this:


http://www.nvnews.net/vbulletin/showthread.php?t=127019 

Are there
any show stopper bugs? 

Rusty Nejdl 
  
Comment 12 Sender Ghost 2011-04-22 17:12:31 UTC
There is new 270.41.06 version of the certified NVIDIA drivers:
http://www.nvidia.com/object/freebsd-x86-270.41.06-driver.html
http://www.nvidia.com/object/freebsd-x64-270.41.06-driver.html

With following changes between 260.19.44 and 270.41.06 drivers:
2011-04-20 version 270.41.06

* Fixed a bug that caused some GPUs to stop responding when the X Server
   was started. All GPUs are susceptible, but the failure was primarily
   seen on GF104 and GF106 boards.

* Added support for the following GPUs:

     * Tesla M2090
     * Tesla M2075
     * Tesla C2075

     * Quadro 7000

2011-04-18 version 270.41.03

* Fixed a bug causing the X server to hang every 49.7 days on 32-bit
   platforms.

* Added support for the following GPUs:

     * GeForce GT 520
     * GeForce GT 525M
     * GeForce GT 520M
     * GeForce GT 445M
     * GeForce GT 530
     * GeForce 405
     * GeForce GTX 590
     * GeForce GTX 550 Ti
     * GeForce GT 420
     * GeForce GT 440
     * GeForce GTX 470M
     * GeForce GTX 485M
     * GeForce GT 550M
     * GeForce GT 555M

     * NVS 4200M
     * Quadro 1000M
     * Quadro 2000M

2011-03-02 version 270.30

* Added support for xserver ABI 10 (xorg-server 1.10).

* Dropped support for xserver ABI 9 (which was only used with xorg-server
   1.10 RC2 due to a last-minute xserver change).

2011-02-24 version 270.29

* Added official support for xorg-server 1.10 [RC2 only, see above].  The
   -ignoreABI option is no longer required with this version of the server.

2011-02-15 version 270.26

* Added NV-CONTROL event notification for NV_CTRL_FRAMELOCK_SYNC_READY
   status changes.

* Added support for the following GPUs:

     * GeForce GTX 560 Ti

* Added a new X configuration option "Interactive", which defaults to
   enabled, but can be disabled to allow long-running GPU compute programs
   to run concurrently with X.

* Fixed a bug in the VDPAU presentation queue that could cause VDPAU
   "display preemption" when rendering to tiny or zero-sized windows or
   pixmaps.

* Fixed a bug in VDPAU which prevented use of the overlay presentation
   queue following an application exiting without gracefully destroying its
   VDPAU presentation queue.

* Fixed a bug in VDPAU that prevented the overlay from ever being used if
   a presentation queue was created while the target window was redirected
   using the Composite extension when the presentation queue was created.

2011-01-21 version 270.18

* Added preliminary support for xserver 1.10.

* Fixed several bugs relating to hardware-accelerated gradients, which were
   causing visual corruption in some of the default Ubuntu GNOME themes.

* Added unofficial GLX protocol support (i.e., for GLX indirect
   rendering) for the following OpenGL extensions:
   GL_ARB_shader_subroutine
   GL_ARB_map_buffer_range

* Added GLX protocol support (i.e., for GLX
   indirect rendering) for the following OpenGL extensions:
   GL_NV_half_float
   GL_NV_occlusion_query
   GL_EXT_blend_equation_separate
   GL_EXT_depth_bounds_test

* Modified colormap updates to no longer be synchronized to vblank.  This
   allows applications to send XStoreColor and XStoreColors requests faster
   than the screen's refresh rate.

   This behavior can be controlled by a new NV-CONTROL attribute,
   NV_CONTROL_SYNC_LUT_UPDATES.  By default, LUT updates are not
   synchronized.  This may cause flickering in some applications that 
use the
   colormap to perform animation, such as xpilot running on a depth 8 X
   screen.  If you experience flickering, try running

       nvidia-settings -a [gpu:0]/SynchronousPaletteUpdates=1
Comment 13 dfilter service freebsd_committer 2011-05-21 15:05:11 UTC
danfe       2011-05-21 14:04:48 UTC

  FreeBSD ports repository

  Modified files:
    x11/nvidia-driver    Makefile distinfo pkg-plist 
    x11/nvidia-driver-173 Makefile 
    x11/nvidia-driver-71 Makefile 
    x11/nvidia-driver-96 Makefile 
  Log:
  - Update corresponding NVidia drivers to versions 270.41.19 and 173.14.30
  - Turn formal requirement for X server into explicit dependency and bump
    port revisions in nvidia-driver-96 and nvidia-driver-71 accordingly
  - Remove NO_PACKAGE; along with previous change, this enables us to build
    nvidia-driver packages
  - Try to rely a little less on the assumption that PREFIX == LOCALBASE and
    explicitly create ${PREFIX}/${MODULESDIR}/extensions directory
  - Fix pkg-plist issue when both lib/xorg/modules/extensions/libglx.so and
    lib/libGL.so.1 handling worked for installation from the port, but was
    insufficient for the package
  
  Special thanks to ale@ for proposing pkg-plist fix and patiently waiting
  for me to realize it is indeed correct.
  
  PR:     ports/152400
  
  Revision  Changes    Path
  1.10      +1 -2      ports/x11/nvidia-driver-173/Makefile
  1.19      +1 -1      ports/x11/nvidia-driver-71/Makefile
  1.20      +1 -1      ports/x11/nvidia-driver-96/Makefile
  1.106     +6 -9      ports/x11/nvidia-driver/Makefile
  1.39      +6 -6      ports/x11/nvidia-driver/distinfo
  1.29      +2 -6      ports/x11/nvidia-driver/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 14 Alexey Dokuchaev freebsd_committer 2011-05-21 15:11:51 UTC
State Changed
From-To: open->closed

NVidia driver ports were updated to their most recent versions and proposed 
changes finally committed.  Thanks everyone for their patience!
Comment 15 dfilter service freebsd_committer 2011-05-23 13:05:50 UTC
bland       2011-05-23 12:05:36 UTC

  FreeBSD ports repository

  Modified files:
    x11/nvidia-xconfig   Makefile 
    x11/nvidia-settings  Makefile 
  Log:
  Add LICENSE.
  
  PR:     152400
  
  Revision  Changes    Path
  1.50      +2 -0      ports/x11/nvidia-settings/Makefile
  1.23      +2 -0      ports/x11/nvidia-xconfig/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"