Bug 153181 - [PATCH] devel/avr-libc: port is not broken when AVRLIBCDOCS
[PATCH] devel/avr-libc: port is not broken when AVRLIBCDOCS
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Joerg Wunsch
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-15 18:30 UTC by leres
Modified: 2010-12-15 22:00 UTC (History)
0 users

See Also:


Attachments
patch-Makefile (775 bytes, text/plain)
2010-12-15 18:32 UTC, leres
no flags Details
patch-Makefile.sig (72 bytes, application/octet-stream)
2010-12-15 18:32 UTC, leres
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description leres 2010-12-15 18:30:09 UTC
	This port is marked as broken but in fact it builds correctly
	when the documentation option (AVRLIBCDOCS) is not selected.

Fix: Change the default for AVRLIBCDOCS to off; move BROKEN to
	the case when AVRLIBCDOCS is on.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk0JCQ4ACgkQWxlAhAje3Jt3nwCeJhQl5bx4pW4KKTz9xVK5qjk0
le8AoI0AGdRHT05+0pnGzrJ/GdrkZ5Sn
=8Wil
-----END PGP SIGNATURE-----

--------------010202050708040408070003
Content-Type: text/plain;
 name="patch-Makefile"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;
 filename="patch-Makefile"



--------------010202050708040408070003
Content-Type: application/octet-stream;
 name="patch-Makefile.sig"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename="patch-Makefile.sig"

iEYEABECAAYFAk0JCQ4ACgkQWxlAhAje3JsKbgCfX9OvRWIWPWE+lvZsiXnbf28vvcEAnib9
59H3vadydK63IswcHneGVtaz
--------------010202050708040408070003----fFjzcCv3T0potK4HyYxfVMJ4Rzsj0JDRaUgCPnAKYgleIncE
Content-Type: text/plain; name="file.diff"
Content-Transfer-Encoding: 7bit
Content-Disposition: attachment; filename="file.diff"

--- Makefile.orig	2010-12-15 09:59:04.000000000 -0800
+++ Makefile	2010-12-15 10:26:28.000000000 -0800
@@ -7,6 +7,7 @@
 
 PORTNAME=	avr-libc
 PORTVERSION=	1.7.0
+PORTREVISION=	1
 PORTEPOCH=	1
 CATEGORIES=	devel
 MASTER_SITES=	${MASTER_SITE_SAVANNAH}
@@ -22,10 +23,8 @@
 		avr-ld:${PORTSDIR}/devel/avr-binutils \
 		avr-gcc:${PORTSDIR}/devel/avr-gcc
 
-BROKEN=		does not build
-
 .if !defined(NOPORTDOCS)
-OPTIONS=	AVRLIBCDOCS "Build avr-libc documents" on
+OPTIONS=	AVRLIBCDOCS "Build avr-libc documents" off
 .endif
 
 .include <bsd.port.options.mk>
@@ -33,6 +32,8 @@
 .if defined(WITHOUT_AVRLIBCDOCS) || defined(NOPORTDOCS)
 WITHOUT_AVRLIBCDOCS=	true
 .undef WITH_AVRLIBCDOCS
+.else
+#BROKEN=		does not build with AVRLIBCDOCS enabled
 .endif
 
 .if defined(WITH_AVRLIBCDOCS)
How-To-Repeat: 	Comment out the BROKEN line, "make config" and enable
	AVRLIBCDOCS and things go wrong.

	"make config" and disable AVRLIBCDOCS and everything builds.
Comment 1 Edwin Groothuis freebsd_committer 2010-12-15 18:30:17 UTC
Responsible Changed
From-To: freebsd-ports-bugs->joerg

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 leres 2010-12-15 18:32:29 UTC
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Oops, there's a typo in the patch; please use the appended version instead.

		Craig
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (FreeBSD)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk0JCb0ACgkQWxlAhAje3Jt3eQCfd3Xj3Gv8TKRNHT0y2gXES+e3
z2kAn3i+37bKsO8aWNtm+rNoizLcOMQh
=8yIN
-----END PGP SIGNATURE-----
Comment 3 dfilter freebsd_committer 2010-12-15 21:56:38 UTC
joerg       2010-12-15 21:56:33 UTC

  FreeBSD ports repository

  Modified files:
    devel/avr-libc       Makefile 
  Log:
  As a workaround for the brokeness caused by the recent doxygen
  upgrade, change the AVRLIBCDOCS option default to "off", and mark the
  port as being BROKEN only if docs are requested, so it will be non
  broken by default.
  
  This can go away again with an upcoming new upstream release that
  implements a proper workaround, but it's a useful workaround until
  then.
  
  PR:             ports/153181
  Submitted by:   Craig Leres
  
  Revision  Changes    Path
  1.77      +4 -3      ports/devel/avr-libc/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Joerg Wunsch freebsd_committer 2010-12-15 21:57:09 UTC
State Changed
From-To: open->closed

Patch applied as a workaround until the proper upstream fix 
arrives. 

thanks!