Bug 154086 - libsicui18n.a in devel/icu constains no symbols
Summary: libsicui18n.a in devel/icu constains no symbols
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Tijl Coosemans
URL:
Keywords:
Depends on: 205120
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-17 15:10 UTC by Pete French
Modified: 2016-09-24 11:14 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Pete French 2011-01-17 15:10:09 UTC
	/usr/ports/devel/icu isnatlls both synamic and static versions
	of it's libraries into /usr/local/lib - the static ones being
	prefixed with 's' compared to the dymanic ones.

	The latest version of icu - icu-4.6 - will not link
	staticly. Upon investigation the problem is the static version
	of i18n - libsicui18n. If 'nm' is applied to this, it claims
	that all the object files cntain no symbols. If an application is
	linked against the dynamic version of the library it works, but
	linking against the static version fails. The problem does not apply
	to the other static versions of the libraries. They work fine.

Fix: 

There is no workaround which will allow static linking that I
	have found.
How-To-Repeat: 
	Write some code using ICU - change the -licui18n option at link
	time to -lsicui18n and observer that it no longer links, failing
	with multiple "undefined reference" errors.
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2011-01-18 18:03:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->bapt

Fix synopsis and assign.
Comment 2 baptiste.daroussin 2011-03-15 13:55:23 UTC
For me it seems to be fixed with the 4.6.1 upgrade, can you confirm?

regards,
Bapt
Comment 3 Pete French 2011-03-15 14:06:55 UTC
> For me it seems to be fixed with the 4.6.1 upgrade, can you confirm?

That hasn't hit my portsnap server yet - will try peridicly and lety
you know. Thanks....

-pete.
Comment 4 Pete French 2011-03-15 15:32:24 UTC
> For me it seems to be fixed with the 4.6.1 upgrade, can you confirm?

I just downloaded this by hand, but am still having problems with the
specific 18n library. Do you have a poece of example code which
works for you using the 18n library and creating a static executable ?
If it seems to be fixed for you then I would like to compare your
linker arguments with mine...
Comment 5 Baptiste Daroussin freebsd_committer 2011-07-22 06:33:52 UTC
Responsible Changed
From-To: bapt->office

Over to the office team
Comment 6 Baptiste Daroussin freebsd_committer 2014-08-26 06:30:40 UTC
Following the icu guide on how to properly statically build with icu just worked for me. Can you confirm?
Comment 7 pete 2014-08-26 09:50:36 UTC
I had been using a hand compiled copy of icu since originally reporting this bug, so I do have a working ICU using the instructions provided, just that it has to live outside of the ports tree. I just tried again with the one in the post tree, and that still will not link staticly for me I am afraid.
Comment 8 Tijl Coosemans freebsd_committer 2016-09-24 11:14:31 UTC
Fixed in ports r422711.