Bug 155600 - net-p2p/transmission-qt4 segmentation fault
Summary: net-p2p/transmission-qt4 segmentation fault
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Jeremy Messenger
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-16 13:40 UTC by Alexandr
Modified: 2011-03-17 20:20 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr 2011-03-16 13:40:13 UTC
pcbsd-7177% transmission-qt
zsh: segmentation fault (core dumped)  transmission-qt

pcbsd-7177% gdb /usr/local/bin/transmission-qt /usr/tmp/coredumps/1001.transmission-qt.78322.core 
GNU gdb 6.1.1 [FreeBSD]
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "amd64-marcel-freebsd"...
Core was generated by `transmission-qt'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/local/lib/libevent-1.4.so.4...done.
Loaded symbols for /usr/local/lib/libevent-1.4.so.4
Reading symbols from /lib/libz.so.5...done.
Loaded symbols for /lib/libz.so.5
Reading symbols from /usr/local/lib/libfontconfig.so.1...done.
Loaded symbols for /usr/local/lib/libfontconfig.so.1
Reading symbols from /usr/local/lib/libcurl.so.6...done.
Loaded symbols for /usr/local/lib/libcurl.so.6
Reading symbols from /usr/local/lib/event2/libevent-2.0.so.5...done.
Loaded symbols for /usr/local/lib/event2/libevent-2.0.so.5
Reading symbols from /usr/local/lib/qt4/libQtDBus.so.4...done.
Loaded symbols for /usr/local/lib/qt4/libQtDBus.so.4
Reading symbols from /usr/local/lib/qt4/libQtXml.so.4...done.
Loaded symbols for /usr/local/lib/qt4/libQtXml.so.4
Reading symbols from /usr/local/lib/qt4/libQtGui.so.4...done.
Loaded symbols for /usr/local/lib/qt4/libQtGui.so.4
Reading symbols from /usr/local/lib/qt4/libQtNetwork.so.4...done.
Loaded symbols for /usr/local/lib/qt4/libQtNetwork.so.4
Reading symbols from /usr/local/lib/qt4/libQtCore.so.4...done.
Loaded symbols for /usr/local/lib/qt4/libQtCore.so.4
Reading symbols from /usr/lib/libstdc++.so.6...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/libm.so.5...done.
Loaded symbols for /lib/libm.so.5
Reading symbols from /lib/libgcc_s.so.1...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libthr.so.3...done.
Loaded symbols for /lib/libthr.so.3
Reading symbols from /lib/libc.so.7...done.
Loaded symbols for /lib/libc.so.7
Reading symbols from /lib/libcrypto.so.6...done.
Loaded symbols for /lib/libcrypto.so.6
Reading symbols from /usr/local/lib/libfreetype.so.9...done.
Loaded symbols for /usr/local/lib/libfreetype.so.9
Reading symbols from /usr/local/lib/libexpat.so.6...done.
Loaded symbols for /usr/local/lib/libexpat.so.6
Reading symbols from /usr/lib/libssl.so.6...done.
Loaded symbols for /usr/lib/libssl.so.6
Reading symbols from /usr/local/lib/libgthread-2.0.so.0...done.
Loaded symbols for /usr/local/lib/libgthread-2.0.so.0
Reading symbols from /usr/local/lib/libglib-2.0.so.0...done.
Loaded symbols for /usr/local/lib/libglib-2.0.so.0
Reading symbols from /usr/local/lib/libpng.so.6...done.
Loaded symbols for /usr/local/lib/libpng.so.6
Reading symbols from /usr/local/lib/libSM.so.6...done.
Loaded symbols for /usr/local/lib/libSM.so.6
Reading symbols from /usr/local/lib/libICE.so.6...done.
Loaded symbols for /usr/local/lib/libICE.so.6
Reading symbols from /usr/local/lib/libXrender.so.1...done.
Loaded symbols for /usr/local/lib/libXrender.so.1
Reading symbols from /usr/local/lib/libXext.so.6...done.
Loaded symbols for /usr/local/lib/libXext.so.6
Reading symbols from /usr/local/lib/libX11.so.6...done.
Loaded symbols for /usr/local/lib/libX11.so.6
Reading symbols from /usr/local/lib/libiconv.so.3...done.
Loaded symbols for /usr/local/lib/libiconv.so.3
Reading symbols from /usr/local/lib/libintl.so.9...done.
Loaded symbols for /usr/local/lib/libintl.so.9
Reading symbols from /usr/local/lib/libpcre.so.0...done.
Loaded symbols for /usr/local/lib/libpcre.so.0
Reading symbols from /usr/local/lib/libxcb.so.2...done.
Loaded symbols for /usr/local/lib/libxcb.so.2
Reading symbols from /usr/local/lib/libXau.so.6...done.
Loaded symbols for /usr/local/lib/libXau.so.6
Reading symbols from /usr/local/lib/libXdmcp.so.6...done.
Loaded symbols for /usr/local/lib/libXdmcp.so.6
Reading symbols from /usr/local/lib/libpthread-stubs.so.0...done.
Loaded symbols for /usr/local/lib/libpthread-stubs.so.0
Reading symbols from /usr/lib/librpcsvc.so.5...done.
Loaded symbols for /usr/lib/librpcsvc.so.5
Reading symbols from /usr/local/lib/libdbus-1.so.3...done.
Loaded symbols for /usr/local/lib/libdbus-1.so.3
Reading symbols from /usr/local/lib/libXrandr.so.2...done.
Loaded symbols for /usr/local/lib/libXrandr.so.2
Reading symbols from /usr/local/lib/libXfixes.so...done.
Loaded symbols for /usr/local/lib/libXfixes.so
Reading symbols from /usr/local/lib/libXcursor.so.1...done.
Loaded symbols for /usr/local/lib/libXcursor.so.1
Reading symbols from /usr/local/lib/libXinerama.so.1...done.
Loaded symbols for /usr/local/lib/libXinerama.so.1
Reading symbols from /usr/local/lib/libXi.so...done.
Loaded symbols for /usr/local/lib/libXi.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/gui_platform/libkde.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/gui_platform/libkde.so
Reading symbols from /usr/local/kde4/lib/libkio.so.7...done.
Loaded symbols for /usr/local/kde4/lib/libkio.so.7
Reading symbols from /usr/local/kde4/lib/libkdeui.so.7...done.
Loaded symbols for /usr/local/kde4/lib/libkdeui.so.7
Reading symbols from /usr/local/lib/qt4/libQtSvg.so.4...done.
Loaded symbols for /usr/local/lib/qt4/libQtSvg.so.4
Reading symbols from /usr/local/kde4/lib/libkdecore.so.7...done.
Loaded symbols for /usr/local/kde4/lib/libkdecore.so.7
Reading symbols from /usr/local/kde4/lib/libnepomuk.so.5...done.
Loaded symbols for /usr/local/kde4/lib/libnepomuk.so.5
Reading symbols from /usr/local/lib/libstreamanalyzer.so.0...done.
Loaded symbols for /usr/local/lib/libstreamanalyzer.so.0
Reading symbols from /usr/local/lib/libstreams.so.0...done.
Loaded symbols for /usr/local/lib/libstreams.so.0
Reading symbols from /usr/local/kde4/lib/libsolid.so.5...done.
Loaded symbols for /usr/local/kde4/lib/libsolid.so.5
Reading symbols from /usr/local/lib/libXft.so.2...done.
Loaded symbols for /usr/local/lib/libXft.so.2
Reading symbols from /usr/local/lib/libXpm.so.4...done.
Loaded symbols for /usr/local/lib/libXpm.so.4
Reading symbols from /usr/local/lib/libsoprano.so.4...done.
Loaded symbols for /usr/local/lib/libsoprano.so.4
Reading symbols from /usr/local/lib/libdbusmenu-qt.so.2...done.
Loaded symbols for /usr/local/lib/libdbusmenu-qt.so.2
Reading symbols from /usr/local/lib/libXtst.so.6...done.
Loaded symbols for /usr/local/lib/libXtst.so.6
Reading symbols from /usr/lib/libbz2.so.4...done.
Loaded symbols for /usr/lib/libbz2.so.4
Reading symbols from /usr/lib/liblzma.so.5...done.
Loaded symbols for /usr/lib/liblzma.so.5
Reading symbols from /usr/local/lib/libsopranoclient.so.1...done.
Loaded symbols for /usr/local/lib/libsopranoclient.so.1
Reading symbols from /usr/local/lib/libxml2.so.5...done.
Loaded symbols for /usr/local/lib/libxml2.so.5
Reading symbols from /usr/local/kde4/lib/kde4/plugins/styles/oxygen.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/styles/oxygen.so
Reading symbols from /usr/local/kde4/lib/liboxygenstyle.so.5...done.
Loaded symbols for /usr/local/kde4/lib/liboxygenstyle.so.5
Reading symbols from /usr/local/lib/qt4/plugins/imageformats/libqgif.so...done.
Loaded symbols for /usr/local/lib/qt4/plugins/imageformats/libqgif.so
Reading symbols from /usr/local/lib/qt4/plugins/imageformats/libqico.so...done.
Loaded symbols for /usr/local/lib/qt4/plugins/imageformats/libqico.so
Reading symbols from /usr/local/lib/qt4/plugins/imageformats/libqjpeg.so...done.
Loaded symbols for /usr/local/lib/qt4/plugins/imageformats/libqjpeg.so
Reading symbols from /usr/local/lib/libjpeg.so.11...done.
Loaded symbols for /usr/local/lib/libjpeg.so.11
Reading symbols from /usr/local/lib/qt4/plugins/imageformats/libqmng.so...done.
Loaded symbols for /usr/local/lib/qt4/plugins/imageformats/libqmng.so
Reading symbols from /usr/local/lib/libmng.so.1...done.
Loaded symbols for /usr/local/lib/libmng.so.1
Reading symbols from /usr/local/lib/liblcms.so.1...done.
Loaded symbols for /usr/local/lib/liblcms.so.1
Reading symbols from /usr/local/lib/qt4/plugins/imageformats/libqsvg.so...done.
Loaded symbols for /usr/local/lib/qt4/plugins/imageformats/libqsvg.so
Reading symbols from /usr/local/lib/qt4/plugins/imageformats/libqtiff.so...done.
Loaded symbols for /usr/local/lib/qt4/plugins/imageformats/libqtiff.so
Reading symbols from /usr/local/lib/libtiff.so.4...done.
Loaded symbols for /usr/local/lib/libtiff.so.4
Reading symbols from /usr/local/lib/libjbig.so.1...done.
Loaded symbols for /usr/local/lib/libjbig.so.1
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_dds.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_dds.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_eps.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_eps.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_exr.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_exr.so
Reading symbols from /usr/local/lib/libImath.so.6...done.
Loaded symbols for /usr/local/lib/libImath.so.6
Reading symbols from /usr/local/lib/libIlmImf.so.6...done.
Loaded symbols for /usr/local/lib/libIlmImf.so.6
Reading symbols from /usr/local/lib/libIex.so.6...done.
Loaded symbols for /usr/local/lib/libIex.so.6
Reading symbols from /usr/local/lib/libHalf.so.6...done.
Loaded symbols for /usr/local/lib/libHalf.so.6
Reading symbols from /usr/local/lib/libIlmThread.so.6...done.
Loaded symbols for /usr/local/lib/libIlmThread.so.6
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_jp2.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_jp2.so
Reading symbols from /usr/local/lib/libjasper.so.4...done.
Loaded symbols for /usr/local/lib/libjasper.so.4
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_pcx.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_pcx.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_pic.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_pic.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_psd.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_psd.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_ras.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_ras.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_rgb.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_rgb.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_tga.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_tga.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_xcf.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_xcf.so
Reading symbols from /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_xview.so...done.
Loaded symbols for /usr/local/kde4/lib/kde4/plugins/imageformats/kimg_xview.so
Reading symbols from /libexec/ld-elf.so.1...done.
Loaded symbols for /libexec/ld-elf.so.1
#0  0x0000000800c522cc in evbuffer_expand_singlechain (buf=0x80b7b3c40, datlen=518) at buffer.c:1676
1676            if (*chainp && CHAIN_SPACE_LEN(*chainp) == 0)
[New Thread 8046041c0 (LWP 100378)]
(gdb) bt
#0  0x0000000800c522cc in evbuffer_expand_singlechain (buf=0x80b7b3c40, datlen=518) at buffer.c:1676
#1  0x0000000800c4f119 in evbuffer_reserve_space (buf=0x80b7b3c40, size=518, vec=0x7fffffffcf50, n_vecs=1) at buffer.c:577
#2  0x00000000004ba8aa in jsonStringFunc (val=dwarf2_read_address: Corrupted DWARF expression.
) at bencode.c:1374
#3  0x00000000004b9fa8 in bencWalk (top=0x7fffffffd100, walkFuncs=0x52a880, user_data=0x7fffffffd040, sort_dicts=1 '\001') at bencode.c:1085
#4  0x00000000004bb1b4 in tr_bencToBuf (top=0x7fffffffd100, mode=TR_FMT_JSON_LEAN, buf=0x80b7b3c40) at bencode.c:1624
#5  0x00000000004bb20c in tr_bencToStr (top=0x7fffffffd100, mode=TR_FMT_JSON_LEAN, len=0x0) at bencode.c:1638
#6  0x000000000048ed83 in Session::exec (this=0x8047cd880, request=0x7fffffffd100) at session.cc:661
#7  0x000000000048f49d in Session::refreshSessionStats (this=0x8047cd880) at session.cc:628
#8  0x0000000000496274 in StatsDialog (this=0x8047c4200, session=@0x8047cd880, parent=0x80461e800) at stats-dialog.cc:60
#9  0x0000000000460d68 in TrMainWindow (this=0x80461e800, session=@0x8047cd880, prefs=@0x8046c0c00, model=@0x804735460, minimized=false) at mainwin.cc:93
#10 0x0000000000427cba in MyApp (this=0x7fffffffe2f0, argc=@0x7fffffffe2ec, argv=0x7fffffffe5b8) at app.cc:170
#11 0x0000000000429443 in main (argc=1, argv=0x7fffffffe5b8) at app.cc:490
Current language:  auto; currently c
(gdb) 

pcbsd-7177% transmission-qt -v    
transmission-qt 2.22 (12099)

How-To-Repeat: cd /usr/ports/net-p2p/transmission-qt4
make install
transmission-qt
Comment 1 Mark Linimon freebsd_committer freebsd_triage 2011-03-17 05:34:28 UTC
Responsible Changed
From-To: freebsd-ports-bugs->mezz

Fix synopsis and assign.
Comment 2 Jeremy Messenger freebsd_committer 2011-03-17 16:41:16 UTC
State Changed
From-To: open->feedback

I can't reproduce the crash, but I think I might notice something wrong with 
your transmission-qt. It looks like it was linked with both version of 
libevent 1.x and 2.x. Please show me the outputs of: 

# pkg_info -IX event 
# ldd /usr/local/bin/transmission-qt
Comment 3 dfilter service freebsd_committer 2011-03-17 20:16:05 UTC
mezz        2011-03-17 20:15:56 UTC

  FreeBSD ports repository

  Modified files:
    net-p2p/transmission-qt4 Makefile 
  Added files:
    net-p2p/transmission-cli/files patch-qt_qtr.pro 
  Log:
  Fix transmission-qt to avoid link with both libevent 1.x and 2.x libraries
  or it will crashes. Remove a hardcore '-levent' (should be -levent-2.0) in
  the qtr.pro and let pkg-config takes care of it. Bump the PORTREVISION.
  
  PR:             ports/155600
  Reported by:    Alexandr <prayer@list.ru>
  
  Revision  Changes    Path
  1.1       +11 -0     ports/net-p2p/transmission-cli/files/patch-qt_qtr.pro (new)
  1.4       +1 -1      ports/net-p2p/transmission-qt4/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Jeremy Messenger freebsd_committer 2011-03-17 20:16:06 UTC
State Changed
From-To: feedback->closed

I have committed a fix, thanks for report!