Bug 158178 - [PATCH] net/liferea: misc changes
[PATCH] net/liferea: misc changes
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: pav
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-22 23:20 UTC by cvs-src
Modified: 2011-06-23 09:30 UTC (History)
0 users

See Also:


Attachments
file.diff (10.67 KB, patch)
2011-06-22 23:20 UTC, cvs-src
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description cvs-src 2011-06-22 23:20:11 UTC
- portlint warnings fixed:
  . move CPPFLAGS out of CONFIGURE_ENV
  . use DATADIR instead of share/liferea
  . i had also tried to enable WITHOUT_NLS but failed [1]
- add --disable-nm configure option to disable Network Manager
- add LICENSE
- add desktopfileutils dependency and call it where needed to 
  update liferea shortcuts and icons while installing/updating
- bump PORTREVISION


[1] I sent bug report in liferea tracker about configure ignores --disable-nls setting. liferea will always install locale data regardless of --disable-nls setting. They answered that the problem is with our autoconf or something:
https://sourceforge.net/tracker/?func=detail&atid=581684&aid=3324589&group_id=87005

I've tried with different autoconf versions but with the same result. Do you have any reasons of this behaviour?

Is there any reason why --disable-libnotify is set?

tinderbuild log (8.2-RELEASE):
http://happy-nation.by.ru/ports/tb/liferea-1.6.6_1.log

Fix: Patch attached with submission follows:
Comment 1 Edwin Groothuis freebsd_committer 2011-06-22 23:20:26 UTC
Responsible Changed
From-To: freebsd-ports-bugs->pav

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 pav freebsd_committer 2011-06-23 09:06:59 UTC
State Changed
From-To: open->closed

Partially committed. The CPPFLAGS and LICENSE bits were OK. 

I haven't committed the rest of your patch because: 

- replacing DATADIR in pkg-plist is a bogus portlint warning. Try setting 
non-default DATADIR and install this port. It will fail to package 
- Gtk20 mandates gettext non-optionally so there's no point trying to disable 
nls in any Gtk app. If someone cares for the extra couple of bytes of disc 
space that's occupied by compiled catalogues, he probably shouldn't be 
running GNOME anyway 
- we don't have NetworkManager in ports at all, so no need to disable detection 
of something that will never be present 
- update-desktop-database is only useful for Mimetype declarations, which there 
are none in liferea's .desktop file 

And to answer your trailing question: configure checks for a range of libnotify 
versions, which current libnotify in ports does not satisfy. The configure 
argument was added to disable the build of plugin for people with old libnotify 
still installed, which would result in extra files being installed and thus 
incomplete/broken plist.
Comment 3 dfilter freebsd_committer 2011-06-23 09:17:48 UTC
pav         2011-06-23 08:17:34 UTC

  FreeBSD ports repository

  Modified files:
    net/liferea          Makefile 
  Log:
  - CPPFLAGS now part of standard LATE_CONFIGURE_ARGS
  - Add LICENSE
  
  PR:             ports/158178
  Submitted by:   Ruslan Mahmatkhanov <cvs-src@yandex.ru>
  
  Revision  Changes    Path
  1.150     +4 -2      ports/net/liferea/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"