Bug 158859 - [ERROR] cannot portupgrade java/eclipse-devel
[ERROR] cannot portupgrade java/eclipse-devel
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: freebsd-eclipse
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-13 07:10 UTC by andy.lavr
Modified: 2011-07-17 00:10 UTC (History)
0 users

See Also:


Attachments
eclipse-devel-pr158859.diff (1.28 KB, patch)
2011-07-13 08:33 UTC, Thomas.Gellekum
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description andy.lavr 2011-07-13 07:10:11 UTC
# portupgrade eclipse\*
--->  Upgrading 'eclipse-devel-3.6.1' to 'eclipse-devel-3.7.0' (java/eclipse-devel)
--->  Building '/usr/ports/java/eclipse-devel'
===>  Cleaning for eclipse-devel-3.7.0

 eclipse-devel is using libxul for gecko support, but you can
 change that by defining WITH_GECKO to the following values:

   libxul 

===>  Vulnerability check disabled, database not found
===>  License check disabled, port has not defined LICENSE
===>  Found saved configuration for eclipse-devel-3.7.0
=> org.hamcrest.core_1.1.0.v20090501071000.jar doesn't seem to exist in /usr/ports/distfiles/eclipse.
=> Attempting to fetch http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/org.hamcrest.core_1.1.0.v20090501071000.jar
--2011-07-13 09:04:48--  http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/org.hamcrest.core_1.1.0.v20090501071000.jar
Распознаётся download.eclipse.org (download.eclipse.org)... 206.191.52.47
Устанавливается соединение с download.eclipse.org (download.eclipse.org)|206.191.52.47|:80... соединение установлено.
Запрос HTTP послан, ожидается ответ... 200 OK
Длина: 27827 (27K) [application/x-java-archive]
Saving to: <<org.hamcrest.core_1.1.0.v20090501071000.jar>>

100%[=====================================================================================================================================================================================================================================>] 27 827      12,5K/s   &#1074; 2,2s     

2011-07-13 09:04:56 (12,5 KB/s) - <<org.hamcrest.core_1.1.0.v20090501071000.jar>> saved [27827/27827]

===>  Extracting for eclipse-devel-3.7.0
=> SHA256 Checksum OK for eclipse/eclipse-build-5791c48513b4207ab1eec1e00bed4b2186f9aad5.tar.xz.
=> SHA256 Checksum OK for eclipse/eclipse-3.7.0-src.tar.bz2.
=> SHA256 Checksum OK for eclipse/apache-ant-1.8.2-bin.tar.bz2.
=> SHA256 Checksum OK for eclipse/junit3.8.2.zip.
=> SHA256 Checksum OK for eclipse/junit-4.8.2.jar.
=> SHA256 Checksum OK for eclipse/com.ibm.icu_4.4.2.v20110208.jar.
=> SHA256 Checksum OK for eclipse/com.jcraft.jsch_0.1.41.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/javax.servlet.jsp_2.0.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/javax.servlet_2.5.0.v201103041518.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.codec_1.3.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.el_1.0.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.httpclient_3.1.0.v201012070820.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.logging_1.0.4.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.jasper_5.5.17.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.lucene.core_2.9.1.v201101211721.jar.
=> SHA256 Checksum OK for eclipse/org.apache.lucene.analysis_2.9.1.v201101211721.jar.
=> SHA256 Checksum mismatch for eclipse/org.hamcrest.core_1.1.0.v20090501071000.jar.
=> SHA256 Checksum OK for eclipse/org.mortbay.jetty.util_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for eclipse/org.mortbay.jetty.server_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for eclipse/org.objectweb.asm_3.3.1.v201105211655.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.core_2.3.0.v20110329.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.pb_2.3.0.v20110329.jar.
===>  Refetch for 1 more times files: eclipse/org.hamcrest.core_1.1.0.v20090501071000.jar 

 eclipse-devel is using libxul for gecko support, but you can
 change that by defining WITH_GECKO to the following values:

   libxul 

===>  Vulnerability check disabled, database not found
===>  License check disabled, port has not defined LICENSE
===>  Found saved configuration for eclipse-devel-3.7.0
=> org.hamcrest.core_1.1.0.v20090501071000.jar doesn't seem to exist in /usr/ports/distfiles/eclipse.
=> Attempting to fetch http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/org.hamcrest.core_1.1.0.v20090501071000.jar
--2011-07-13 09:04:57--  http://download.eclipse.org/tools/orbit/downloads/drops/R20110523182458/repository/plugins/org.hamcrest.core_1.1.0.v20090501071000.jar
&#1056;&#1072;&#1089;&#1087;&#1086;&#1079;&#1085;&#1072;&#1105;&#1090;&#1089;&#1103; download.eclipse.org (download.eclipse.org)... 206.191.52.47
&#1059;&#1089;&#1090;&#1072;&#1085;&#1072;&#1074;&#1083;&#1080;&#1074;&#1072;&#1077;&#1090;&#1089;&#1103; &#1089;&#1086;&#1077;&#1076;&#1080;&#1085;&#1077;&#1085;&#1080;&#1077; &#1089; download.eclipse.org (download.eclipse.org)|206.191.52.47|:80... &#1089;&#1086;&#1077;&#1076;&#1080;&#1085;&#1077;&#1085;&#1080;&#1077; &#1091;&#1089;&#1090;&#1072;&#1085;&#1086;&#1074;&#1083;&#1077;&#1085;&#1086;.
&#1047;&#1072;&#1087;&#1088;&#1086;&#1089; HTTP &#1087;&#1086;&#1089;&#1083;&#1072;&#1085;, &#1086;&#1078;&#1080;&#1076;&#1072;&#1077;&#1090;&#1089;&#1103; &#1086;&#1090;&#1074;&#1077;&#1090;... 416 Requested Range Not Satisfiable

    &#1060;&#1072;&#1081;&#1083; &#1091;&#1078;&#1077; &#1087;&#1086;&#1083;&#1085;&#1086;&#1089;&#1090;&#1100;&#1102; &#1079;&#1072;&#1075;&#1088;&#1091;&#1078;&#1077;&#1085;; &#1085;&#1077;&#1095;&#1077;&#1075;&#1086; &#1074;&#1099;&#1087;&#1086;&#1083;&#1085;&#1103;&#1090;&#1100;.


 eclipse-devel is using libxul for gecko support, but you can
 change that by defining WITH_GECKO to the following values:

   libxul 

===>  Vulnerability check disabled, database not found
===>  License check disabled, port has not defined LICENSE
===>  Found saved configuration for eclipse-devel-3.7.0
=> SHA256 Checksum OK for eclipse/eclipse-build-5791c48513b4207ab1eec1e00bed4b2186f9aad5.tar.xz.
=> SHA256 Checksum OK for eclipse/eclipse-3.7.0-src.tar.bz2.
=> SHA256 Checksum OK for eclipse/apache-ant-1.8.2-bin.tar.bz2.
=> SHA256 Checksum OK for eclipse/junit3.8.2.zip.
=> SHA256 Checksum OK for eclipse/junit-4.8.2.jar.
=> SHA256 Checksum OK for eclipse/com.ibm.icu_4.4.2.v20110208.jar.
=> SHA256 Checksum OK for eclipse/com.jcraft.jsch_0.1.41.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/javax.servlet.jsp_2.0.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/javax.servlet_2.5.0.v201103041518.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.codec_1.3.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.el_1.0.0.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.httpclient_3.1.0.v201012070820.jar.
=> SHA256 Checksum OK for eclipse/org.apache.commons.logging_1.0.4.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.jasper_5.5.17.v201101211617.jar.
=> SHA256 Checksum OK for eclipse/org.apache.lucene.core_2.9.1.v201101211721.jar.
=> SHA256 Checksum OK for eclipse/org.apache.lucene.analysis_2.9.1.v201101211721.jar.
=> SHA256 Checksum mismatch for eclipse/org.hamcrest.core_1.1.0.v20090501071000.jar.
=> SHA256 Checksum OK for eclipse/org.mortbay.jetty.util_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for eclipse/org.mortbay.jetty.server_6.1.23.v201012071420.jar.
=> SHA256 Checksum OK for eclipse/org.objectweb.asm_3.3.1.v201105211655.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.core_2.3.0.v20110329.jar.
=> SHA256 Checksum OK for eclipse/org.sat4j.pb_2.3.0.v20110329.jar.
===>  Giving up on fetching files: eclipse/org.hamcrest.core_1.1.0.v20090501071000.jar 
Make sure the Makefile and distinfo file (/usr/ports/java/eclipse-devel/distinfo)
are up to date.  If you are absolutely sure you want to override this
check, type "make NO_CHECKSUM=yes [other args]".
*** Error code 1

Stop in /usr/ports/java/eclipse-devel.
*** Error code 1

Stop in /usr/ports/java/eclipse-devel.
*** Error code 1

Stop in /usr/ports/java/eclipse-devel.
** Command failed [exit code 1]: /usr/bin/script -qa /var/tmp/portupgrade20110713-11405-1xjbzo7-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=eclipse-devel-3.6.1 UPGRADE_PORT_VER=3.6.1 make
** Fix the problem and try again.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! java/eclipse-devel (eclipse-devel-3.6.1)      (checksum mismatch)
Comment 1 Edwin Groothuis freebsd_committer 2011-07-13 07:10:25 UTC
Responsible Changed
From-To: freebsd-ports-bugs->freebsd-eclipse

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 Thomas.Gellekum 2011-07-13 08:33:32 UTC
They re-rolled the JAR, so there were date changes on two files inside. 
Checksums recorded in meta-inf/eclipsef.sf match the old version. I have 
attached an update to distinfo.

tg
Comment 3 dfilter freebsd_committer 2011-07-17 00:06:38 UTC
glewis      2011-07-16 23:06:29 UTC

  FreeBSD ports repository

  Modified files:
    java/eclipse-devel   distinfo 
  Log:
  . Chase re-rolled JAR file.
  
  PR:             158859
  Submitted by:   tg@
  
  Revision  Changes    Path
  1.14      +2 -2      ports/java/eclipse-devel/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 4 Greg Lewis freebsd_committer 2011-07-17 00:07:17 UTC
State Changed
From-To: open->closed

Committed the patch from Thomas.  Thanks!