Bug 159798 - [MAINTAINER] sysutils/lsof: update to 4.85D
Summary: [MAINTAINER] sysutils/lsof: update to 4.85D
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Chris Rees
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-15 20:20 UTC by Larry Rosenman
Modified: 2011-08-17 08:30 UTC (History)
0 users

See Also:


Attachments
lsof-4.85D_1,5.patch (941 bytes, patch)
2011-08-15 20:20 UTC, Larry Rosenman
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Larry Rosenman freebsd_committer 2011-08-15 20:20:02 UTC
- Update to 4.85D
Better FreeBSD 9.0-BETA1 support

Generated with FreeBSD Port Tools 0.99
Comment 1 Chris Rees freebsd_committer 2011-08-15 20:44:10 UTC
Responsible Changed
From-To: freebsd-ports-bugs->crees

I'll take it.
Comment 2 Chris Rees freebsd_committer 2011-08-16 08:01:51 UTC
State Changed
From-To: open->feedback

Hm, I'm afraid it fails on FreeBSD 9. I'm going to update my Tinderbox 
to the latest current to check -- have you tested it on CURRENT? 
http://www.bayofrum.net/tb/index.php?action=display_markup_log&build=9-local&id=1244
Comment 3 Chris Rees freebsd_committer 2011-08-16 10:07:47 UTC
On 16 August 2011 08:51, Larry Rosenman <ler@lerctr.org> wrote:
> I will check it. How does it fail for you?
> --
> Sent from my Android phone with K-9 Mail. Please excuse my brevity.

There's a link to the complete log in my original email, but the
failure is here:

===> Building for lsof-4.85D_1,5
(cd lib; make DEBUG="-O" CFGF="-DHASEFFNLINK=i_effnlink -DHASF_VNODE
-DHASSBSTATE -DHAS_KVM_VNODE -DHAS_UFS1_2 -DHAS_VM_MEMATTR_T
-DHAS_CDEV2PRIV -DHAS_NO_SI_UDEV -DHAS_SYS_SX_H -DHAS_ZFS
-DHAS_V_LOCKF -DHAS_LOCKF_ENTRY -DHAS_NO_6PORT -DHAS_NO_6PPCB
-DFREEBSDV=9000 -DHASFDESCFS=2 -DHASPSEUDOFS -DHASNULLFS -DHASIPv6
-DHASUTMPX -DHAS_STRFTIME -DLSOF_VSTR=\"9.0-CURRENT\"")
cc -DHASEFFNLINK=i_effnlink -DHASF_VNODE -DHASSBSTATE -DHAS_KVM_VNODE
-DHAS_UFS1_2 -DHAS_VM_MEMATTR_T -DHAS_CDEV2PRIV -DHAS_NO_SI_UDEV
-DHAS_SYS_SX_H -DHAS_ZFS -DHAS_V_LOCKF -DHAS_LOCKF_ENTRY
-DHAS_NO_6PORT -DHAS_NO_6PPCB -DFREEBSDV=9000 -DHASFDESCFS=2
-DHASPSEUDOFS -DHASNULLFS -DHASIPv6 -DHASUTMPX -DHAS_STRFTIME
-DLSOF_VSTR="9.0-CURRENT" -I/usr/src/sys -O -c ckkv.c
In file included from ../dlsof.h:90,
from ../lsof.h:195,
from ckkv.c:43:
/usr/src/sys/sys/conf.h:338: warning: parameter names (without types)
in function declaration
In file included from /usr/src/sys/vm/pmap.h:89,
from ../dlsof.h:400,
from ../lsof.h:195,
from ckkv.c:43:
/usr/include/machine/pmap.h:436: error: expected
specifier-qualifier-list before 'cpumask_t'
*** Error code 1
Stop in /work/a/ports/workspace/pcvs/lsof/work/lsof_4.85D.freebsd/lib.
*** Error code 1
Stop in /work/a/ports/workspace/pcvs/lsof/work/lsof_4.85D.freebsd.
*** Error code 1
Stop in /a/ports/workspace/pcvs/lsof.

The issue is from r222813 [1], log can be found at [2].

Perhaps doing a REINPLACE_CMD to replace cpumask_t with cpuset_t might
fix it, I'll investigate and let you know.

Upstream could do with knowing too if that fixes it.

Chris


[1] http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/i386/include/pmap.h.diff?r1=1.153;r2=1.154;f=h

[2] http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/i386/include/pmap.h
Comment 4 Larry Rosenman freebsd_committer 2011-08-16 14:44:21 UTC
It compiles just fine on my 9.0-BETA1 system that is up to date as of Sunday
afternoon (US/Central).

Can you double check that you've done a make world/install world with your
current sources?



-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: ler@lerctr.org
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893

-----Original Message-----
From: utisoft@gmail.com [mailto:utisoft@gmail.com] On Behalf Of Chris Rees
Sent: Tuesday, August 16, 2011 4:08 AM
To: Larry Rosenman; bug-followup@freebsd.org
Subject: Re: ports/159798: [MAINTAINER] sysutils/lsof: update to 4.85D

On 16 August 2011 08:51, Larry Rosenman <ler@lerctr.org> wrote:
> I will check it. How does it fail for you?
> --
> Sent from my Android phone with K-9 Mail. Please excuse my brevity.

There's a link to the complete log in my original email, but the
failure is here:

===> Building for lsof-4.85D_1,5
(cd lib; make DEBUG="-O" CFGF="-DHASEFFNLINK=i_effnlink -DHASF_VNODE
-DHASSBSTATE -DHAS_KVM_VNODE -DHAS_UFS1_2 -DHAS_VM_MEMATTR_T
-DHAS_CDEV2PRIV -DHAS_NO_SI_UDEV -DHAS_SYS_SX_H -DHAS_ZFS
-DHAS_V_LOCKF -DHAS_LOCKF_ENTRY -DHAS_NO_6PORT -DHAS_NO_6PPCB
-DFREEBSDV=9000 -DHASFDESCFS=2 -DHASPSEUDOFS -DHASNULLFS -DHASIPv6
-DHASUTMPX -DHAS_STRFTIME -DLSOF_VSTR=\"9.0-CURRENT\"")
cc -DHASEFFNLINK=i_effnlink -DHASF_VNODE -DHASSBSTATE -DHAS_KVM_VNODE
-DHAS_UFS1_2 -DHAS_VM_MEMATTR_T -DHAS_CDEV2PRIV -DHAS_NO_SI_UDEV
-DHAS_SYS_SX_H -DHAS_ZFS -DHAS_V_LOCKF -DHAS_LOCKF_ENTRY
-DHAS_NO_6PORT -DHAS_NO_6PPCB -DFREEBSDV=9000 -DHASFDESCFS=2
-DHASPSEUDOFS -DHASNULLFS -DHASIPv6 -DHASUTMPX -DHAS_STRFTIME
-DLSOF_VSTR="9.0-CURRENT" -I/usr/src/sys -O -c ckkv.c
In file included from ../dlsof.h:90,
from ../lsof.h:195,
from ckkv.c:43:
/usr/src/sys/sys/conf.h:338: warning: parameter names (without types)
in function declaration
In file included from /usr/src/sys/vm/pmap.h:89,
from ../dlsof.h:400,
from ../lsof.h:195,
from ckkv.c:43:
/usr/include/machine/pmap.h:436: error: expected
specifier-qualifier-list before 'cpumask_t'
*** Error code 1
Stop in /work/a/ports/workspace/pcvs/lsof/work/lsof_4.85D.freebsd/lib.
*** Error code 1
Stop in /work/a/ports/workspace/pcvs/lsof/work/lsof_4.85D.freebsd.
*** Error code 1
Stop in /a/ports/workspace/pcvs/lsof.

The issue is from r222813 [1], log can be found at [2].

Perhaps doing a REINPLACE_CMD to replace cpumask_t with cpuset_t might
fix it, I'll investigate and let you know.

Upstream could do with knowing too if that fixes it.

Chris


[1]
http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/i386/include/pmap.h.diff?r1=1.
153;r2=1.154;f=h

[2] http://www.freebsd.org/cgi/cvsweb.cgi/src/sys/i386/include/pmap.h
Comment 5 Chris Rees freebsd_committer 2011-08-16 17:06:07 UTC
State Changed
From-To: feedback->open

Submitter has suggested that I should update my Tinderbox :) Doing so.
Comment 6 dfilter service freebsd_committer 2011-08-17 08:25:36 UTC
crees       2011-08-17 07:25:27 UTC

  FreeBSD ports repository

  Modified files:
    sysutils/lsof        Makefile distinfo 
  Log:
  Update to 4.85D to support latest 9.0-BETA1
  
  PR:             ports/159798
  Submitted by:   Larry Rosenman <ler@lerctr.org> (maintainer)
  
  Revision  Changes    Path
  1.187     +7 -1      ports/sysutils/lsof/Makefile
  1.148     +2 -2      ports/sysutils/lsof/distinfo
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 7 Chris Rees freebsd_committer 2011-08-17 08:25:47 UTC
State Changed
From-To: open->closed

Committed. Thanks!