Bug 160184 - graphics/jpeg2pdf is broken with ruby 1.9, but does not report it
Summary: graphics/jpeg2pdf is broken with ruby 1.9, but does not report it
Status: Closed FIXED
Alias: None
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s) (show other bugs)
Version: Latest
Hardware: Any Any
: Normal Affects Only Me
Assignee: Steve Wills
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-08-25 15:00 UTC by Oliver Heesakkers
Modified: 2011-10-22 18:50 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oliver Heesakkers 2011-08-25 15:00:22 UTC
Switching to ruby 1.9, I noticed that jpeg2pdf stopped to function. This is not evident in the build-process, but only when you want to use it:

<internal:lib/rubygems/custom_require>:29:in `require': /usr/local/lib/ruby/site_ruby/1.9/rpdf/document.rb:21: invalid multibyte char (US-ASCII) (SyntaxError)
/usr/local/lib/ruby/site_ruby/1.9/rpdf/document.rb:21: invalid multibyte char (US-ASCII)
/usr/local/lib/ruby/site_ruby/1.9/rpdf/document.rb:21: syntax error, unexpected $end, expecting keyword_end
      bytes << "&#65533;&#65533;&#65533;\n"  # Ensure file transfer...
                  ^
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from /usr/local/lib/ruby/site_ruby/1.9/rpdf.rb:30:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from /usr/local/lib/ruby/site_ruby/1.9/jpeg2pdf.rb:30:in `<top (required)>'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from <internal:lib/rubygems/custom_require>:29:in `require'
        from /usr/local/bin/jpeg2pdf:33:in `<main>'

Fix: 

I realized I could write a shell script calling ImageMagick and ghostscript to get the same functionality, so I've dropped this port entirely.

The port needs either fixing or a warning to indicate that it's broken with ruby 1.9, something like:

.if ${RUBY_VER} == 1.9
BROKEN= does not work with ruby 1.9
.endif
How-To-Repeat: Use graphics/jpeg2pdf with ruby 1.9
Comment 1 Edwin Groothuis freebsd_committer 2011-08-25 15:00:30 UTC
Maintainer of graphics/jpeg2pdf,

Please note that PR ports/160184 has just been submitted.

If it contains a patch for an upgrade, an enhancement or a bug fix
you agree on, reply to this email stating that you approve the patch
and a committer will take care of it.

The full text of the PR can be found at:
    http://www.freebsd.org/cgi/query-pr.cgi?pr=ports/160184

-- 
Edwin Groothuis via the GNATS Auto Assign Tool
edwin@FreeBSD.org
Comment 2 Edwin Groothuis freebsd_committer 2011-08-25 15:00:32 UTC
State Changed
From-To: open->feedback

Awaiting maintainers feedback (via the GNATS Auto Assign Tool)
Comment 3 Steve Wills freebsd_committer 2011-10-22 18:43:46 UTC
Responsible Changed
From-To: freebsd-ports-bugs->swills

I'll take it.
Comment 4 Steve Wills freebsd_committer 2011-10-22 18:44:48 UTC
State Changed
From-To: feedback->closed

Committed. Thanks!
Comment 5 dfilter service freebsd_committer 2011-10-22 18:44:55 UTC
swills      2011-10-22 17:44:41 UTC

  FreeBSD ports repository

  Modified files:
    graphics/jpeg2pdf    Makefile 
  Log:
  - Mark broken with Ruby 1.9 (builds OK, doesn't run)
  
  PR:             ports/160184
  Submitted by:   Oliver Heesakkers <dev2@heesakkers.info>
  Approved by:    maintainer timeout (>9 weeks)
  
  Revision  Changes    Path
  1.2       +7 -1      ports/graphics/jpeg2pdf/Makefile
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"