Bug 160422 - astro/google-earth: crashes on FreeBSD 9.0
astro/google-earth: crashes on FreeBSD 9.0
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: Juergen Lock
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-03 14:10 UTC by ohartman
Modified: 2013-04-21 15:11 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ohartman 2011-09-03 14:10:10 UTC
The port astro/google-earth crashes on FreeBSD 9.0-BETA2/amd64 as well as on FreeBSD 8.2-STABLE/amd64 with SIGNAL 11. 

The content of the error log file located in folder /home/ohartmann/.googleearth/crashlogs for the FreeBSD 9.0 box is as followed.

Google Earth has caught signal 11.



We apologize for the inconvenience, but Google Earth has crashed.
 This is a bug in the program, and should never happen under normal
 circumstances. A bug report and debugging data have been written
 to this text file:

    /home/ohartmann/.googleearth/crashlogs/crashlog-4e621c52.txt

Please include this file if you submit a bug report to Google.


==>>

Major Version 6
Minor Version 0
Build Number 0003
Build Date May 17 2011
Build Time 00:40:40
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 16
OS Patch Version 0
Crash Signal 11
Crash Time 1315052626
Up Time 2.09553

Stacktrace from glibc:
./libgoogleearth_free.so[0x2813a953]
./libgoogleearth_free.so[0x2813aad3]
[0xffffe047]
./libQtWebKit.so.4[0x29492da2]
./libQtWebKit.so.4[0x29492e15]
./libQtWebKit.so.4[0x29493c66]
./libQtWebKit.so.4[0x29535f44]
./libQtWebKit.so.4[0x29535cf1]
./libQtWebKit.so.4[0x298c1e01]
./libQtWebKit.so.4[0x298c1e62]
./libQtWebKit.so.4[0x299d7536]
./libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x1a7)[0x282e79c7]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac)[0x285a469c]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x426)[0x285af666]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x78)[0x282d5ba8]
./libQtCore.so.4[0x28305af6]
./libQtCore.so.4(_ZN20QEventDispatcherUNIX13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0xc7)[0x28305cb7]
./libQtGui.so.4[0x2865eeee]
./libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x49)[0x282d4b39]
./libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x102)[0x282d4d12]
./libQtGui.so.4(_ZN7QDialog4execEv+0x103)[0x28ab2d33]
./libQtGui.so.4[0x28ada2ff]
./libQtGui.so.4(_ZN11QMessageBox8questionEP7QWidgetRK7QStringS4_S4_S4_S4_ii+0x4a)[0x28ada4da]
/usr/local/share/google-earth/libevll.so(_ZN5earth4evll17RenderContextImpl18RequireDXOGLSwitchERK7QStringS4_+0x1950)[0x32066680]
./librender.so(_ZN12RenderWidget6SetApiEPN5earth4evll3APIE+0x143)[0x2ad2fbe3]
./librender.so(_ZN5earth6render12RenderWindow12createWidgetEv+0x16a)[0x2ad1438a]
./libgoogleearth_free.so(_ZN5earth6client12ModuleWidget9showEventEP10QShowEvent+0x8d)[0x2811544d]
./libQtGui.so.4(_ZN7QWidget5eventEP6QEvent+0x770)[0x28607a60]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac)[0x285a469c]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x484)[0x285af6c4]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x78)[0x282d5ba8]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x145)[0x286096d5]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7d)[0x286093cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0xc5)[0x286094b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x28609a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0x28609560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7d)[0x286093cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0xc5)[0x286094b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x28609a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0x28609560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN14QWidgetPrivate14show_recursiveEv+0x7d)[0x286093cd]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0xc5)[0x286094b5]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x28609a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0x28609560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x28609a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0x28609560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x28609a2b]
./libQtGui.so.4(_ZN14QWidgetPrivate12showChildrenEb+0x170)[0x28609560]
./libQtGui.so.4(_ZN14QWidgetPrivate11show_helperEv+0x61)[0x286095f1]
./libQtGui.so.4(_ZN7QWidget10setVisibleEb+0x1db)[0x28609a2b]
./libQtGui.so.4(_ZN7QWidget10showNormalEv+0x5c)[0x285f716c]
./libgoogleearth_free.so(_ZN10MainWindow18readScreensizeInfoEv+0xd2f)[0x28107bbf]
./libgoogleearth_free.so(_ZN5earth6client11Application12SetupMainWinENS0_3Kvw7ProductEb+0x31c)[0x281418cc]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x50e)[0x28144aae]
./libgoogleearth_free.so[0x2813940b]
./libgoogleearth_free.so(earthmain+0x247)[0x2813a587]
./googleearth-bin[0x804872b]
/lib/libc.so.6(__libc_start_main+0xe5)[0x2a42b6e5]
./googleearth-bin[0x8048671]


The crashfile on the FreeBSD 8.2-STABLE/amd64 box is as follows:

Major Version 6
Minor Version 0
Build Number 0003
Build Date May 17 2011
Build Time 00:40:40
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 16
OS Patch Version 0
Crash Signal 11
Crash Time 1315055039
Up Time 28.9194

Stacktrace from glibc:
./libgoogleearth_free.so[0x2813a953]
./libgoogleearth_free.so[0x2813aad3]
[0xffffefb7]
./libQtCore.so.4(_ZN4QDir9cleanPathERK7QString+0x31d)[0x2825109d]
./libQtCore.so.4[0x282a51c3]
./libQtCore.so.4(_ZNK13QFSFileEngine8fileNameEN19QAbstractFileEngine8FileNameE+0x5cf)[0x282ac4af]
./libQtCore.so.4[0x28260b9f]
./libQtCore.so.4(_ZNK9QFileInfo17canonicalFilePathEv+0x3c)[0x2826141c]
./libQtCore.so.4(_ZN16QCoreApplication19applicationFilePathEv+0x3de)[0x282d8e5e]
./libQtCore.so.4(_ZN16QCoreApplication18applicationDirPathEv+0x6e)[0x282d94ce]
./libQtCore.so.4[0x281cd3ee]
./libQtCore.so.4[0x281cd5ef]
./libQtCore.so.4[0x281cd687]
./libQtCore.so.4(_ZN12QLibraryInfo8locationENS_15LibraryLocationE+0x38)[0x281cd7d8]
./libQtCore.so.4(_ZN16QCoreApplication12libraryPathsEv+0xe3)[0x282d9833]
./libQtCore.so.4(_ZN16QCoreApplication4initEv+0xbb)[0x282d9fbb]
./libQtCore.so.4(_ZN16QCoreApplicationC2ER23QCoreApplicationPrivate+0x44)[0x282da0c4]
./libQtGui.so.4(_ZN12QApplicationC1ERiPPci+0x55)[0x285b3735]
./libgoogleearth_free.so(_ZN5earth6client11ApplicationC1EiPPc+0x77)[0x281463a7]
./libgoogleearth_free.so[0x28139403]
./libgoogleearth_free.so(earthmain+0x247)[0x2813a587]
./googleearth-bin[0x804872b]
/lib/libc.so.6(__libc_start_main+0xe5)[0x2a42b6e5]
./googleearth-bin[0x8048671]

How-To-Repeat: Install astro/google-earth on amd64/SMP boxes and wathc it crashing
Comment 1 Edwin Groothuis freebsd_committer 2011-09-03 14:10:20 UTC
Responsible Changed
From-To: freebsd-ports-bugs->nox

Over to maintainer (via the GNATS Auto Assign Tool)
Comment 2 nox 2011-09-03 20:52:23 UTC
Some googling found this issue with a very similar backtrace that
is marked `Status:  Outdated', `Closed:  Mar 9':

	https://code.google.com/p/earth-issues/issues/detail?id=1132#c0

There is a comment `This issue is still manifesting on Windows versions.',
maybe someone with an account wants to add another comment (linking to
this PR) that it still happens on FreeBSD too?

Here is my backtrace:  (I first thought this was an nvidia-driver
issue since my only 9 box uses that and I only saw the bug there
and back then I didn't google it enough, but if it even happens on
Windows and the other comment on that ticket says `Several memory
corruption issues were fives in 6.0.1.2032.  Couldn't reproduce
with that version.'... :)

Major Version 6
Minor Version 0
Build Number 0003
Build Date May 17 2011
Build Time 00:40:40
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 16
OS Patch Version 0
Crash Signal 11
Crash Time 1315079064
Up Time 7.98596

Stacktrace from glibc:
./libgoogleearth_free.so[0x2813a953]
./libgoogleearth_free.so[0x2813aad3]
[0xffffe067]
./libQtWebKit.so.4[0x294fdda2]
./libQtWebKit.so.4[0x294fde15]
./libQtWebKit.so.4[0x294fec66]
./libQtWebKit.so.4[0x295a0f44]
./libQtWebKit.so.4[0x295a0cf1]
./libQtWebKit.so.4[0x2992ce01]
./libQtWebKit.so.4[0x2992ce62]
./libQtWebKit.so.4[0x29a42536]
./libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x1a7)[0x282e79c7]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac)[0x285a469c]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x426)[0x285af666]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x78)[0x282d5ba8]
./libQtCore.so.4[0x28305af6]
./libQtCore.so.4(_ZN20QEventDispatcherUNIX13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0xc7)[0x28305cb7]
./libQtGui.so.4[0x2865eeee]
./libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x49)[0x282d4b39]
./libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x102)[0x282d4d12]
./libQtCore.so.4(_ZN16QCoreApplication4execEv+0xaf)[0x282d71bf]
./libQtGui.so.4(_ZN12QApplication4execEv+0x27)[0x285a4177]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x605)[0x28144ba5]
./libgoogleearth_free.so[0x2813940b]
./libgoogleearth_free.so(earthmain+0x247)[0x2813a587]
./googleearth-bin[0x804872b]
/lib/libc.so.6(__libc_start_main+0xe5)[0x2a4966e5]
./googleearth-bin[0x8048671]
Comment 3 Oliver Heesakkers 2011-12-11 13:06:05 UTC
The same thing is happening for 5.2.1.1588 (:previous) on my 9.0 RC2 without 
any clang.

According to the ports-history, the 5.2-version was shortly used, but 
abandoned due to, again very similar, problems.
Comment 4 nox 2012-01-18 17:36:30 UTC
6.1.0.5001 crashes similarly:

Major Version 6
Minor Version 1
Build Number 0000
Build Date Oct 17 2011
Build Time 04:05:20
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 16
OS Patch Version 0
Crash Signal 11
Crash Time 1326907223
Up Time 3.61168

Stacktrace from glibc:
./libgoogleearth_free.so[0x2814bd53]
./libgoogleearth_free.so[0x2814bed3]
[0xffffe067]
./libQtWebKit.so.4[0x29518da2]
./libQtWebKit.so.4[0x29518e15]
./libQtWebKit.so.4[0x29519c66]
./libQtWebKit.so.4[0x295bbf44]
./libQtWebKit.so.4[0x295bbcf1]
./libQtWebKit.so.4[0x29947e01]
./libQtWebKit.so.4[0x29947e62]
./libQtWebKit.so.4[0x29a5d536]
./libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x1a7)[0x282fd9c7]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xac)[0x285b969c]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x426)[0x285c4666]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x78)[0x282ebba8]
./libQtCore.so.4[0x2831baf6]
./libQtCore.so.4(_ZN20QEventDispatcherUNIX13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0xc7)[0x2831bcb7]
./libQtGui.so.4[0x28673eee]
./libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x49)[0x282eab39]
./libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0x102)[0x282ead12]
./libQtCore.so.4(_ZN16QCoreApplication4execEv+0xaf)[0x282ed1bf]
./libQtGui.so.4(_ZN12QApplication4execEv+0x27)[0x285b9177]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x7e0)[0x28156090]
./libgoogleearth_free.so[0x2814a80b]
./libgoogleearth_free.so(earthmain+0x247)[0x2814b987]
./googleearth-bin[0x804876b]
/lib/libc.so.6(__libc_start_main+0xe5)[0x2a4b16e5]
./googleearth-bin[0x80486b1]
Comment 5 dfilter freebsd_committer 2012-01-18 17:56:23 UTC
nox         2012-01-18 17:56:15 UTC

  FreeBSD ports repository

  Modified files:
    astro/google-earth   Makefile distinfo pkg-plist 
    astro/google-earth/files patch-bin-googleearth 
  Added files:
    astro/google-earth/files Google-googleearth.desktop.in 
                             googleearth-mimetypes.xml 
  Log:
  Update to 6.1.0.5001 (which unfortunately still crashes on >= 9.0/amd64 ):
  
  PR:             ports/160422 (the 9.x crash and backtrace)
  Noticed by:     Yuri <yuri@rawbw.com> (via private email)
  
  Revision  Changes    Path
  1.49      +20 -29    ports/astro/google-earth/Makefile
  1.28      +2 -2      ports/astro/google-earth/distinfo
  1.1       +13 -0     ports/astro/google-earth/files/Google-googleearth.desktop.in (new)
  1.1       +21 -0     ports/astro/google-earth/files/googleearth-mimetypes.xml (new)
  1.3       +6 -8      ports/astro/google-earth/files/patch-bin-googleearth
  1.21      +57 -613   ports/astro/google-earth/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 6 yuri 2012-01-26 09:08:22 UTC
I think google earth 6.1.0.5001,1 works fine now on 9.0 amd64.
I just installed it on installed from scratch dependency packages, and 
it works actually faster than on 8.2 on the same hardware and didn't crash.

Yuri
Comment 7 ohartman 2012-01-26 09:31:08 UTC
On 01/26/12 10:08, Yuri wrote:
> I think google earth 6.1.0.5001,1 works fine now on 9.0 amd64.
> I just installed it on installed from scratch dependency packages, and
> it works actually faster than on 8.2 on the same hardware and didn't crash.
> 
> Yuri



Still the same here. Appended, the required log:


Major Version 6
Minor Version 1
Build Number 0000
Build Date Oct 17 2011
Build Time 04:05:20
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 16
OS Patch Version 0
Crash Signal 11
Crash Time 1327570001
Up Time 40.7457

Stacktrace from glibc:
./libgoogleearth_free.so(+0xbcd53)[0x28147d53]
./libgoogleearth_free.so(+0xbced3)[0x28147ed3]
[0xffffe047]
./libQtCore.so.4(_ZN4QDir9cleanPathERK7QString+0x31d)[0x2826309d]
./libQtCore.so.4(+0x1391c3)[0x282b71c3]
./libQtCore.so.4(_ZNK13QFSFileEngine8fileNameEN19QAbstractFileEngine8FileNameE+0x5cf)[0x282be4af]
./libQtCore.so.4(+0xf4b9f)[0x28272b9f]
./libQtCore.so.4(_ZNK9QFileInfo17canonicalFilePathEv+0x3c)[0x2827341c]
./libQtCore.so.4(_ZN16QCoreApplication19applicationFilePathEv+0x3de)[0x282eae5e]
./libQtCore.so.4(_ZN16QCoreApplication18applicationDirPathEv+0x6e)[0x282eb4ce]
./libQtCore.so.4(+0x613ee)[0x281df3ee]
./libQtCore.so.4(+0x615ef)[0x281df5ef]
./libQtCore.so.4(+0x61687)[0x281df687]
./libQtCore.so.4(_ZN12QLibraryInfo8locationENS_15LibraryLocationE+0x38)[0x281df7d8]
./libQtCore.so.4(_ZN16QCoreApplication12libraryPathsEv+0xe3)[0x282eb833]
./libQtCore.so.4(_ZN16QCoreApplication4initEv+0xbb)[0x282ebfbb]
./libQtCore.so.4(_ZN16QCoreApplicationC2ER23QCoreApplicationPrivate+0x44)[0x282ec0c4]
./libQtGui.so.4(_ZN12QApplicationC1ERiPPci+0x55)[0x285c5735]
./libgoogleearth_free.so(_ZN5earth6client11ApplicationC1EiPPc+0x77)[0x281538a7]
./libgoogleearth_free.so(+0xbb803)[0x28146803]
./libgoogleearth_free.so(earthmain+0x247)[0x28147987]
./googleearth-bin[0x804876b]
/lib/libc.so.6(__libc_start_main+0xe6)[0x2a4adcc6]
./googleearth-bin[0x80486b1]
Comment 8 dfilter freebsd_committer 2012-01-29 16:28:11 UTC
nox         2012-01-29 16:27:58 UTC

  FreeBSD ports repository

  Modified files:
    astro/google-earth   Makefile distinfo pkg-plist 
    astro/google-earth/files patch-bin-googleearth 
  Removed files:
    astro/google-earth/files Google-googleearth.desktop.in 
                             googleearth-mimetypes.xml 
  Log:
  - Go back to previous version, 6.0.3.2197, as the new one, 6.2.0.5905,
    not only still crashes on 9.x/amd64 [1] but now also on 8.x with
    Radeon Graphics: (using Xorg drivers as there is no fglrx for FreeBSD)
  
          http://people.freebsd.org/~nox/tmp/google-earth-6.2.0.5905/8-radeon-amd64/crashlog-4f24bff5.txt
  
    Port shar for 6.2.0.5905 for testing:
  
          http://people.freebsd.org/~nox/tmp/google-earth-6.2.0.5905/google-earth-6.2.0.5905.shar
  
    Crashlog for 6.2.0.5905 on 9.x/amd64 with Nvidia Graphics:
  
          http://people.freebsd.org/~nox/tmp/google-earth-6.2.0.5905/9-nvidia-amd64/crashlog-4f24c0d5.txt
  
    Crashlog for 6.1.0.5001 on 9.x/amd64 with Nvidia Graphics for comparison:
  
          http://people.freebsd.org/~nox/tmp/google-earth-6.1.0.5001/9-nvidia-amd64/crashlog-4f16ff57.txt
  
  - Bump PORTEPOCH.
  
  PR:             ports/160422 [1]
  Submitted by:   "Hartmann, O." <ohartman@zedat.fu-berlin.de> [1]
  
  Revision  Changes    Path
  1.50      +30 -21    ports/astro/google-earth/Makefile
  1.29      +2 -2      ports/astro/google-earth/distinfo
  1.2       +0 -13     ports/astro/google-earth/files/Google-googleearth.desktop.in (dead)
  1.2       +0 -21     ports/astro/google-earth/files/googleearth-mimetypes.xml (dead)
  1.4       +8 -6      ports/astro/google-earth/files/patch-bin-googleearth
  1.22      +613 -57   ports/astro/google-earth/pkg-plist
_______________________________________________
cvs-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/cvs-all
To unsubscribe, send any mail to "cvs-all-unsubscribe@freebsd.org"
Comment 9 Marcus von Appen freebsd_committer 2012-05-15 16:51:32 UTC
Version 5.2.1.1588 on RELENG_9, amd64 with x11/nvidia-driver-295.49
works without any problems.

Can we remove the BROKEN line as long as it is not updated?

Regards
Marcus
Comment 10 nox 2012-05-15 22:28:45 UTC
On Tue, May 15, 2012 at 04:00:13PM +0000, Marcus von Appen wrote:
> The following reply was made to PR ports/160422; it has been noted by GNATS.
> 
> From: Marcus von Appen <mva@FreeBSD.org>
> To: bug-followup@FreeBSD.org, ohartman@zedat.fu-berlin.de
> Cc:  
> Subject: Re: ports/160422: astro/google-earth: crashes on FreeBSD 9.0
> Date: Tue, 15 May 2012 17:51:32 +0200

>  Version 5.2.1.1588 on RELENG_9, amd64 with x11/nvidia-driver-295.49
>  works without any problems.
>  
>  Can we remove the BROKEN line as long as it is not updated?

I just tested on head, r235381, amd64, and got a similar crash as
before:

Major Version 5
Minor Version 2
Build Number 0001
Build Date Sep  1 2010
Build Time 11:25:42
OS Type 3
OS Major Version 2
OS Minor Version 6
OS Build Version 16
OS Patch Version 0
Crash Signal 11
Crash Time 1337116197
Up Time 2.54237

Stacktrace from glibc:
./libgoogleearth_free.so[0x2813c90b]
[0xffffe067]
./libQtWebKit.so.4[0x28ff7f23]
./libQtWebKit.so.4[0x28ff7f5f]
./libQtWebKit.so.4[0x28ff7f79]
./libQtWebKit.so.4[0x28ff7fd3]
./libQtWebKit.so.4[0x290b5da8]
./libQtWebKit.so.4[0x290b5d1c]
./libQtWebKit.so.4[0x29457709]
./libQtWebKit.so.4[0x294577ad]
./libQtWebKit.so.4[0x2956a908]
./libQtCore.so.4(_ZN7QObject5eventEP6QEvent+0x112)[0x283dbfca]
./libQtGui.so.4(_ZN19QApplicationPrivate13notify_helperEP7QObjectP6QEvent+0xa0)[0x2863ae20]
./libQtGui.so.4(_ZN12QApplication6notifyEP7QObjectP6QEvent+0x22e)[0x28644962]
./libQtCore.so.4(_ZN16QCoreApplication14notifyInternalEP7QObjectP6QEvent+0x70)[0x283cdd50]
./libQtCore.so.4[0x283f3743]
./libQtCore.so.4(_ZN20QEventDispatcherUNIX14activateTimersEv+0x17)[0x283f381f]
./libQtCore.so.4(_ZN20QEventDispatcherUNIX13processEventsE6QFlagsIN10QEventLoop17ProcessEventsFlagEE+0xd9)[0x283f39ed]
./libQtGui.so.4[0x286cfca4]
./libQtCore.so.4(_ZN10QEventLoop13processEventsE6QFlagsINS_17ProcessEventsFlagEE+0x47)[0x283ccfbf]
./libQtCore.so.4(_ZN10QEventLoop4execE6QFlagsINS_17ProcessEventsFlagEE+0xff)[0x283cd223]
./libQtCore.so.4(_ZN16QCoreApplication4execEv+0x9d)[0x283cec05]
./libQtGui.so.4(_ZN12QApplication4execEv+0x25)[0x2863a7a1]
./libgoogleearth_free.so(_ZN5earth6client11Application3runEv+0x4bc)[0x28147b0c]
./libgoogleearth_free.so(earthmain+0x27d)[0x2813bd3d]
./googleearth-bin(_init+0x12e)[0x80486d2]
/lib/libc.so.6(__libc_start_main+0xe5)[0x29c596e5]
./googleearth-bin(_init+0x9d)[0x8048641]
Comment 11 yuri 2012-06-09 20:30:38 UTC
I am just reporting that I also got this crash in VM in virtual box with 
the current version 5.2.1.1588_1,3 with the same stack.
However, version 6.1.0.5001,1 that was up in the repository briefly in 
January still works very well on my desktop with NVidia 9400 GT card.
I updated the port to that January 18th version but it doesn't build any 
more. File size mismatch. Sadly they don't keep the rpms or .bin by 
version. Or do they?
Looks like the current version up on their website is 6.0.0.1735-1. So 
they have withdrawn 6.1.0.5001 for some reason.

Yuri
Comment 12 freebsd2013 2013-04-20 02:36:27 UTC
Hi,

Following patch was enough to solve the problem for my setup in 
google-earth port directory:

--- work/google-earth-5/drivers.ini.orig    2013-04-20 
03:04:44.000000000 +0200
+++ work/google-earth-5/drivers.ini    2013-04-20 03:04:55.000000000 +0200
@@ -97,7 +97,7 @@
      }}
  }

-OS = linux {
+OS = FreeBSD {
      SETTINGS {
          onlyOGL = true
      }


Regards,

-- Cybil
Comment 13 nox 2013-04-20 16:10:28 UTC
On Sat, Apr 20, 2013 at 01:40:00AM +0000, COURRAUD Cybil wrote:

>  Hi,
>  
>  Following patch was enough to solve the problem for my setup in 
>  google-earth port directory:

>  [...]

Thanx! :)  I'll post a CFT to make sure it works for most people.
Patch I used:

	http://people.freebsd.org/~nox/tmp/google-earth-5.2.1.1588-crashfixp-001.patch
Comment 14 dfilter freebsd_committer 2013-04-21 15:08:48 UTC
Author: nox
Date: Sun Apr 21 14:08:38 2013
New Revision: 316179
URL: http://svnweb.freebsd.org/changeset/ports/316179

Log:
  - Update to 6.0.3.2197, adding a fix [1] for 9.x crashes.
  
  PR:		ports/160422
  Submitted by:	COURRAUD Cybil <freebsd2013@cyb.fr> [1]
  Tested by:	several people on -emulation, thanx! :)
  Feature safe:	yes

Modified:
  head/astro/google-earth/Makefile   (contents, props changed)
  head/astro/google-earth/distinfo   (contents, props changed)
  head/astro/google-earth/pkg-plist   (contents, props changed)

Modified: head/astro/google-earth/Makefile
==============================================================================
--- head/astro/google-earth/Makefile	Sun Apr 21 14:00:08 2013	(r316178)
+++ head/astro/google-earth/Makefile	Sun Apr 21 14:08:38 2013	(r316179)
@@ -6,13 +6,12 @@
 #
 
 PORTNAME=	google-earth
-PORTVERSION=	5.2.1.1588
-PORTREVISION=	1
+PORTVERSION=	6.0.3.2197
 PORTEPOCH=	3
 CATEGORIES=	astro deskutils geography
 MASTER_SITES=	http://dl.google.com/earth/client/advanced/previous/:previous \
 		http://dl.google.com/earth/client/current/:current
-DISTFILES=	GoogleEarthLinux.bin:previous
+DISTFILES=	GoogleEarthLinux.bin:current
 DIST_SUBDIR=	${PORTNAME}/${PORTVERSION}
 EXTRACT_ONLY=	# none
 
@@ -49,9 +48,10 @@ IGNORE=	FreeBSD>=7.X is needed with Linu
 IGNORE=	needs non-default linux ports (define OVERRIDE_LINUX_BASE_PORT=f10 and OVERRIDE_LINUX_NONBASE_PORTS=f10)
 .endif
 
-.if ${OSVERSION} >= 900000 && ${ARCH} == "amd64"
-BROKEN=	seems to crash on >= 9.x/amd64: http://www.freebsd.org/cgi/query-pr.cgi?pr=160422
-.endif
+# Fixed by the first post-patch target line?  Also, linprocfs needs to be mounted.
+#.if ${OSVERSION} >= 900000 && ${ARCH} == "amd64"
+#BROKEN=	seems to crash on >= 9.x/amd64: http://www.freebsd.org/cgi/query-pr.cgi?pr=160422
+#.endif
 
 do-extract:
 	@${MKDIR} ${WRKSRC}
@@ -61,6 +61,7 @@ do-extract:
 	@cd ${WRKSRC} && ${TAR} xf googleearth-linux-x86.tar && ${RM} -f googleearth-linux-x86.tar
 
 post-patch:
+	@${REINPLACE_CMD} -i "" -e '/OS.*=/s|linux|FreeBSD|' ${WRKSRC}/drivers.ini
 	@${REINPLACE_CMD} -i "" -e 's|^# Set the home.*|GOOGLEEARTH_DATA_PATH=${DATADIR}|' ${WRKSRC}/bin/googleearth
 	@${REINPLACE_CMD} -i "" -e "s|^# Let's boogie.*|rm -f \$${HOME}/.googleearth/instance-running-lock|" ${WRKSRC}/bin/googleearth
 	@${REINPLACE_CMD} -i "" -e 's/^TMPPATH.*/exit 0/' ${WRKSRC}/postinstall.sh

Modified: head/astro/google-earth/distinfo
==============================================================================
--- head/astro/google-earth/distinfo	Sun Apr 21 14:00:08 2013	(r316178)
+++ head/astro/google-earth/distinfo	Sun Apr 21 14:08:38 2013	(r316179)
@@ -1,2 +1,2 @@
-SHA256 (google-earth/5.2.1.1588/GoogleEarthLinux.bin) = 2e6fcbd2384446e2a6eed8ca23173e32c5f3f9ae4d1168e2e348c3924fd2bf30
-SIZE (google-earth/5.2.1.1588/GoogleEarthLinux.bin) = 31406473
+SHA256 (google-earth/6.0.3.2197/GoogleEarthLinux.bin) = 8c1cabb6a196e93224be05bd8a4786087813075f76e1734a17680c30a9ad972d
+SIZE (google-earth/6.0.3.2197/GoogleEarthLinux.bin) = 33688483

Modified: head/astro/google-earth/pkg-plist
==============================================================================
--- head/astro/google-earth/pkg-plist	Sun Apr 21 14:00:08 2013	(r316178)
+++ head/astro/google-earth/pkg-plist	Sun Apr 21 14:08:38 2013	(r316179)
@@ -6,6 +6,33 @@ bin/googleearth
 %%DATADIR%%/README.linux
 %%DATADIR%%/bin/googleearth
 %%DATADIR%%/bin/browserwrapper
+%%DATADIR%%/desktop_icons/consumer/product_logo_128.png
+%%DATADIR%%/desktop_icons/consumer/product_logo_16.png
+%%DATADIR%%/desktop_icons/consumer/product_logo_22.png
+%%DATADIR%%/desktop_icons/consumer/product_logo_24.png
+%%DATADIR%%/desktop_icons/consumer/product_logo_256.png
+%%DATADIR%%/desktop_icons/consumer/product_logo_32.png
+%%DATADIR%%/desktop_icons/consumer/product_logo_32.xpm
+%%DATADIR%%/desktop_icons/consumer/product_logo_48.png
+%%DATADIR%%/desktop_icons/consumer/product_logo_64.png
+%%DATADIR%%/desktop_icons/ec/product_logo_128.png
+%%DATADIR%%/desktop_icons/ec/product_logo_16.png
+%%DATADIR%%/desktop_icons/ec/product_logo_22.png
+%%DATADIR%%/desktop_icons/ec/product_logo_24.png
+%%DATADIR%%/desktop_icons/ec/product_logo_256.png
+%%DATADIR%%/desktop_icons/ec/product_logo_32.png
+%%DATADIR%%/desktop_icons/ec/product_logo_32.xpm
+%%DATADIR%%/desktop_icons/ec/product_logo_48.png
+%%DATADIR%%/desktop_icons/ec/product_logo_64.png
+%%DATADIR%%/desktop_icons/pro/product_logo_128.png
+%%DATADIR%%/desktop_icons/pro/product_logo_16.png
+%%DATADIR%%/desktop_icons/pro/product_logo_22.png
+%%DATADIR%%/desktop_icons/pro/product_logo_24.png
+%%DATADIR%%/desktop_icons/pro/product_logo_256.png
+%%DATADIR%%/desktop_icons/pro/product_logo_32.png
+%%DATADIR%%/desktop_icons/pro/product_logo_32.xpm
+%%DATADIR%%/desktop_icons/pro/product_logo_48.png
+%%DATADIR%%/desktop_icons/pro/product_logo_64.png
 %%DATADIR%%/drivers.ini
 %%DATADIR%%/googleearth-bin
 %%DATADIR%%/googleearth-icon.png
@@ -114,6 +141,15 @@ bin/googleearth
 %%DATADIR%%/linux/xdg/xdg-mime
 %%DATADIR%%/plugins/imageformats/libqgif.so
 %%DATADIR%%/plugins/imageformats/libqjpeg.so
+%%DATADIR%%/product_logo_128.png
+%%DATADIR%%/product_logo_16.png
+%%DATADIR%%/product_logo_22.png
+%%DATADIR%%/product_logo_24.png
+%%DATADIR%%/product_logo_256.png
+%%DATADIR%%/product_logo_32.png
+%%DATADIR%%/product_logo_32.xpm
+%%DATADIR%%/product_logo_48.png
+%%DATADIR%%/product_logo_64.png
 %%DATADIR%%/qt.conf
 %%DATADIR%%/resources/ad.country/startinglocation.kml
 %%DATADIR%%/resources/ae.country/startinglocation.kml
@@ -122,7 +158,6 @@ bin/googleearth
 %%DATADIR%%/resources/ai.country/startinglocation.kml
 %%DATADIR%%/resources/al.country/startinglocation.kml
 %%DATADIR%%/resources/am.country/startinglocation.kml
-%%DATADIR%%/resources/american-flag.png
 %%DATADIR%%/resources/an.country/startinglocation.kml
 %%DATADIR%%/resources/ao.country/startinglocation.kml
 %%DATADIR%%/resources/application.rcc
@@ -130,18 +165,13 @@ bin/googleearth
 %%DATADIR%%/resources/ar.country/startinglocation.kml
 %%DATADIR%%/resources/ar.locale/default_myplaces.kml
 %%DATADIR%%/resources/as.country/startinglocation.kml
-%%DATADIR%%/resources/asian-flag.png
 %%DATADIR%%/resources/at.country/startinglocation.kml
 %%DATADIR%%/resources/au.country/startinglocation.kml
-%%DATADIR%%/resources/auto-service.png
-%%DATADIR%%/resources/auto.png
 %%DATADIR%%/resources/aw.country/startinglocation.kml
 %%DATADIR%%/resources/ax.country/startinglocation.kml
 %%DATADIR%%/resources/az.country/startinglocation.kml
 %%DATADIR%%/resources/ba.country/startinglocation.kml
 %%DATADIR%%/resources/balloons.rcc
-%%DATADIR%%/resources/bang.png
-%%DATADIR%%/resources/bars.png
 %%DATADIR%%/resources/bb.country/startinglocation.kml
 %%DATADIR%%/resources/bd.country/startinglocation.kml
 %%DATADIR%%/resources/be.country/startinglocation.kml
@@ -157,37 +187,24 @@ bin/googleearth
 %%DATADIR%%/resources/br.country/startinglocation.kml
 %%DATADIR%%/resources/bs.country/startinglocation.kml
 %%DATADIR%%/resources/bt.country/startinglocation.kml
-%%DATADIR%%/resources/building.png
-%%DATADIR%%/resources/button-dis-leftendcap-flat.png
-%%DATADIR%%/resources/button-dis-repeating-flat.png
-%%DATADIR%%/resources/button-dis-rightendcap-flat.png
-%%DATADIR%%/resources/button-md-leftendcap-flat.png
-%%DATADIR%%/resources/button-md-repeating-flat.png
-%%DATADIR%%/resources/button-md-rightendcap-flat.png
+%%DATADIR%%/resources/builtin_webdata.rcc
 %%DATADIR%%/resources/bv.country/startinglocation.kml
 %%DATADIR%%/resources/bw.country/startinglocation.kml
 %%DATADIR%%/resources/by.country/startinglocation.kml
 %%DATADIR%%/resources/bz.country/startinglocation.kml
 %%DATADIR%%/resources/ca.country/startinglocation.kml
 %%DATADIR%%/resources/ca.locale/default_myplaces.kml
-%%DATADIR%%/resources/camera32.png
 %%DATADIR%%/resources/cc.country/startinglocation.kml
 %%DATADIR%%/resources/cd.country/startinglocation.kml
 %%DATADIR%%/resources/cf.country/startinglocation.kml
 %%DATADIR%%/resources/cg.country/startinglocation.kml
 %%DATADIR%%/resources/ch.country/startinglocation.kml
-%%DATADIR%%/resources/check-sel.png
-%%DATADIR%%/resources/check-somechildsel.png
-%%DATADIR%%/resources/check-unsel.png
 %%DATADIR%%/resources/ci.country/startinglocation.kml
 %%DATADIR%%/resources/ck.country/startinglocation.kml
 %%DATADIR%%/resources/cl.country/startinglocation.kml
-%%DATADIR%%/resources/closednetworkfolder.png
 %%DATADIR%%/resources/cm.country/startinglocation.kml
 %%DATADIR%%/resources/cn.country/startinglocation.kml
 %%DATADIR%%/resources/co.country/startinglocation.kml
-%%DATADIR%%/resources/coffee_house_16.png
-%%DATADIR%%/resources/collapsedtree.png
 %%DATADIR%%/resources/cr.country/startinglocation.kml
 %%DATADIR%%/resources/cs.country/startinglocation.kml
 %%DATADIR%%/resources/cs.locale/default_myplaces.kml
@@ -201,17 +218,11 @@ bin/googleearth
 %%DATADIR%%/resources/da.locale/default_myplaces.kml
 %%DATADIR%%/resources/de.country/startinglocation.kml
 %%DATADIR%%/resources/de.locale/default_myplaces.kml
-%%DATADIR%%/resources/dining.png
-%%DATADIR%%/resources/dining_16.png
 %%DATADIR%%/resources/dj.country/startinglocation.kml
 %%DATADIR%%/resources/dk.country/startinglocation.kml
 %%DATADIR%%/resources/dm.country/startinglocation.kml
 %%DATADIR%%/resources/do.country/startinglocation.kml
 %%DATADIR%%/resources/doppler.txt
-%%DATADIR%%/resources/drawcircle.png
-%%DATADIR%%/resources/drawline.png
-%%DATADIR%%/resources/drawpolygon.png
-%%DATADIR%%/resources/drawpolyline.png
 %%DATADIR%%/resources/dz.country/startinglocation.kml
 %%DATADIR%%/resources/ec.country/startinglocation.kml
 %%DATADIR%%/resources/ee.country/startinglocation.kml
@@ -225,12 +236,9 @@ bin/googleearth
 %%DATADIR%%/resources/es.country/startinglocation.kml
 %%DATADIR%%/resources/es.locale/default_myplaces.kml
 %%DATADIR%%/resources/et.country/startinglocation.kml
-%%DATADIR%%/resources/fast-food.png
 %%DATADIR%%/resources/fi.country/startinglocation.kml
 %%DATADIR%%/resources/fi.locale/default_myplaces.kml
 %%DATADIR%%/resources/fil.locale/default_myplaces.kml
-%%DATADIR%%/resources/find-next-dis.png
-%%DATADIR%%/resources/find-prev-dis.png
 %%DATADIR%%/resources/fj.country/startinglocation.kml
 %%DATADIR%%/resources/fk.country/startinglocation.kml
 %%DATADIR%%/resources/flightsim/aircraft/f16.acf
@@ -256,17 +264,12 @@ bin/googleearth
 %%DATADIR%%/resources/flightsim/planet/earth.ini
 %%DATADIR%%/resources/fm.country/startinglocation.kml
 %%DATADIR%%/resources/fo.country/startinglocation.kml
-%%DATADIR%%/resources/four-dollars.png
-%%DATADIR%%/resources/fr-layers.png
 %%DATADIR%%/resources/fr.country/startinglocation.kml
 %%DATADIR%%/resources/fr.locale/default_myplaces.kml
-%%DATADIR%%/resources/french-flag.png
 %%DATADIR%%/resources/ga.country/startinglocation.kml
 %%DATADIR%%/resources/gb.country/startinglocation.kml
 %%DATADIR%%/resources/gd.country/startinglocation.kml
 %%DATADIR%%/resources/ge.country/startinglocation.kml
-%%DATADIR%%/resources/geforce_cursor.png
-%%DATADIR%%/resources/geforce_cursor_32.png
 %%DATADIR%%/resources/gf.country/startinglocation.kml
 %%DATADIR%%/resources/gg.country/startinglocation.kml
 %%DATADIR%%/resources/gh.country/startinglocation.kml
@@ -284,8 +287,6 @@ bin/googleearth
 %%DATADIR%%/resources/gy.country/startinglocation.kml
 %%DATADIR%%/resources/he.locale/default_myplaces.kml
 %%DATADIR%%/resources/hi.locale/default_myplaces.kml
-%%DATADIR%%/resources/high_res_places.png
-%%DATADIR%%/resources/highway_16.png
 %%DATADIR%%/resources/hk.country/startinglocation.kml
 %%DATADIR%%/resources/hm.country/startinglocation.kml
 %%DATADIR%%/resources/hn.country/startinglocation.kml
@@ -300,14 +301,12 @@ bin/googleearth
 %%DATADIR%%/resources/il.country/startinglocation.kml
 %%DATADIR%%/resources/im.country/startinglocation.kml
 %%DATADIR%%/resources/in.country/startinglocation.kml
-%%DATADIR%%/resources/invisible.png
 %%DATADIR%%/resources/io.country/startinglocation.kml
 %%DATADIR%%/resources/iq.country/startinglocation.kml
 %%DATADIR%%/resources/ir.country/startinglocation.kml
 %%DATADIR%%/resources/is.country/startinglocation.kml
 %%DATADIR%%/resources/it.country/startinglocation.kml
 %%DATADIR%%/resources/it.locale/default_myplaces.kml
-%%DATADIR%%/resources/italian-flag.png
 %%DATADIR%%/resources/ja.locale/default_myplaces.kml
 %%DATADIR%%/resources/je.country/startinglocation.kml
 %%DATADIR%%/resources/jm.country/startinglocation.kml
@@ -326,15 +325,13 @@ bin/googleearth
 %%DATADIR%%/resources/ky.country/startinglocation.kml
 %%DATADIR%%/resources/kz.country/startinglocation.kml
 %%DATADIR%%/resources/la.country/startinglocation.kml
-%%DATADIR%%/resources/large_traffic_count_16.png
-%%DATADIR%%/resources/layers_16.png
 %%DATADIR%%/resources/lb.country/startinglocation.kml
 %%DATADIR%%/resources/lc.country/startinglocation.kml
 %%DATADIR%%/resources/leftpanel-common.rcc
 %%DATADIR%%/resources/leftpanel-layer.rcc
 %%DATADIR%%/resources/li.country/startinglocation.kml
 %%DATADIR%%/resources/lk.country/startinglocation.kml
-%%DATADIR%%/resources/loading-image.png
+%%DATADIR%%/resources/localshapes.rcc
 %%DATADIR%%/resources/lr.country/startinglocation.kml
 %%DATADIR%%/resources/ls.country/startinglocation.kml
 %%DATADIR%%/resources/lt.country/startinglocation.kml
@@ -347,10 +344,8 @@ bin/googleearth
 %%DATADIR%%/resources/mc.country/startinglocation.kml
 %%DATADIR%%/resources/md.country/startinglocation.kml
 %%DATADIR%%/resources/me.country/startinglocation.kml
-%%DATADIR%%/resources/mexican-flag.png
 %%DATADIR%%/resources/mg.country/startinglocation.kml
 %%DATADIR%%/resources/mh.country/startinglocation.kml
-%%DATADIR%%/resources/misc-dining.png
 %%DATADIR%%/resources/mk.country/startinglocation.kml
 %%DATADIR%%/resources/ml.country/startinglocation.kml
 %%DATADIR%%/resources/mm.country/startinglocation.kml
@@ -378,210 +373,32 @@ bin/googleearth
 %%DATADIR%%/resources/nl.locale/default_myplaces.kml
 %%DATADIR%%/resources/no.country/startinglocation.kml
 %%DATADIR%%/resources/no.locale/default_myplaces.kml
-%%DATADIR%%/resources/node-closed.png
-%%DATADIR%%/resources/node-open.png
-%%DATADIR%%/resources/note.png
+%%DATADIR%%/resources/notifications.rcc
 %%DATADIR%%/resources/np.country/startinglocation.kml
 %%DATADIR%%/resources/nr.country/startinglocation.kml
 %%DATADIR%%/resources/nu.country/startinglocation.kml
 %%DATADIR%%/resources/nz.country/startinglocation.kml
 %%DATADIR%%/resources/om.country/startinglocation.kml
-%%DATADIR%%/resources/one-dollar.png
-%%DATADIR%%/resources/opennetworkfolder.png
-%%DATADIR%%/resources/opentree.png
 %%DATADIR%%/resources/pa.country/startinglocation.kml
-%%DATADIR%%/resources/paddle/1-lv.png
-%%DATADIR%%/resources/paddle/1.png
-%%DATADIR%%/resources/paddle/10-lv.png
-%%DATADIR%%/resources/paddle/10.png
-%%DATADIR%%/resources/paddle/2-lv.png
-%%DATADIR%%/resources/paddle/2.png
-%%DATADIR%%/resources/paddle/3-lv.png
-%%DATADIR%%/resources/paddle/3.png
-%%DATADIR%%/resources/paddle/4-lv.png
-%%DATADIR%%/resources/paddle/4.png
-%%DATADIR%%/resources/paddle/5-lv.png
-%%DATADIR%%/resources/paddle/5.png
-%%DATADIR%%/resources/paddle/6-lv.png
-%%DATADIR%%/resources/paddle/6.png
-%%DATADIR%%/resources/paddle/7-lv.png
-%%DATADIR%%/resources/paddle/7.png
-%%DATADIR%%/resources/paddle/8-lv.png
-%%DATADIR%%/resources/paddle/8.png
-%%DATADIR%%/resources/paddle/9-lv.png
-%%DATADIR%%/resources/paddle/9.png
-%%DATADIR%%/resources/paddle/a-lv.png
-%%DATADIR%%/resources/paddle/a.png
-%%DATADIR%%/resources/paddle/b-lv.png
-%%DATADIR%%/resources/paddle/b.png
-%%DATADIR%%/resources/paddle/blu-blank-lv.png
-%%DATADIR%%/resources/paddle/blu-blank.png
-%%DATADIR%%/resources/paddle/blu-circle-lv.png
-%%DATADIR%%/resources/paddle/blu-circle.png
-%%DATADIR%%/resources/paddle/blu-diamond-lv.png
-%%DATADIR%%/resources/paddle/blu-diamond.png
-%%DATADIR%%/resources/paddle/blu-square-lv.png
-%%DATADIR%%/resources/paddle/blu-square.png
-%%DATADIR%%/resources/paddle/blu-stars-lv.png
-%%DATADIR%%/resources/paddle/blu-stars.png
-%%DATADIR%%/resources/paddle/c-lv.png
-%%DATADIR%%/resources/paddle/c.png
-%%DATADIR%%/resources/paddle/d-lv.png
-%%DATADIR%%/resources/paddle/d.png
-%%DATADIR%%/resources/paddle/e-lv.png
-%%DATADIR%%/resources/paddle/e.png
-%%DATADIR%%/resources/paddle/f-lv.png
-%%DATADIR%%/resources/paddle/f.png
-%%DATADIR%%/resources/paddle/g-lv.png
-%%DATADIR%%/resources/paddle/g.png
-%%DATADIR%%/resources/paddle/go-lv.png
-%%DATADIR%%/resources/paddle/go.png
-%%DATADIR%%/resources/paddle/grn-blank-lv.png
-%%DATADIR%%/resources/paddle/grn-blank.png
-%%DATADIR%%/resources/paddle/grn-circle-lv.png
-%%DATADIR%%/resources/paddle/grn-circle.png
-%%DATADIR%%/resources/paddle/grn-diamond-lv.png
-%%DATADIR%%/resources/paddle/grn-diamond.png
-%%DATADIR%%/resources/paddle/grn-square-lv.png
-%%DATADIR%%/resources/paddle/grn-square.png
-%%DATADIR%%/resources/paddle/grn-stars-lv.png
-%%DATADIR%%/resources/paddle/grn-stars.png
-%%DATADIR%%/resources/paddle/h-lv.png
-%%DATADIR%%/resources/paddle/h.png
-%%DATADIR%%/resources/paddle/i-lv.png
-%%DATADIR%%/resources/paddle/i.png
-%%DATADIR%%/resources/paddle/j-lv.png
-%%DATADIR%%/resources/paddle/j.png
-%%DATADIR%%/resources/paddle/k-lv.png
-%%DATADIR%%/resources/paddle/k.png
-%%DATADIR%%/resources/paddle/l-lv.png
-%%DATADIR%%/resources/paddle/l.png
-%%DATADIR%%/resources/paddle/ltblu-blank-lv.png
-%%DATADIR%%/resources/paddle/ltblu-blank.png
-%%DATADIR%%/resources/paddle/ltblu-circle-lv.png
-%%DATADIR%%/resources/paddle/ltblu-circle.png
-%%DATADIR%%/resources/paddle/ltblu-diamond-lv.png
-%%DATADIR%%/resources/paddle/ltblu-diamond.png
-%%DATADIR%%/resources/paddle/ltblu-square-lv.png
-%%DATADIR%%/resources/paddle/ltblu-square.png
-%%DATADIR%%/resources/paddle/ltblu-stars-lv.png
-%%DATADIR%%/resources/paddle/ltblu-stars.png
-%%DATADIR%%/resources/paddle/m-lv.png
-%%DATADIR%%/resources/paddle/m.png
-%%DATADIR%%/resources/paddle/n-lv.png
-%%DATADIR%%/resources/paddle/n.png
-%%DATADIR%%/resources/paddle/o-lv.png
-%%DATADIR%%/resources/paddle/o.png
-%%DATADIR%%/resources/paddle/p-lv.png
-%%DATADIR%%/resources/paddle/p.png
-%%DATADIR%%/resources/paddle/pause-lv.png
-%%DATADIR%%/resources/paddle/pause.png
-%%DATADIR%%/resources/paddle/pink-blank-lv.png
-%%DATADIR%%/resources/paddle/pink-blank.png
-%%DATADIR%%/resources/paddle/pink-circle-lv.png
-%%DATADIR%%/resources/paddle/pink-circle.png
-%%DATADIR%%/resources/paddle/pink-diamond-lv.png
-%%DATADIR%%/resources/paddle/pink-diamond.png
-%%DATADIR%%/resources/paddle/pink-square-lv.png
-%%DATADIR%%/resources/paddle/pink-square.png
-%%DATADIR%%/resources/paddle/pink-stars-lv.png
-%%DATADIR%%/resources/paddle/pink-stars.png
-%%DATADIR%%/resources/paddle/purple-circle-lv.png
-%%DATADIR%%/resources/paddle/purple-circle.png
-%%DATADIR%%/resources/paddle/purple-diamond-lv.png
-%%DATADIR%%/resources/paddle/purple-diamond.png
-%%DATADIR%%/resources/paddle/purple-square-lv.png
-%%DATADIR%%/resources/paddle/purple-square.png
-%%DATADIR%%/resources/paddle/purple-stars-lv.png
-%%DATADIR%%/resources/paddle/purple-stars.png
-%%DATADIR%%/resources/paddle/q-lv.png
-%%DATADIR%%/resources/paddle/q.png
-%%DATADIR%%/resources/paddle/r-lv.png
-%%DATADIR%%/resources/paddle/r.png
-%%DATADIR%%/resources/paddle/red-circle-lv.png
-%%DATADIR%%/resources/paddle/red-circle.png
-%%DATADIR%%/resources/paddle/red-diamond-lv.png
-%%DATADIR%%/resources/paddle/red-diamond.png
-%%DATADIR%%/resources/paddle/red-square-lv.png
-%%DATADIR%%/resources/paddle/red-square.png
-%%DATADIR%%/resources/paddle/red-stars-lv.png
-%%DATADIR%%/resources/paddle/red-stars.png
-%%DATADIR%%/resources/paddle/route.png
-%%DATADIR%%/resources/paddle/s-lv.png
-%%DATADIR%%/resources/paddle/s.png
-%%DATADIR%%/resources/paddle/stop-lv.png
-%%DATADIR%%/resources/paddle/stop.png
-%%DATADIR%%/resources/paddle/t-lv.png
-%%DATADIR%%/resources/paddle/t.png
-%%DATADIR%%/resources/paddle/u-lv.png
-%%DATADIR%%/resources/paddle/u.png
-%%DATADIR%%/resources/paddle/v-lv.png
-%%DATADIR%%/resources/paddle/v.png
-%%DATADIR%%/resources/paddle/w-lv.png
-%%DATADIR%%/resources/paddle/w.png
-%%DATADIR%%/resources/paddle/wht-blank-lv.png
-%%DATADIR%%/resources/paddle/wht-blank.png
-%%DATADIR%%/resources/paddle/wht-circle-lv.png
-%%DATADIR%%/resources/paddle/wht-circle.png
-%%DATADIR%%/resources/paddle/wht-diamond-lv.png
-%%DATADIR%%/resources/paddle/wht-diamond.png
-%%DATADIR%%/resources/paddle/wht-square-lv.png
-%%DATADIR%%/resources/paddle/wht-square.png
-%%DATADIR%%/resources/paddle/wht-stars-lv.png
-%%DATADIR%%/resources/paddle/wht-stars.png
-%%DATADIR%%/resources/paddle/x-lv.png
-%%DATADIR%%/resources/paddle/x.png
-%%DATADIR%%/resources/paddle/y-lv.png
-%%DATADIR%%/resources/paddle/y.png
-%%DATADIR%%/resources/paddle/ylw-blank-lv.png
-%%DATADIR%%/resources/paddle/ylw-blank.png
-%%DATADIR%%/resources/paddle/ylw-circle-lv.png
-%%DATADIR%%/resources/paddle/ylw-circle.png
-%%DATADIR%%/resources/paddle/ylw-diamond-lv.png
-%%DATADIR%%/resources/paddle/ylw-diamond.png
-%%DATADIR%%/resources/paddle/ylw-square-lv.png
-%%DATADIR%%/resources/paddle/ylw-square.png
-%%DATADIR%%/resources/paddle/ylw-stars-lv.png
-%%DATADIR%%/resources/paddle/ylw-stars.png
-%%DATADIR%%/resources/paddle/z-lv.png
-%%DATADIR%%/resources/paddle/z.png
-%%DATADIR%%/resources/parks.png
 %%DATADIR%%/resources/pe.country/startinglocation.kml
 %%DATADIR%%/resources/pf.country/startinglocation.kml
 %%DATADIR%%/resources/pg.country/startinglocation.kml
 %%DATADIR%%/resources/ph.country/startinglocation.kml
-%%DATADIR%%/resources/photo_icon_64.png
-%%DATADIR%%/resources/photo_listview.png
 %%DATADIR%%/resources/pk.country/startinglocation.kml
 %%DATADIR%%/resources/pl.country/startinglocation.kml
 %%DATADIR%%/resources/pl.locale/default_myplaces.kml
 %%DATADIR%%/resources/pm.country/startinglocation.kml
 %%DATADIR%%/resources/pn.country/startinglocation.kml
 %%DATADIR%%/resources/pr.country/startinglocation.kml
-%%DATADIR%%/resources/premium_lock.png
-%%DATADIR%%/resources/premium_locked.png
-%%DATADIR%%/resources/premium_star.png
-%%DATADIR%%/resources/printlogo.png
 %%DATADIR%%/resources/progress.rcc
 %%DATADIR%%/resources/ps.country/startinglocation.kml
 %%DATADIR%%/resources/pt-PT.locale/default_myplaces.kml
 %%DATADIR%%/resources/pt.country/startinglocation.kml
 %%DATADIR%%/resources/pt.locale/default_myplaces.kml
-%%DATADIR%%/resources/pushpin/blue-pushpin.png
-%%DATADIR%%/resources/pushpin/grn-pushpin.png
-%%DATADIR%%/resources/pushpin/ltblu-pushpin.png
-%%DATADIR%%/resources/pushpin/pink-pushpin.png
-%%DATADIR%%/resources/pushpin/purple-pushpin.png
-%%DATADIR%%/resources/pushpin/red-pushpin.png
-%%DATADIR%%/resources/pushpin/wht-pushpin.png
-%%DATADIR%%/resources/pushpin/ylw-pushpin.png
 %%DATADIR%%/resources/pw.country/startinglocation.kml
 %%DATADIR%%/resources/py.country/startinglocation.kml
 %%DATADIR%%/resources/qa.country/startinglocation.kml
-%%DATADIR%%/resources/query.png
 %%DATADIR%%/resources/re.country/startinglocation.kml
-%%DATADIR%%/resources/recreation.png
-%%DATADIR%%/resources/red_tile.png
 %%DATADIR%%/resources/renderui.rcc
 %%DATADIR%%/resources/ro.country/startinglocation.kml
 %%DATADIR%%/resources/ro.locale/default_myplaces.kml
@@ -592,117 +409,10 @@ bin/googleearth
 %%DATADIR%%/resources/sa.country/startinglocation.kml
 %%DATADIR%%/resources/sb.country/startinglocation.kml
 %%DATADIR%%/resources/sc.country/startinglocation.kml
-%%DATADIR%%/resources/school_16.png
 %%DATADIR%%/resources/sd.country/startinglocation.kml
 %%DATADIR%%/resources/se.country/startinglocation.kml
 %%DATADIR%%/resources/sg.country/startinglocation.kml
 %%DATADIR%%/resources/sh.country/startinglocation.kml
-%%DATADIR%%/resources/shapes/airports.png
-%%DATADIR%%/resources/shapes/arrow-reverse.png
-%%DATADIR%%/resources/shapes/arrow.png
-%%DATADIR%%/resources/shapes/arts.png
-%%DATADIR%%/resources/shapes/bars.png
-%%DATADIR%%/resources/shapes/broken_link.png
-%%DATADIR%%/resources/shapes/bus.png
-%%DATADIR%%/resources/shapes/cabs.png
-%%DATADIR%%/resources/shapes/camera-lv.png
-%%DATADIR%%/resources/shapes/camera.png
-%%DATADIR%%/resources/shapes/campfire.png
-%%DATADIR%%/resources/shapes/campground.png
-%%DATADIR%%/resources/shapes/capital_big.png
-%%DATADIR%%/resources/shapes/capital_big_highlight.png
-%%DATADIR%%/resources/shapes/capital_small.png
-%%DATADIR%%/resources/shapes/capital_small_highlight.png
-%%DATADIR%%/resources/shapes/caution.png
-%%DATADIR%%/resources/shapes/church.png
-%%DATADIR%%/resources/shapes/coffee.png
-%%DATADIR%%/resources/shapes/convenience.png
-%%DATADIR%%/resources/shapes/cross-hairs.png
-%%DATADIR%%/resources/shapes/cross-hairs_highlight.png
-%%DATADIR%%/resources/shapes/cycling.png
-%%DATADIR%%/resources/shapes/dining.png
-%%DATADIR%%/resources/shapes/dollar.png
-%%DATADIR%%/resources/shapes/donut.png
-%%DATADIR%%/resources/shapes/earthquake.png
-%%DATADIR%%/resources/shapes/electronics.png
-%%DATADIR%%/resources/shapes/euro.png
-%%DATADIR%%/resources/shapes/falling_rocks.png
-%%DATADIR%%/resources/shapes/ferry.png
-%%DATADIR%%/resources/shapes/firedept.png
-%%DATADIR%%/resources/shapes/fishing.png
-%%DATADIR%%/resources/shapes/flag.png
-%%DATADIR%%/resources/shapes/forbidden.png
-%%DATADIR%%/resources/shapes/gas_stations.png
-%%DATADIR%%/resources/shapes/golf.png
-%%DATADIR%%/resources/shapes/grocery.png
-%%DATADIR%%/resources/shapes/heliport.png
-%%DATADIR%%/resources/shapes/highway.png
-%%DATADIR%%/resources/shapes/hiker.png
-%%DATADIR%%/resources/shapes/homegardenbusiness.png
-%%DATADIR%%/resources/shapes/horsebackriding.png
-%%DATADIR%%/resources/shapes/hospitals.png
-%%DATADIR%%/resources/shapes/info-i.png
-%%DATADIR%%/resources/shapes/info.png
-%%DATADIR%%/resources/shapes/info_circle.png
-%%DATADIR%%/resources/shapes/lodging.png
-%%DATADIR%%/resources/shapes/man.png
-%%DATADIR%%/resources/shapes/marina.png
-%%DATADIR%%/resources/shapes/mechanic.png
-%%DATADIR%%/resources/shapes/motorcycling.png
-%%DATADIR%%/resources/shapes/mountains.png
-%%DATADIR%%/resources/shapes/movies.png
-%%DATADIR%%/resources/shapes/open-diamond.png
-%%DATADIR%%/resources/shapes/parking_lot.png
-%%DATADIR%%/resources/shapes/parks.png
-%%DATADIR%%/resources/shapes/partly_cloudy.png
-%%DATADIR%%/resources/shapes/pharmacy_rx.png
-%%DATADIR%%/resources/shapes/phone.png
-%%DATADIR%%/resources/shapes/picnic.png
-%%DATADIR%%/resources/shapes/placemark_circle.png
-%%DATADIR%%/resources/shapes/placemark_circle_highlight.png
-%%DATADIR%%/resources/shapes/placemark_square.png
-%%DATADIR%%/resources/shapes/placemark_square_highlight.png
-%%DATADIR%%/resources/shapes/play.png
-%%DATADIR%%/resources/shapes/poi.png
-%%DATADIR%%/resources/shapes/police.png
-%%DATADIR%%/resources/shapes/polygon.png
-%%DATADIR%%/resources/shapes/post_office.png
-%%DATADIR%%/resources/shapes/rail.png
-%%DATADIR%%/resources/shapes/rainy.png
-%%DATADIR%%/resources/shapes/ranger_station.png
-%%DATADIR%%/resources/shapes/realestate.png
-%%DATADIR%%/resources/shapes/road_shield1.png
-%%DATADIR%%/resources/shapes/road_shield2.png
-%%DATADIR%%/resources/shapes/road_shield3.png
-%%DATADIR%%/resources/shapes/ruler.png
-%%DATADIR%%/resources/shapes/sailing.png
-%%DATADIR%%/resources/shapes/salon.png
-%%DATADIR%%/resources/shapes/schools.png
-%%DATADIR%%/resources/shapes/shaded_dot.png
-%%DATADIR%%/resources/shapes/shopping.png
-%%DATADIR%%/resources/shapes/ski.png
-%%DATADIR%%/resources/shapes/snack_bar.png
-%%DATADIR%%/resources/shapes/snowflake_simple.png
-%%DATADIR%%/resources/shapes/square.png
-%%DATADIR%%/resources/shapes/star.png
-%%DATADIR%%/resources/shapes/subway.png
-%%DATADIR%%/resources/shapes/sunny.png
-%%DATADIR%%/resources/shapes/swimming.png
-%%DATADIR%%/resources/shapes/target.png
-%%DATADIR%%/resources/shapes/terrain.png
-%%DATADIR%%/resources/shapes/thunderstorm.png
-%%DATADIR%%/resources/shapes/toilets.png
-%%DATADIR%%/resources/shapes/track.png
-%%DATADIR%%/resources/shapes/trail.png
-%%DATADIR%%/resources/shapes/tram.png
-%%DATADIR%%/resources/shapes/triangle.png
-%%DATADIR%%/resources/shapes/truck.png
-%%DATADIR%%/resources/shapes/volcano.png
-%%DATADIR%%/resources/shapes/water.png
-%%DATADIR%%/resources/shapes/webcam.png
-%%DATADIR%%/resources/shapes/wheel_chair_accessible.png
-%%DATADIR%%/resources/shapes/woman.png
-%%DATADIR%%/resources/shapes/yen.png
 %%DATADIR%%/resources/si.country/startinglocation.kml
 %%DATADIR%%/resources/sj.country/startinglocation.kml
 %%DATADIR%%/resources/sk.country/startinglocation.kml
@@ -717,21 +427,17 @@ bin/googleearth
 %%DATADIR%%/resources/sr.locale/default_myplaces.kml
 %%DATADIR%%/resources/st.country/startinglocation.kml
 %%DATADIR%%/resources/statusbar.rcc
-%%DATADIR%%/resources/streamed_layer.png
-%%DATADIR%%/resources/streamed_layers.png
 %%DATADIR%%/resources/sv.country/startinglocation.kml
 %%DATADIR%%/resources/sv.locale/default_myplaces.kml
 %%DATADIR%%/resources/sy.country/startinglocation.kml
 %%DATADIR%%/resources/sz.country/startinglocation.kml
 %%DATADIR%%/resources/tc.country/startinglocation.kml
 %%DATADIR%%/resources/td.country/startinglocation.kml
-%%DATADIR%%/resources/terrain_16.png
 %%DATADIR%%/resources/terrainmgr.rcc
 %%DATADIR%%/resources/tf.country/startinglocation.kml
 %%DATADIR%%/resources/tg.country/startinglocation.kml
 %%DATADIR%%/resources/th.country/startinglocation.kml
 %%DATADIR%%/resources/th.locale/default_myplaces.kml
-%%DATADIR%%/resources/three-dollars.png
 %%DATADIR%%/resources/tj.country/startinglocation.kml
 %%DATADIR%%/resources/tk.country/startinglocation.kml
 %%DATADIR%%/resources/tl.country/startinglocation.kml
@@ -743,12 +449,9 @@ bin/googleearth
 %%DATADIR%%/resources/tourcontrols.rcc
 %%DATADIR%%/resources/tr.country/startinglocation.kml
 %%DATADIR%%/resources/tr.locale/default_myplaces.kml
-%%DATADIR%%/resources/transp.png
-%%DATADIR%%/resources/transportation.png
 %%DATADIR%%/resources/tt.country/startinglocation.kml
 %%DATADIR%%/resources/tv.country/startinglocation.kml
 %%DATADIR%%/resources/tw.country/startinglocation.kml
-%%DATADIR%%/resources/two-dollars.png
 %%DATADIR%%/resources/tz.country/startinglocation.kml
 %%DATADIR%%/resources/ua.country/startinglocation.kml
 %%DATADIR%%/resources/ug.country/startinglocation.kml
@@ -768,7 +471,6 @@ bin/googleearth
 %%DATADIR%%/resources/vn.country/startinglocation.kml
 %%DATADIR%%/resources/vu.country/startinglocation.kml
 %%DATADIR%%/resources/webbrowser.rcc
-%%DATADIR%%/resources/webcam_16.png
 %%DATADIR%%/resources/wf.country/startinglocation.kml
 %%DATADIR%%/resources/ws.country/startinglocation.kml
 %%DATADIR%%/resources/ye.country/startinglocation.kml
@@ -861,8 +563,14 @@ bin/googleearth
 share/applications/googleearth.desktop
 share/mime/application/earthviewer.xml
 share/mime/application/keyhole.xml
+share/mime/application/vnd.google-earth.kml+xml.xml
+share/mime/application/vnd.google-earth.kmz.xml
 share/mime/packages/googleearth-mimetypes.xml
 @dirrm %%DATADIR%%/bin
+@dirrm %%DATADIR%%/desktop_icons/consumer
+@dirrm %%DATADIR%%/desktop_icons/ec
+@dirrm %%DATADIR%%/desktop_icons/pro
+@dirrm %%DATADIR%%/desktop_icons
 @dirrm %%DATADIR%%/lang
 @dirrm %%DATADIR%%/linux/xdg
 @dirrm %%DATADIR%%/linux
@@ -1070,7 +778,6 @@ share/mime/packages/googleearth-mimetype
 @dirrm %%DATADIR%%/resources/nz.country
 @dirrm %%DATADIR%%/resources/om.country
 @dirrm %%DATADIR%%/resources/pa.country
-@dirrm %%DATADIR%%/resources/paddle
 @dirrm %%DATADIR%%/resources/pe.country
 @dirrm %%DATADIR%%/resources/pf.country
 @dirrm %%DATADIR%%/resources/pg.country
@@ -1085,7 +792,6 @@ share/mime/packages/googleearth-mimetype
 @dirrm %%DATADIR%%/resources/pt-PT.locale
 @dirrm %%DATADIR%%/resources/pt.country
 @dirrm %%DATADIR%%/resources/pt.locale
-@dirrm %%DATADIR%%/resources/pushpin
 @dirrm %%DATADIR%%/resources/pw.country
 @dirrm %%DATADIR%%/resources/py.country
 @dirrm %%DATADIR%%/resources/qa.country
@@ -1103,7 +809,6 @@ share/mime/packages/googleearth-mimetype
 @dirrm %%DATADIR%%/resources/se.country
 @dirrm %%DATADIR%%/resources/sg.country
 @dirrm %%DATADIR%%/resources/sh.country
-@dirrm %%DATADIR%%/resources/shapes
 @dirrm %%DATADIR%%/resources/si.country
 @dirrm %%DATADIR%%/resources/sj.country
 @dirrm %%DATADIR%%/resources/sk.country
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"
Comment 15 Juergen Lock freebsd_committer 2013-04-21 15:11:04 UTC
State Changed
From-To: open->closed

I hope this is now fixed (finally).  Thanx!