Bug 160436 - [ucom] ucom wedges machine on parity error ?
Summary: [ucom] ucom wedges machine on parity error ?
Status: Open
Alias: None
Product: Base System
Classification: Unclassified
Component: usb (show other bugs)
Version: 8.2-STABLE
Hardware: Any Any
: Normal Affects Only Me
Assignee: freebsd-usb mailing list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-09-03 21:00 UTC by Poul-Henning Kamp
Modified: 2018-01-03 05:16 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Poul-Henning Kamp 2011-09-03 21:00:20 UTC
	I'm running Soekris NET4801 doing data collection, it has been
	running stable for years.

	Recently I added a USB-serial port running in raw mode
	at 300/7/EVEN

	The machine started freezing hard and recovered only when the
	watchdog kicked in.

	When frozen, there is no serial console reaction, no packet
	traffic and no signs of a panic message.

	I tried two different USB-serial dongles, one UPLCOM and
	one UFTDI, apart from a possibly slightly different frequency,
	no difference.

	Disabling the software on the USB serial port, made the freezes
	go away.

	I have now moved the parity check into software, running the
	port as 300/8/NONE instead, and the problem has not been seen
	since.

	Has anybody ever tested a parity error on a USB serial port ?
Comment 1 Eitan Adler freebsd_committer freebsd_triage 2017-12-31 08:00:25 UTC
For bugs matching the following criteria:

Status: In Progress Changed: (is less than) 2014-06-01

Reset to default assignee and clear in-progress tags.

Mail being skipped