Bug 161701 - New port: games/chocolate-doom Doom port
New port: games/chocolate-doom Doom port
Status: Closed FIXED
Product: Ports & Packages
Classification: Unclassified
Component: Individual Port(s)
Latest
Any Any
: Normal Affects Only Me
Assigned To: jgh@FreeBSD.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-10-16 05:40 UTC by MP2E
Modified: 2013-01-29 23:00 UTC (History)
0 users

See Also:


Attachments
file.shar (4.64 KB, text/plain)
2011-10-16 05:40 UTC, MP2E
no flags Details
chocolate-doom.shar (4.67 KB, application/x-shar)
2011-10-19 08:46 UTC, MP2E
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description MP2E 2011-10-16 05:40:10 UTC
Chocolate Doom is a port that aims to be as perfectly compatible to the original DOS Doom executables as possible. This includes reproducing bugs, perfect demo compatibility and all the limitations the original Doom2.exe(or doom.exe, final doom executable) had.

I'm sorry if you are getting repeats of the same bug report, I keep trying to send them via send-pr but I don't think my reports are going through. I only see them with a search or get confirmation via the web form.

Fix: Patch attached with submission follows:
Comment 1 Eitan Adler freebsd_committer 2011-10-22 00:55:05 UTC
Responsible Changed
From-To: freebsd-ports-bugs->eadler

I'll take it.
Comment 2 Eitan Adler freebsd_committer 2011-11-02 22:02:00 UTC
Responsible Changed
From-To: eadler->freebsd-ports-bugs

ENOTIME
Comment 3 Pawel Pekala freebsd_committer 2011-12-04 12:16:49 UTC
Responsible Changed
From-To: freebsd-ports-bugs->pawel

I'll take it.
Comment 4 Pawel Pekala freebsd_committer 2011-12-12 22:09:54 UTC
State Changed
From-To: open->feedback

Port leaves files behind when NOPORTDOCS=true, please see log: 
http://people.freebsd.org/~pawel/buildlogs/7/chocolate-doom-1.6.0.log
Comment 5 Pawel Pekala freebsd_committer 2012-02-11 13:06:19 UTC
Responsible Changed
From-To: pawel->freebsd-ports-bugs

No submitter response, back to the pool
Comment 6 scheidell freebsd_committer 2012-03-21 14:32:55 UTC
State Changed
From-To: feedback->closed

New port submitter response timeout of more then 4 months.
Comment 7 jgh@FreeBSD.org freebsd_committer 2013-01-17 17:17:31 UTC
State Changed
From-To: closed->open

bringing this back to life... 


Comment 8 jgh@FreeBSD.org freebsd_committer 2013-01-17 17:17:31 UTC
Responsible Changed
From-To: freebsd-ports-bugs->jgh

bringing this back to life... 

http://www.freebsd.org/cgi/query-pr.cgi?pr=161701 

Date: Thu, 17 Jan 2013 23:50:33 +0100
Comment 9 jgh@FreeBSD.org freebsd_committer 2013-01-29 22:58:23 UTC
State Changed
From-To: open->closed

New port added, with minor changes. Thanks!
Comment 10 dfilter freebsd_committer 2013-01-29 22:58:25 UTC
Author: jgh
Date: Tue Jan 29 22:58:11 2013
New Revision: 311190
URL: http://svnweb.freebsd.org/changeset/ports/311190

Log:
  - add new port: games/chocolate-doom
  
  Chocolate Doom is a port of ID Software's Doom, Doom II, and Final Doom to
  modern operating systems that aims to be as compatible with the original DOS
  executable as possible. This includes emulating all the different versions,
  playing demos perfectly accurately, playing "vanilla-only" PWADS, and netcode
  that works on newer operating systems while still behaving the same as
  "vanilla" Doom.
  
  WWW: http://chocolate-doom.org
  
  PR:		161701
  Submitted by:	jakub_lach@mailplus.pl

Added:
  head/games/chocolate-doom/
  head/games/chocolate-doom/Makefile   (contents, props changed)
  head/games/chocolate-doom/distinfo   (contents, props changed)
  head/games/chocolate-doom/files/
  head/games/chocolate-doom/files/patch-d__iwad.c   (contents, props changed)
  head/games/chocolate-doom/pkg-descr   (contents, props changed)
  head/games/chocolate-doom/pkg-message   (contents, props changed)
  head/games/chocolate-doom/pkg-plist   (contents, props changed)
Modified:
  head/games/Makefile

Modified: head/games/Makefile
==============================================================================
--- head/games/Makefile	Tue Jan 29 22:39:14 2013	(r311189)
+++ head/games/Makefile	Tue Jan 29 22:58:11 2013	(r311190)
@@ -126,6 +126,7 @@
     SUBDIR += cgoban
     SUBDIR += chanta
     SUBDIR += chapping
+    SUBDIR += chocolate-doom
     SUBDIR += cheech
     SUBDIR += childsplay
     SUBDIR += childsplay_plugins

Added: head/games/chocolate-doom/Makefile
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/games/chocolate-doom/Makefile	Tue Jan 29 22:58:11 2013	(r311190)
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME=	chocolate-doom
+PORTVERSION=	1.7.0
+CATEGORIES=	games
+MASTER_SITES=	SF
+
+MAINTAINER=	jakub_lach@mailplus.pl
+COMMENT=	Doom port that aims to be compatible with the original exe
+
+LICENSE=	GPLv2
+
+USE_GMAKE=	yes
+USE_SDL=	mixer net sdl
+USE_PYTHON=	2.5+
+MAKE_JOBS_SAFE=	yes
+GNU_CONFIGURE=	yes
+
+MAN5=		chocolate-doom.cfg.5 default.cfg.5
+MAN6=		chocolate-doom.6 chocolate-server.6 chocolate-setup.6
+PORTDOCS=	CMDLINE ChangeLog HACKING INSTALL NEWS NOT-BUGS README README.OPL
+
+.include "${.CURDIR}/../doom-data/Makefile.include"
+
+.include <bsd.port.options.mk>
+
+post-patch-script:
+	${REINPLACE_CMD} -e 's|gamesdir = $$(prefix)/games|gamesdir = $$(prefix)/bin|' \
+		${WRKSRC}/src/Makefile.in ${WRKSRC}/setup/Makefile.in
+
+post-install:
+	${INSTALL_DATA} ${WRKSRC}/HACKING ${DOCSDIR}
+	@${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>

Added: head/games/chocolate-doom/distinfo
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/games/chocolate-doom/distinfo	Tue Jan 29 22:58:11 2013	(r311190)
@@ -0,0 +1,2 @@
+SHA256 (chocolate-doom-1.7.0.tar.gz) = c1cffb602e3cc3a82941b4675b9dc816a6e419076faf8f54db46df397f86bfc0
+SIZE (chocolate-doom-1.7.0.tar.gz) = 1091798

Added: head/games/chocolate-doom/files/patch-d__iwad.c
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/games/chocolate-doom/files/patch-d__iwad.c	Tue Jan 29 22:58:11 2013	(r311190)
@@ -0,0 +1,12 @@
+--- src/d_iwad.c	2011-05-17 16:01:48.000000000 -0700
++++ src/d_iwad.c	2011-10-15 11:30:26.998495197 -0700
+@@ -559,8 +559,7 @@
+ 
+     // Standard places where IWAD files are installed under Unix.
+ 
+-    AddIWADDir("/usr/share/games/doom");
+-    AddIWADDir("/usr/local/share/games/doom");
++    AddIWADDir("/usr/local/share/doom");
+ 
+ #endif
+ 

Added: head/games/chocolate-doom/pkg-descr
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/games/chocolate-doom/pkg-descr	Tue Jan 29 22:58:11 2013	(r311190)
@@ -0,0 +1,8 @@
+Chocolate Doom is a port of ID Software's Doom, Doom II, and Final Doom to
+modern operating systems that aims to be as compatible with the original DOS
+executable as possible. This includes emulating all the different versions,
+playing demos perfectly accurately, playing "vanilla-only" PWADS, and netcode
+that works on newer operating systems while still behaving the same as
+"vanilla" Doom.
+
+WWW: http://chocolate-doom.org

Added: head/games/chocolate-doom/pkg-message
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/games/chocolate-doom/pkg-message	Tue Jan 29 22:58:11 2013	(r311190)
@@ -0,0 +1,6 @@
+**************************************************************
+
+To enable OPL MIDI emulation you need to run chocolate-setup,
+default Native MIDI is very similar to Roland SC-55.
+
+**************************************************************

Added: head/games/chocolate-doom/pkg-plist
==============================================================================
--- /dev/null	00:00:00 1970	(empty, because file is newly added)
+++ head/games/chocolate-doom/pkg-plist	Tue Jan 29 22:58:11 2013	(r311190)
@@ -0,0 +1,11 @@
+share/icons/chocolate-doom.png
+share/icons/chocolate-setup.png
+share/applications/chocolate-doom.desktop
+share/applications/screensavers/chocolate-doom-screensaver.desktop
+share/applications/chocolate-setup.desktop
+bin/chocolate-doom
+bin/chocolate-server
+bin/chocolate-setup
+@dirrmtry share/icons
+@dirrmtry share/applications/screensavers
+@dirrmtry share/applications
_______________________________________________
svn-ports-all@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/svn-ports-all
To unsubscribe, send any mail to "svn-ports-all-unsubscribe@freebsd.org"